Page 14 of 24 FirstFirst ... 41213141516 ... LastLast
Results 131 to 140 of 236

Thread: Grub 2 Title Tweaks Thread

  1. #131
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Title Tweaks Thread

    @ alababi,

    If you still have a Grub menu, but only see the "Recovery mode" option, highlight it and press "e". This should display the recovery mode menu commands.

    Find the linux line - it should look something like this:
    linux /boot/vmlinuz-2.6.35-23-generic root=UUID=1c4adc10-a208-4373-b842-9851a8421da9 ro single
    Replace the word "single" with "quiet splash", then press CTRL-x to boot to the normal mode.
    linux /boot/vmlinuz-2.6.35-23-generic root=UUID=1c4adc10-a208-4373-b842-9851a8421da9 ro quiet splash
    If successful, delete the current /etc/grub.d/10_linux file and copy the 10_linux file posted by Agent.Logic_ or rename your backup file. To use a file browser as root, open nautilus with "gksu nautilus /etc/grub.d/"

    After replacing the 10_linux file, run:
    Code:
    sudo update-grub
    That should put things back the way they were.
    GRUB2

    Retired.

  2. #132
    Join Date
    Nov 2010
    Beans
    2

    Re: Grub 2 Title Tweaks Thread

    I am trying to get item 9 working (hide grub menu for a multi-OS system) but I have a different version of the 30_os-prober file. I am a new user and got this version of grub with my maverick install.

    The major change I see is the defninition of a "make_timeout" script before the "adjust_timeout" script. I don't read scriptesse and I tried making what I hoped would be equivalent changes to this new script but nothing seems to have happened.

    If I grab a copy of the old script and make the recommended changes will it mess anything up?

  3. #133
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Title Tweaks Thread

    Quote Originally Posted by weymouth View Post
    I am trying to get item 9 working (hide grub menu for a multi-OS system) but I have a different version of the 30_os-prober file. I am a new user and got this version of grub with my maverick install.

    The major change I see is the defninition of a "make_timeout" script before the "adjust_timeout" script. I don't read scriptesse and I tried making what I hoped would be equivalent changes to this new script but nothing seems to have happened.

    If I grab a copy of the old script and make the recommended changes will it mess anything up?
    Have you tried just setting the "GRUB_TIMEOUT" value in /etc/default/grub to 0 ? I find in Maverick that is all it takes (after running update-grub).

    If the "GRUB_TIMEOUT=0" does not work, does your system begin a countdown when the menu displays or does it await input from you? If there is no countdown it's possible that grub is detecting a 'recordfail' and will wait for input. We can change that behaviour as well but by a different method.

    For now, if the TIMEOUT setting doesn't work, open /etc/grub.d/00_header and go to approximately line 238:
    Code:
    gksu gedit +238 /etc/grub.d/00_header
    Find this section and make the changes in dark red, then save the file and run "sudo update-grub".
    make_timeout ()
    {
    cat << EOF
    if [ "\${recordfail}" = 1 ]; then
    set timeout=-1
    else

    # Manually change timeout to 0
    # set timeout=${2}
    set timeout=0
    # End manual change

    fi
    EOF
    }
    This should eliminate the menu display unless there is a "recordfail" event. It also preserves the ability to display the menu by holding down the SHIFT key during boot. Please let me know if this solution works for you.

    I'll update the initial instructions after I've determined what has changed with the G2 scripts.
    GRUB2

    Retired.

  4. #134
    Join Date
    Nov 2010
    Beans
    2

    Re: Grub 2 Title Tweaks Thread

    Either I was unclear in the question or I don't understand the answer.

    I don't want to bypass the grub menu, I want to hide it. So I want to boot the default OS unless I hold down the shift key, in which case the menu should come up allowing me to select the OS to boot.

    In my experimentation, setting the GRUB_TIMEOUT=0 doesn't hide the menu - it bypasses it. Even if I'm holding down the shift key I go to the default boot option. How can I choose the OS in this case?

    As way of explanation, this behavior is for a touch screen netbook. If I turn it on in tablet mode then I want win7 to come up without needing to type anything. (This also lets my family use the computer without having to wonder "what the $%&* is ubuntu?".) If I'm using the computer to ssh or something, then I will have the key board available and can hold down shift while booting to call up the grub menu.

  5. #135
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Title Tweaks Thread

    Quote Originally Posted by weymouth View Post
    Either I was unclear in the question or I don't understand the answer.
    We may be talking cross purposes. Here are the ways you should be able to get the grub menu to work:

    (Single OS) Set the grub hidden timeout value to a positive integer. The screen will be blank and you can press any key during the countdown and the menu will appear for the time specified in the grub timeout. If no key is pressed, the grub default is booted. Note that if grub timeout is 0 you will not see the menu even if you press a key during the hidden timeout (it activates the display, but it displays it for 0 seconds so you don't see it).

    If grub hidden timeout is not set or zero, the menu displays (on multiple-OS computers) for the value of grub timeout, then boots the default.

    Do you want a blank screen for a period of time before the system selects the default? Normally you would set the grub hidden timeout value to a positive number (or 0 for no delay at all) and set the grub timeout to 0. This sounds like what you want. The problem for you is that the way the 30_os-prober is written the hidden menu timeout options are limited to single OS systems. The script edits I recommend merely remove the condition that no other operating systems are found by 30_os-prober. (There are certain things such as a recordfail event that force the menu to appear.)

    In my experimentation, setting the GRUB_TIMEOUT=0 doesn't hide the menu - it bypasses it. Even if I'm holding down the shift key I go to the default boot option. How can I choose the OS in this case?
    Grub is never 'bypassed' per se. It always boots to the whatever it's told the default is. The default may be a name, a menuentry number, or the last used OS.
    There are times when the holding down the shift key doesn't work. This may be what you were trying to fix. If so, read on for a solution.

    The way the Grub2 developers set up the keystatus check limits its function to specific circumstances. We can change the conditionals but it's easiest to just make sure it's checked by adding it to 00_header. If holding the shift key isn't working when you want it to, you can copy the following to the end of the /etc/grub.d/00_header file so that it is always available.

    cat <<EOF
    if [ "x\${timeout}" != "x-1" ]; then
    if keystatus; then
    if keystatus --shift; then
    set timeout=-1
    else
    set timeout=0
    fi
    else
    if sleep$verbose --interruptible 3 ; then
    set timeout=0
    fi
    fi
    fi
    EOF
    Last edited by drs305; November 12th, 2010 at 12:22 PM. Reason: Revised and expanded explanation.
    GRUB2

    Retired.

  6. #136
    Join Date
    Sep 2009
    Beans
    44
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Grub 2 Title Tweaks Thread

    Quote Originally Posted by drs305 View Post
    7. CHANGING "Windows Recovery Environment (loader)" to "Windows Vista"
    or Any Other Windows Title in the 30_os-prober Section of grub.cfg
    Quote Originally Posted by drs305 View Post
    if [ "$LONGNAME" = "Windows Recovery Environment (loader)" ] && [ "${DEVICE}" = "/dev/sda1" ] ; then
    ${LONGNAME}="Windows Vista"
    fi
    The syntax above is incorrect; it causes an error in 30_os-prober, which then fails to create any Windows entry in grub.cfg.

    The following code works:

    if [ "$LONGNAME" = "Windows Recovery Environment (loader)" ] && [ "${DEVICE}" = "/dev/sda1" ] ; then
    LONGNAME="Windows Vista"
    fi
    Thanks for this tutorial. It solved my problem.

  7. #137
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Title Tweaks Thread

    Quote Originally Posted by sweetleaf View Post
    The syntax above is incorrect; it causes an error in 30_os-prober, which then fails to create any Windows entry in grub.cfg.

    Thanks for this tutorial. It solved my problem.
    Thanks. Somewhere I messed it up during a revision update. Fixed.
    GRUB2

    Retired.

  8. #138
    n.hinton is offline Gee! These Aren't Roasted!
    Join Date
    Nov 2008
    Location
    North Norfolk, UK
    Beans
    169
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Grub 2 Title Tweaks Thread

    Grub2 boots windows 98 in dos compatibility mode.

    Have win98se on secondary master as it fully supports some devices Ubuntu doesn't (Aries scan it pro, pci smart modem, Lexmark printer/scanner x2250), Lucid is on primary master. Grub seamlessly booted windows using menu.lst entry:

    Code:
    title		Windows 95/98/Me
    rootnoverify	(hd1,0)
    savedefault
    makeactive
    chainloader	+1
    map (hd0) (hd1)
    map (hd1) (hd0)
    Have updated grub to grub2 and cannot get it to boot windows without dos compatibility mode (which is no good for 2 of the above devices), it is not overwriting the secondary master's mbr, it just appears that way when booting from grub2 menu. Disabling primary master in CMOS setup, has windows boot normally.

    The 30_os-prober generates:

    Code:
    ### BEGIN /etc/grub.d/30_os-prober ###
    Found Windows 95/98/Me on /dev/sdb1
    menuentry "Windows 95/98/Me (on /dev/sdb1)" {
    	insmod fat
    	set root='(hd1,1)'
    	search --no-floppy --fs-uuid --set 2d27-07ee
    	drivemap -s (hd0) ${root}
    	chainloader +1
    }
    ### END /etc/grub.d/30_os-prober ###
    Which fails as above (dos compatibility mode), as does 40_custom, with all the permutations I've tried so far, like:

    Code:
    ### BEGIN /etc/grub.d/40_custom ###
    menuentry "Microsoft Windows" {
    	insmod fat
    	set root=(hd1,1)
    	chainloader +1
    	drivemap -s hd0 hd1
    }
    ### END /etc/grub.d/40_custom ###
    and have experimented with parttool and load_env/save_env, without success and am wondering if the problem is rootnoverify not being supported.

    Would be grateful if anyone knows a configuration that works, as using CMOS/BIOS setup to boot windows is a pain.
    Last edited by n.hinton; November 24th, 2010 at 05:51 PM.

  9. #139
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub 2 Title Tweaks Thread

    @ n.hinton

    I have almost no experience with Windows and G2, but try something along these lines:

    menuentry “Microsoft Windows” {
    drivemap (hd0) (hd1)
    drivemap (hd1) (hd0)
    set root=(hd0)
    chainloader (hd1,1)+1
    }
    GRUB2

    Retired.

  10. #140
    n.hinton is offline Gee! These Aren't Roasted!
    Join Date
    Nov 2008
    Location
    North Norfolk, UK
    Beans
    169
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Grub 2 Title Tweaks Thread

    Hi drs305,

    Just ran that, double checked it was in grub.cfg (yes it was) but grub2 will not display that configuration as a menu item.

Page 14 of 24 FirstFirst ... 41213141516 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •