Page 11 of 12 FirstFirst ... 9101112 LastLast
Results 101 to 110 of 115

Thread: GRUB 2 Introduction

  1. #101
    Join Date
    Oct 2006
    Beans
    36

    Re: GRUB 2 Introduction

    Quote Originally Posted by drs305 View Post
    That happened because "update-grub" would have reset the value back to -1.

    The only thing I can think of it to go through and select every item in your menu. If they work, perhaps it will reset the value of whatever is making the recordfail -1. That, as they say, is just a WAG.

    I tried loading an incorrect splash image to see if that would freeze the menu, but it didn't. It just booted to the mono background.

    I'm going to play around in a VM to see if I can duplicate it.
    I gave it a shot and tried all the options from the boot screen (recovery mode, 2 memtest86+), but still no change. I ran update-grub again too.

    I guess I'll move on to my printing issue now. If you all have any other suggestions, I'd love to hear them

    Thanks again for all the help!

  2. #102
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: GRUB 2 Introduction

    Well, the onlything that I can think of is to get rid of the;
    cat << EOF
    if [ \${recordfail} = 1 ]; then
    set timeout=-1
    else
    set timeout=${GRUB_TIMEOUT}
    fi
    EOF
    part of your 00_header file (/etc/grub.d/00_header).

    We know from the stuff that drs305 had you run that the lack of that in your menuentry does not hose your boot, and that you get a 3 second timeout on your menu.

    I would hash out that whole section like so;
    [code]
    cat << EOF
    ## if [ \${recordfail} = 1 ]; then
    ## set timeout=-1
    ## else
    ## set timeout=${GRUB_TIMEOUT}
    ## fi
    ## EOF
    [code]
    and see what happens.
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

  3. #103
    Join Date
    Oct 2006
    Beans
    36

    Unhappy Re: GRUB 2 Introduction

    Quote Originally Posted by ranch hand View Post
    Well, the onlything that I can think of is to get rid of the;

    part of your 00_header file (/etc/grub.d/00_header).

    We know from the stuff that drs305 had you run that the lack of that in your menuentry does not hose your boot, and that you get a 3 second timeout on your menu.

    I would hash out that whole section like so;
    [code]
    cat << EOF
    ## if [ \${recordfail} = 1 ]; then
    ## set timeout=-1
    ## else
    ## set timeout=${GRUB_TIMEOUT}
    ## fi
    ## EOF
    [code]
    and see what happens.
    Thanks for taking the time to help ranch hand!

    I'm sorry to report, but it didn't make a bit of difference. I made the change, did sudo update-grub, rebooted, and after waiting about a minute at the grub2 menu I hit enter, and ...

    I put the 00_header file back the way it was, just in case.

    Any other ideas would be greatly appreciated!

    (I'm not having any luck w/ my cups or touchpad issues either )

  4. #104
    Join Date
    Feb 2005
    Location
    Poland
    Beans
    93
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: GRUB 2 Introduction

    good introduction ok, but I used to put 'apci=off' to menu.lst, where can I turn it off now?

  5. #105
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: GRUB 2 Introduction

    Quote Originally Posted by Paool View Post
    good introduction ok, but I used to put 'apci=off' to menu.lst, where can I turn it off now?
    If you want it in normal boots, open /etc/default/grub:
    Code:
    gksudo gedit /etc/default/grub
    Change this line (acpi=off to it if you already have "quite" and/or "splash"). Adding it to this line will cause normal boots to start with this option:
    GRUB_CMDLINE_LINUX_DEFAULT="acpi=off"
    Save the file, then run:
    Code:
    sudo update-grub
    GRUB2

    Retired.

  6. #106
    Join Date
    Feb 2005
    Location
    Poland
    Beans
    93
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: GRUB 2 Introduction

    works like a charm now, thank you very much!

  7. #107
    Join Date
    Oct 2006
    Beans
    36

    Re: GRUB 2 Introduction

    Does anyone know whether it's possible that a future update will fix my grub2 boot menu issues?

    I'm still really bummed that we can't fix this.

    I'm not having any luck squashing my other bugs either

    Any help would be greatly appreciated.

    thx

  8. #108
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: GRUB 2 Introduction

    Grub 1.97 has been released. We are using 1.97beta4.

    I am not sure what the change log is, I thought I had it bookmarked. It will probably be one of the early updates after release of 9.10.

    If you filed the bug report, at least the Ubuntu devs know about the issue. It might be good to file with the grub devs too.

    I hope the update fixes your problems. There are still several with grrub2.

    The priority is probably the improvement of os-prober performance.
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

  9. #109
    Join Date
    Dec 2005
    Beans
    1,171
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: GRUB 2 Introduction

    Quote Originally Posted by ranch hand View Post
    I am not sure what the change log is, I thought I had it bookmarked. It will probably be one of the early updates after release of 9.10.
    Announcement

    Changelog

  10. #110
    Join Date
    Apr 2008
    Location
    Southern California, USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: GRUB 2 Introduction

    Quote Originally Posted by kstarkey1 View Post
    ...I'm still really bummed that we can't fix this...
    So your problem is that once you turn on your pc and presented with a grub2 menu, there is no count down timer to boot the default partition, correct?

    output
    Code:
    sudo fdisk -l
    and
    Code:
    sudo blkid
    I know this may have nothing to do with anything, but just complete the picture. I feel your frustration. Also, you may have mentioned this before, but have you have any OS installed and any quirks with them?
    boot_info_script | AMD64 Athlon X2 Dual-Core - nVidia Geforce 6150 SE - 4GB DDR3

Page 11 of 12 FirstFirst ... 9101112 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •