Page 10 of 12 FirstFirst ... 89101112 LastLast
Results 91 to 100 of 115

Thread: GRUB 2 Introduction

  1. #91
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: GRUB 2 Introduction

    Quote Originally Posted by kstarkey1 View Post
    Ever since this morning the grub2 menu appears and if I go away for > 30 minutes it's still there when I come back (not sure how long it's set for). How can I get it to take the first entry and go with it. If I hit the enter key everythings cool. I just want it to show the grub2 screen for a ~3 seconds and then go with the first entry.
    Open /etc/default/grub for editing as root:
    Code:
    gksudo gedit /etc/default/grub
    Make it look like the following:
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=3
    Leave the "DEFAULT=" line with whatever it is currently set to if it is defaulting to what you want.

    After saving the changes:
    Code:
    sudo update-grub
    GRUB2

    Retired.

  2. #92
    Join Date
    Oct 2006
    Beans
    36

    Re: GRUB 2 Introduction

    Quote Originally Posted by drs305 View Post
    Open /etc/default/grub for editing as root:
    Code:
    gksudo gedit /etc/default/grub
    Make it look like the following:


    Leave the "DEFAULT=" line with whatever it is currently set to if it is defaulting to what you want.

    After saving the changes:
    Code:
    sudo update-grub
    Thanks for the help drs305, but that didn't fix it. I made the change, ran sudo update-grub, and rebooted to test it out. Same as before.

    Here's what's in my /etc/default/grub file:

    Code:
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=3
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    Anything else I can try?

    Thanks,

  3. #93
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: GRUB 2 Introduction

    Quote Originally Posted by kstarkey1 View Post
    Anything else I can try?
    There is a section in /boot/grub/grub.cfg about "recordfail" and if the value is "-1" then the menu won't advance automatically. The "recordfail" is also generated in the /etc/grub.d/10_linux entry.

    A possibility is that at the value is 'stuck' on one.

    There could be a much simpler explanation and I hesitate to give you instructions on how to disassemble the watch when all it needs is to be wound up! But here it goes anyway.

    If you would like to briefly tinker to see if this is the cause, you could run this and see if it boots. I wouldn't leave it there permanently, just if you are curious.

    Code:
    sudo sed 's/timeout=-1/timeout=3/g' -i /boot/grub/grub.cfg
    This is strictly an exercise. It won't mess up your boot but is not a permanent solution. You can reset the value by running "sudo update-grub".
    GRUB2

    Retired.

  4. #94
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: GRUB 2 Introduction

    This is real interesting.

    Is your menu still visible?

    With only one OS on your box it should never have been visible. So, the first thing to do is;
    Code:
    ubuntu-bug grub2
    and follow the directions.

    How about showing us your /boot/grub/grub.cfg file. It should have all that information in it and it sounds like it doesn't.

    Just for fun, try running;
    Code:
    sudo grub-mkconfig
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

  5. #95
    Join Date
    Aug 2008
    Location
    South East Montana
    Beans
    6,153

    Re: GRUB 2 Introduction

    Quote Originally Posted by drs305 View Post
    There is a section in /boot/grub/grub.cfg about "recordfail" and if the value is "-1" then the menu won't advance automatically. The "recordfail" is also generated in the /etc/grub.d/10_linux entry.

    A possibility is that at the value is 'stuck' on one.

    There could be a much simpler explanation and I hesitate to give you instructions on how to disassemble the watch when all it needs is to be wound up! But here it goes anyway.

    If you would like to briefly tinker to see if this is the cause, you could run this and see if it boots. I wouldn't leave it there permanently, just if you are curious.

    Code:
    sudo sed 's/timeout=-1/timeout=3/g' -i /boot/grub/grub.cfg
    This is strictly an exercise. It won't mess up your boot but is not a permanent solution. You can reset the value by running "sudo update-grub".
    You may be on to something here.

    It sure acts stuck on something.
    Dell 480 XPS 3G ram Quad Core 2.40GHz, Radeon HD 2400 PRO, Audigy1, 3x320G HDD, 320G External, Debian Testing for use, Debian Squeeze for secure use, Debian Sid for FUN

  6. #96
    Join Date
    Oct 2006
    Beans
    36

    Re: GRUB 2 Introduction

    Quote Originally Posted by ranch hand View Post
    This is real interesting.

    Is your menu still visible?
    It's still visible (see here): http://twitpic.com/n5ivk

    Here's my /boot/default/grub.cfg
    Code:
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by /usr/sbin/grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #
    
    ### BEGIN /etc/grub.d/00_header ###
    if [ -s /boot/grub/grubenv ]; then
      have_grubenv=true
      load_env
    fi
    set default="0"
    if [ ${prev_saved_entry} ]; then
      saved_entry=${prev_saved_entry}
      save_env saved_entry
      prev_saved_entry=
      save_env prev_saved_entry
    fi
    insmod ext2
    set root=(hd0,1)
    search --no-floppy --fs-uuid --set f973cc35-65c0-4b83-b71b-3484e63643d1
    if loadfont /usr/share/grub/unicode.pf2 ; then
      set gfxmode=640x480
      insmod gfxterm
      insmod vbe
      if terminal_output gfxterm ; then true ; else
        # For backward compatibility with versions of terminal.mod that don't
        # understand terminal_output
        terminal gfxterm
      fi
    fi
    if [ ${recordfail} = 1 ]; then
      set timeout=-1
    else
      set timeout=3
    fi
    ### END /etc/grub.d/00_header ###
    
    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight=black/white
    ### END /etc/grub.d/05_debian_theme ###
    
    ### BEGIN /etc/grub.d/10_linux ###
    menuentry "Ubuntu, Linux 2.6.31-14-generic" {
            recordfail=1
            if [ -n ${have_grubenv} ]; then save_env recordfail; fi
    	set quiet=1
    	insmod ext2
    	set root=(hd0,1)
    	search --no-floppy --fs-uuid --set f973cc35-65c0-4b83-b71b-3484e63643d1
    	linux	/boot/vmlinuz-2.6.31-14-generic root=UUID=f973cc35-65c0-4b83-b71b-3484e63643d1 ro   quiet splash
    	initrd	/boot/initrd.img-2.6.31-14-generic
    }
    menuentry "Ubuntu, Linux 2.6.31-14-generic (recovery mode)" {
            recordfail=1
            if [ -n ${have_grubenv} ]; then save_env recordfail; fi
    	insmod ext2
    	set root=(hd0,1)
    	search --no-floppy --fs-uuid --set f973cc35-65c0-4b83-b71b-3484e63643d1
    	linux	/boot/vmlinuz-2.6.31-14-generic root=UUID=f973cc35-65c0-4b83-b71b-3484e63643d1 ro single 
    	initrd	/boot/initrd.img-2.6.31-14-generic
    }
    ### END /etc/grub.d/10_linux ###
    
    ### BEGIN /etc/grub.d/20_memtest86+ ###
    menuentry "Memory test (memtest86+)" {
    	linux16	/boot/memtest86+.bin
    }
    menuentry "Memory test (memtest86+, serial console 115200)" {
    	linux16	/boot/memtest86+.bin console=ttyS0,115200n8
    }
    ### END /etc/grub.d/20_memtest86+ ###
    
    ### BEGIN /etc/grub.d/30_os-prober ###
    ### END /etc/grub.d/30_os-prober ###
    
    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    ### END /etc/grub.d/40_custom ###
    I'll try running those command you suggested next

  7. #97
    Join Date
    Oct 2006
    Beans
    36

    Re: GRUB 2 Introduction

    Quote Originally Posted by drs305 View Post
    There is a section in /boot/grub/grub.cfg about "recordfail" and if the value is "-1" then the menu won't advance automatically. The "recordfail" is also generated in the /etc/grub.d/10_linux entry.

    A possibility is that at the value is 'stuck' on one.

    There could be a much simpler explanation and I hesitate to give you instructions on how to disassemble the watch when all it needs is to be wound up! But here it goes anyway.

    If you would like to briefly tinker to see if this is the cause, you could run this and see if it boots. I wouldn't leave it there permanently, just if you are curious.

    Code:
    sudo sed 's/timeout=-1/timeout=3/g' -i /boot/grub/grub.cfg
    This is strictly an exercise. It won't mess up your boot but is not a permanent solution. You can reset the value by running "sudo update-grub".
    Thanks drs305!

    This kinda worked. I still saw the grub2 boot menu (I suppose I'm not even supposed to be seeing this??), and it stayed on screen for ~3 seconds,

    So what do you think this means then?

  8. #98
    Join Date
    Oct 2006
    Beans
    36

    Re: GRUB 2 Introduction

    Quote Originally Posted by ranch hand View Post
    This is real interesting.

    Is your menu still visible?

    With only one OS on your box it should never have been visible. So, the first thing to do is;
    Code:
    ubuntu-bug grub2
    and follow the directions.

    How about showing us your /boot/grub/grub.cfg file. It should have all that information in it and it sounds like it doesn't.

    Just for fun, try running;
    Code:
    sudo grub-mkconfig
    Ok, I submitted a bug report for this.

    And I just ran sudo grub-mkconfig. I guess I'll reboot and see it that did anything.

  9. #99
    Join Date
    Oct 2006
    Beans
    36

    Re: GRUB 2 Introduction

    Well, rebooted, but nothing seems to have changed. It booted to the grub2 menu and just sat there waiting for me to hit enter.

    Any thoughts?

    Thanks,

  10. #100
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: GRUB 2 Introduction

    Quote Originally Posted by kstarkey1 View Post
    Well, rebooted, but nothing seems to have changed. It booted to the grub2 menu and just sat there waiting for me to hit enter.

    Any thoughts?

    Thanks,
    That happened because "update-grub" would have reset the value back to -1.

    The only thing I can think of it to go through and select every item in your menu. If they work, perhaps it will reset the value of whatever is making the recordfail -1. That, as they say, is just a WAG.

    I tried loading an incorrect splash image to see if that would freeze the menu, but it didn't. It just booted to the mono background.

    I'm going to play around in a VM to see if I can duplicate it.
    Last edited by drs305; October 27th, 2009 at 06:59 PM.
    GRUB2

    Retired.

Page 10 of 12 FirstFirst ... 89101112 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •