Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Desktop effects cannot be enabled when Gnome-Do has started

  1. #1
    Join Date
    Aug 2005
    Location
    Groningen, The Netherland
    Beans
    194
    Distro
    Ubuntu 10.04 Lucid Lynx

    Desktop effects cannot be enabled when Gnome-Do has started

    Hi Everyone,

    I'm pretty sure that when I first installed Karmic on my EEEpc 904HA with integrated 945 GME graphics chip, Compiz worked just fine.

    However, I just installed Gnome-Do, and everything seemed to be working fine for a moment. But then ... I restared the computer.

    Now I just came to the conclusion that Compiz apparently crashes with Gnome-Do. Is anybody else experiencing this problem?

    How can I best determine this problem for a bug-report?
    "All of your base are belong to us!"

  2. #2
    Join Date
    Oct 2005
    Beans
    62

    Re: Desktop effects cannot be enabled when Gnome-Do has started

    I'm not sure it is related to gnome do. I'm having the same problem with the same card, but when I disable gnome do it still happens. Furthermore, everything is just slow right now.

  3. #3
    Join Date
    Sep 2009
    Beans
    8,874
    Distro
    Ubuntu Development Release

    Re: Desktop effects cannot be enabled when Gnome-Do has started

    On Karmic, Gnome-Do the PPA version comes up as a black square that is unreadable, and the auto-scroll icon in Firefox is just a black dot although it works. The graphics stuff is probably not set up yet.

  4. #4
    Join Date
    Aug 2005
    Location
    Groningen, The Netherland
    Beans
    194
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Desktop effects cannot be enabled when Gnome-Do has started

    I don't know what the problem is. I thought I had it, but I haven't experienced any problems since doing the following.

    - Start up Karmic.
    - Remove Gnome-Do from the Startup Applications list.
    - Restart Karmic.
    - Gnome-Do doesn't start, and now it is possible to enable (all) desktop effects.
    - Put Gnome-Do back in the Startup Applications.
    - After Reboot, I haven't encountered any problems.

    (I have to admit I'm a little bit hesitant to recreate the problem
    "All of your base are belong to us!"

  5. #5
    Join Date
    Aug 2005
    Location
    Groningen, The Netherland
    Beans
    194
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Desktop effects cannot be enabled when Gnome-Do has started

    Quote Originally Posted by Maupertus View Post
    I don't know what the problem is. I thought I had it, but I haven't experienced any problems since doing the following.

    - Start up Karmic.
    - Remove Gnome-Do from the Startup Applications list.
    - Restart Karmic.
    - Gnome-Do doesn't start, and now it is possible to enable (all) desktop effects.
    - Put Gnome-Do back in the Startup Applications.
    - After Reboot, I haven't encountered any problems.

    (I have to admit I'm a little bit hesitant to recreate the problem
    And alas, this doesn't work every time.... grrr
    "All of your base are belong to us!"

  6. #6
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Desktop effects cannot be enabled when Gnome-Do has started

    I don't use Gnome-Do but I reckon it uses some form of transparency. If Compiz isn't running it most probably enables Metacity's transparency, which isn't compatible with Compiz (Metacity is GNOME's default window manager).

    Next time Compiz can't be enabled, use this to check why that is: http://forlong.blogage.de/entries/pages/Compiz-Check

  7. #7
    Join Date
    Dec 2007
    Location
    green bay, wi
    Beans
    2,187
    Distro
    Lubuntu 14.04 Trusty Tahr

    Lightbulb Re: Desktop effects cannot be enabled when Gnome-Do has started

    i have the same problem and all my updates are current

  8. #8
    Join Date
    Dec 2007
    Location
    New York, NY
    Beans
    92
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Desktop effects cannot be enabled when Gnome-Do has started

    This happened to me too. I had to do a
    sudo dpkg-reconfigure -phigh xorg-server
    and reboot. That made desktop effects work again and the desktop no longer very very slow.

  9. #9
    Join Date
    Aug 2005
    Location
    Groningen, The Netherland
    Beans
    194
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Desktop effects cannot be enabled when Gnome-Do has started

    Well, I have been playing around for the lesser part of a week and it's strange but I have to start compiz manually from terminal. After I've entered "compiz" without even closing Gnome-Do, everything works fine and fast.

    If I want to enable compiz via the appearance menu, it only works after terminating gnome-do and metacity in the system manager.

    Now, although this isn't a real deal breaker, it would be great if this wasn't necessary. So, how do I discover the reason of this strange bug?
    "All of your base are belong to us!"

  10. #10
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: Desktop effects cannot be enabled when Gnome-Do has started

    install and run 'fusion-icon'
    this gives you a nice icon on the panel to control compiz emerald etc...
    you can also set it up in the startup programs.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •