Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: network service discovery disabled

  1. #1
    Join Date
    Jan 2006
    Beans
    310

    network service discovery disabled

    I keep getting this message when I log in. Something about '.local' domain.

    Any ideas how to fix it?

    I searched, but my results seem to suggest there is a 'network' item on the 'System/Administration' menu, which there isn't - I guess they were using an older version of Ubuntu (I'm on 9.04).

    Max.

  2. #2
    Join Date
    Mar 2005
    Location
    York, UK
    Beans
    1,811

    Re: network service discovery disabled

    This notification is informing you that mDNS (Avahi) has been disabled. It's only used for a small number of applications that only work on the local network, it won't adversely affect your Internet connection or DNS.

    The most well known use for mDNS is sharing music with Rhythmbox (or iTunes) over your LAN. It's an Apple technology, but it's largely been ignored in favour of uPNP or DLNA.

    If you haven't seen it already then you might want to read this page.
    http://avahi.org/wiki/AvahiAndUnicastDotLocal
    UP Team member

  3. #3
    Join Date
    Jan 2006
    Beans
    310

    Re: network service discovery disabled

    Quote Originally Posted by spd106 View Post
    This notification is informing you that mDNS (Avahi) has been disabled. It's only used for a small number of applications that only work on the local network, it won't adversely affect your Internet connection or DNS.

    The most well known use for mDNS is sharing music with Rhythmbox (or iTunes) over your LAN. It's an Apple technology, but it's largely been ignored in favour of uPNP or DLNA.

    If you haven't seen it already then you might want to read this page.
    http://avahi.org/wiki/AvahiAndUnicastDotLocal
    OK. All very interesting, but what do I do to make the warning go away - permanently? As far as I can tell, I don't care about any of this stuff.

    Max.

  4. #4
    Join Date
    Nov 2008
    Location
    Brazil
    Beans
    309
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: network service discovery disabled

    Yes, I'm having this warning too, although not at every boot it seems.
    Does it means that avahi is already disabled? Or has it been disabled by some other process?
    Anyway, it's by no means a big issue but I would be interested to know also how to disable this warning (since I'm not looking forward to use the avahi service).
    (9.10)

  5. #5
    Join Date
    Mar 2005
    Location
    York, UK
    Beans
    1,811

    Re: network service discovery disabled

    You should be able to disable Avahi completely by opening System -> Administration -> Servies and unticking "Multicast DNS service discovery".

    These instructions only work on GNOME, I'm not sure how you would do this with KDE or XFCE.
    UP Team member

  6. #6
    Join Date
    Jan 2006
    Beans
    310

    Re: network service discovery disabled

    Quote Originally Posted by spd106 View Post
    You should be able to disable Avahi completely by opening System -> Administration -> Servies and unticking "Multicast DNS service discovery".

    These instructions only work on GNOME, I'm not sure how you would do this with KDE or XFCE.
    Thanks...that's what I was after

    Max.

  7. #7
    Join Date
    Jul 2008
    Location
    BKK, TH
    Beans
    66
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: network service discovery disabled

    Thanks, spd106. Your explanation was directly to the point and informative. However, since I upgraded to Karmic, I couldn't find "Services" under any of the System's sub-menu. I remember that I used to see and access that dialog before the upgrade. Please help me get it back to the menu.

  8. #8
    Join Date
    Jan 2009
    Beans
    16

    Re: network service discovery disabled

    This Problem also affects me on Ubuntu 9.10.
    I can't find where to disable the Multicast mdns discovery.

  9. #9
    Join Date
    Jan 2010
    Beans
    2

    Re: network service discovery disabled

    Hi,

    you can try:

    sudo stop avahi-daemon
    sudo sed -e '/^start/,+1s/^/#/' /etc/init/avahi-daemon.conf

    or you just go to /etc/init/ and edit the avahi-deamon.conf manually and comment out the following two lines:

    #start on (filesystem
    # and started dbus)


    here you can find more info: http://wiki.ubuntu.com/KarmicKoala/R...20is%20present

    Hope this helps!

  10. #10
    Join Date
    May 2009
    Location
    Russia, Moscow
    Beans
    119
    Distro
    Ubuntu

    Re: network service discovery disabled

    This didn't help me, I commented out those lines, restarted computer but every Wi-Fi connection starts, I see that irritating notification.

    UPD. FIXED.

    from this thread: http://ubuntuforums.org/showthread.php?t=1339516

    > Changing AVAHI_DAEMON_DETECT_LOCAL=1 to AVAHI_DAEMON_DETECT_LOCAL=0 in /etc/default/avahi-daemon has got rid of the irritating pop-up.
    Last edited by aneganov; March 2nd, 2010 at 07:30 PM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •