Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Stop Tor from autorunning

  1. #1
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    21
    Distro
    Ubuntu 9.10 Karmic Koala

    Stop Tor from autorunning

    This isn't so much a problem as an annoyance: Tor autoruns when I start up my machine, and Privoxy can't control Tor if it's already running.

    I've been able to work around this by using
    Code:
    sudo killall tor
    in the terminal, but that's a temporary fix. I want to set it so Tor doesn't start a process until Vidalia tells it to.
    I've read about sysv-rc-conf and from what I gather I think it can help me get what I want. However, I don't understand what the runlevels mean. (When I run sysv-rc-conf Tor is checked on levels 2 3 4 and 5.) Could someone help me figure out how to do this through sysv-rc-conf, or tell me another way to disable autorun on startup for Tor?

    tl;dr I want Tor to only run when I tell it to, through Vidalia.

  2. #2
    Join Date
    Jan 2008
    Location
    Argentina
    Beans
    755
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Stop Tor from autorunning

    why don't you make a script like this:

    Code:
    #!/bin/bash
    
    killall tor
    save it and make it run at startup in preferences.

    (I don't usually sudo the command killall, but it depends on the circumstances)

    surely there is a better way, this is just a workaround
    AMD Phenom II X3 720 Black Edition 2,8 GHz - GIGABYTE GA-MA770T-UD3P - 6 GB RAM Mushkin DDR3 1333 - ZOTAC GeForce 9800 GT 1 GB DDR3

  3. #3
    Join Date
    Aug 2006
    Beans
    1,374
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Stop Tor from autorunning

    T.R. runs TOR in a relay? You can easily stop this via Vidalia.

  4. #4
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    21
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Stop Tor from autorunning

    I'm not running it in a relay. It just runs on its own at startup.

  5. #5
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    21
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Stop Tor from autorunning

    bruno: I tried the script it didn't seem to work. I think Tor might autorun just after startup, or it's lower priority than the autorun script.

    It also seems I have to sudo killall with Tor. If I don't bash gives me an Operation not permitted message. I'll try adding sudo to the script to see if that changes anything.

    Edit: adding sudo to the script didn't make it work.

    If I can figure out sysv-rc-conf I could probably keep it from running at startup to begin with...
    Last edited by T.R.; September 28th, 2009 at 08:33 AM. Reason: sudo didn't change anything.

  6. #6
    Join Date
    Jan 2008
    Location
    Argentina
    Beans
    755
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Stop Tor from autorunning

    I am going to try and install tor tonite, to see where it ends up.

    You could also check if it is from the services menu that you control it's behavior
    AMD Phenom II X3 720 Black Edition 2,8 GHz - GIGABYTE GA-MA770T-UD3P - 6 GB RAM Mushkin DDR3 1333 - ZOTAC GeForce 9800 GT 1 GB DDR3

  7. #7
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    21
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Stop Tor from autorunning

    Bootup manager (bum) fixed it.

  8. #8

    Re: Stop Tor from autorunning

    How did you manage to do that with bum?

    I have been trying to do the same thing for the last 3 days with no success. I managed to stop tor from starting on startup with bum but then when Vidalia starts it gives me the error message "[Warning] If you set the "User" option, you must start Tor as root.".

  9. #9
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    21
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Stop Tor from autorunning

    I just unchecked the box for Tor, and it worked.

    EDIT: if bum isn't working, type
    Code:
    sudo sysv-rc-conf
    in terminal, go down to tor, and toggle off all the runlevels for tor.
    Last edited by T.R.; November 25th, 2009 at 08:23 AM. Reason: provide alternative solution

  10. #10
    Join Date
    Nov 2009
    Beans
    Hidden!

    Re: Stop Tor from autorunning

    This command always removes TOR from the start-up for me:

    Code:
    sudo update-rc.d -f tor remove

    But also note that when TOR updates to a new version it does re-add its self to the start-up and I have to run the command again.

    It's really too bad this is TORs default setting. I think it should be the other way around.


    For Privoxy:

    Code:
    sudo update-rc.d -f privoxy remove

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •