Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Stop Tor from autorunning

  1. #11
    Join Date
    May 2009
    Location
    Austin, TX
    Beans
    21
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Stop Tor from autorunning

    On my machine Privoxy is set to autorun and it works fine. It might just be the settings and packages on my machine, but I don't think it matters except for maybe a slightly better boot time with it off.

  2. #12
    Join Date
    Apr 2006
    Beans
    85
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Stop Tor from autorunning

    Quote Originally Posted by leoquant View Post
    T.R. runs TOR in a relay? You can easily stop this via Vidalia.
    Vidalia cannot stop or otherwise control TOR unless it started it. And of course it can't start it if it is already started. It's kind of annoying.
    Quote Originally Posted by anonymous admin
    root is a flying nuclear buzzsaw
    GETFIXED: Video BadAlloc crashes! Turn ON the error beep! Get 64 bit Flash! Fix mplayer!

  3. #13
    Join Date
    Apr 2006
    Beans
    85
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Stop Tor from autorunning

    Quote Originally Posted by anonSam View Post
    This command always removes TOR from the start-up for me:

    Code:
    sudo update-rc.d -f tor remove

    But also note that when TOR updates to a new version it does re-add its self to the start-up and I have to run the command again.

    It's really too bad this is TORs default setting. I think it should be the other way around.


    For Privoxy:

    Code:
    sudo update-rc.d -f privoxy remove
    Or at the very least, if you install Vidalia Tor should get removed from startup. Or the Vidalia people should figure out what magic is required to control an already running Tor or restart it through their GUI.
    Quote Originally Posted by anonymous admin
    root is a flying nuclear buzzsaw
    GETFIXED: Video BadAlloc crashes! Turn ON the error beep! Get 64 bit Flash! Fix mplayer!

  4. #14
    Join Date
    Apr 2006
    Beans
    85
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Stop Tor from autorunning

    Quote Originally Posted by anonSam View Post
    This command always removes TOR from the start-up for me:

    Code:
    sudo update-rc.d -f tor remove

    But also note that when TOR updates to a new version it does re-add its self to the start-up and I have to run the command again.

    It's really too bad this is TORs default setting. I think it should be the other way around.


    For Privoxy:

    Code:
    sudo update-rc.d -f privoxy remove
    I read the manpage for update-rc.d .. what it does is manipulate the links under /etc/rc0.d .. if you do remove it deletes the links, but that means that when you upgrade the package again the links will get put back. What you need to do is change the S in front of the link name to a K. update-rc.d will do this for you if you do "disable" instead of remove, and the next time you upgrade update-rc.d will see there are links there and leave that alone.

    Code:
    $ sudo update-rc.d tor disable
    update-rc.d: warning: tor start runlevel arguments (none) do not match LSB Default-Start values (2 3 4 5)
    update-rc.d: warning: tor stop runlevel arguments (none) do not match LSB Default-Stop values (0 1 6)
     Disabling system startup links for /etc/init.d/tor ...
     Removing any system startup links for /etc/init.d/tor ...
       /etc/rc0.d/K20tor
       /etc/rc1.d/K20tor
       /etc/rc2.d/S20tor
       /etc/rc3.d/S20tor
       /etc/rc4.d/S20tor
       /etc/rc5.d/S20tor
       /etc/rc6.d/K20tor
     Adding system startup for /etc/init.d/tor ...
       /etc/rc0.d/K20tor -> ../init.d/tor
       /etc/rc1.d/K20tor -> ../init.d/tor
       /etc/rc6.d/K20tor -> ../init.d/tor
       /etc/rc2.d/K80tor -> ../init.d/tor
       /etc/rc3.d/K80tor -> ../init.d/tor
       /etc/rc4.d/K80tor -> ../init.d/tor
       /etc/rc5.d/K80tor -> ../init.d/tor
    Quote Originally Posted by anonymous admin
    root is a flying nuclear buzzsaw
    GETFIXED: Video BadAlloc crashes! Turn ON the error beep! Get 64 bit Flash! Fix mplayer!

  5. #15
    Join Date
    Apr 2010
    Beans
    1

    Re: Stop Tor from autorunning

    thanks for this info.

    regards
    Swastik bhargava
    Excel combines
    MeritVCO extra virgin coconut oil

  6. #16
    Join Date
    Apr 2006
    Beans
    85
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Stop Tor from autorunning

    Quote Originally Posted by rifter View Post
    Vidalia cannot stop or otherwise control TOR unless it started it. And of course it can't start it if it is already started. It's kind of annoying.
    I stand corrected. The Vidalia teem have figured out the magic after all, and given instructions!. So you could also edit your torrc apparently and fix this. It's weird though because I could have sworn my tor was already configured to use that control port. Incidentally I found that while reading about this bug in my quest to find a fix for Vidalia's recent propensity to freeze up on my system.
    Quote Originally Posted by anonymous admin
    root is a flying nuclear buzzsaw
    GETFIXED: Video BadAlloc crashes! Turn ON the error beep! Get 64 bit Flash! Fix mplayer!

  7. #17
    Join Date
    Apr 2006
    Beans
    85
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Stop Tor from autorunning

    I decided to get rid of Vidalia. It was hogging resources, going greyed out all the time, and in the end the only thing it was "controlling" about tor was starting and stopping it. so I just got rid of Vidalia and set tor back to starting on startup; no problems anymore.
    Quote Originally Posted by anonymous admin
    root is a flying nuclear buzzsaw
    GETFIXED: Video BadAlloc crashes! Turn ON the error beep! Get 64 bit Flash! Fix mplayer!

  8. #18
    Join Date
    Oct 2010
    Beans
    1

    Re: Stop Tor from autorunning

    I dont under stand any of this script talk. can someone tell me where and how to open up where the script goes. and what the exact script is?

  9. #19
    Join Date
    May 2009
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Stop Tor from autorunning

    Hello.
    What is being said, is that if you enter
    sudo update-rc.d tor disable

    into a terminal, Tor will stop running at start up & updates won't affect the change.
    (Click on Applications/Accessories/Terminal. Copy & paste the command into it. Type in your password (you wo'nt see it), press Enter & done.) I did the same for Polipo as well.
    I hope this helps.
    P.S. 1. Don't worry about the script talk, the above method works, so no need.
    2. Thanks "
    rifter" for the solution.

  10. #20
    Join Date
    Aug 2010
    Beans
    3

    Re: Stop Tor from autorunning

    FYI, to check on Tor service status use
    Code:
    /etc/init.d/tor status
    other possible commands are
    Code:
    /etc/init.d/tor start
    /etc/init.d/tor stop
    /etc/init.d/tor restart
    /etc/init.d/tor reload
    /etc/init.d/tor force-reload
    also, I would suggest to Tor developers to add the commands:
    /etc/init.d/tor autostart-on
    and
    /etc/init.d/tor autostart-off
    to make the process of managing the service easier.
    Note: the last two commands are not actual commands
    Last edited by technophant; April 18th, 2012 at 06:27 PM. Reason: had idea

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •