Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Can't Install Ubuntuzilla

  1. #1
    Join Date
    Nov 2007
    Location
    Metro Dallas/Ft Worth USA
    Beans
    2,150
    Distro
    Ubuntu 14.04 Trusty Tahr

    Can't Install Ubuntuzilla

    When I try..it gives: Error: Dependency is not satisfiable: libstdc++5
    "There is no failure, just ways that don't work" And when this is realized, people are much happier in life because if they stop trying, they fail as to give up. If people take this approach in life, they will never ever fail"

  2. #2
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,066
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Can't Install Ubuntuzilla

    Hi
    which version of ubuntu? and do you have the universe repo enabled?

  3. #3
    Join Date
    Nov 2007
    Location
    Metro Dallas/Ft Worth USA
    Beans
    2,150
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Install Ubuntuzilla

    Karmic and I do have them installed..Furthermore..when I tried to install thunderbird (I deleted the folder as to start fresh) I was presented with /opt/thunderbird/thunderbird-bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory. That was from the terminal.
    "There is no failure, just ways that don't work" And when this is realized, people are much happier in life because if they stop trying, they fail as to give up. If people take this approach in life, they will never ever fail"

  4. #4
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,066
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Can't Install Ubuntuzilla

    Hi

    well... that package /did/ exist in all prior versions of ubuntu, so i don't know what happened to it with karmic.

    it is also required to run the mozilla builds of firefox/thunderbird, so the error message you're getting about the missing library is no surprise.

    don't know what's going on with the karmic repos, but... nothing i can do about it. suggest you ask someone who might know what's going on. maybe on irc in #ubuntu-dev, or something like that. or maybe on launchpad.

  5. #5
    Join Date
    Nov 2007
    Location
    Metro Dallas/Ft Worth USA
    Beans
    2,150
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Install Ubuntuzilla

    Thanks for the help..I started a new topic..Yeah this does seem odd...6 is installed..
    "There is no failure, just ways that don't work" And when this is realized, people are much happier in life because if they stop trying, they fail as to give up. If people take this approach in life, they will never ever fail"

  6. #6
    Join Date
    Apr 2008
    Beans
    10,825

    Re: Can't Install Ubuntuzilla

    I've been doing some looking. I had installed Ubuntuzilla in Karmic alpha 4 (and 5 I think).

    The change was made upstream in Debian Sid:

    http://www.debianhelp.org/node/15792

    I did a lot of looking and this has been somewhat of a recurring issue since as far back as 2006.

    Anyway in that link they recommend:

    just giving a soft link from /usr/lib/libstdc++.so.6 to /usr/lib/libstdc++.so.5 and see if it works for you.
    No idea how to do that but I'd be glad to give it a try if someone knows how to create such a link.

    No sweat if I break things!

    I have tried installing libstdc++5 from Jaunty and it's a no go!

  7. #7
    Join Date
    Apr 2008
    Beans
    10,825

    Re: Can't Install Ubuntuzilla

    Thought this was funny from Debian:

    Please remove the gcc-3.3 source and binaries (gcc-3.3-base, libstdc++5); The
    compiler isn't built anymore, and libstdc++5 isn't used as a dependency anymore.
    A simple google search proves that wrong.

  8. #8
    Join Date
    Apr 2008
    Beans
    10,825

    Re: Can't Install Ubuntuzilla

    I also have an ongoing discussion here:

    http://ubuntuforums.org/showthread.p...11#post8028911

  9. #9
    Join Date
    Apr 2008
    Beans
    10,825

    Re: Can't Install Ubuntuzilla

    Just learned from mc4man that Gdebi is broken in Karmic. I installed the libstdc++5 .deb from the Jaunty package list using dpkg with no problem.

    I then used dpkg to install Ubuntuzilla (failed because I needed to install libnotify-bin from repos), after installing libnotify-bin Ubuntuzilla installed properly and the script ran OK.

    I say OK, but I have noticed for a while that I get the plugin path warning but I just hit enter and everything still works afterwards.

    Anyway, until the devs get Karmic straightened out, it can be worked around.

    It might be wise to let me run this for a couple of days to make sure I didn't break anything. Nothing apparent, but something could crop up.

  10. #10
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,066
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Can't Install Ubuntuzilla

    Quote Originally Posted by kansasnoob View Post
    just giving a soft link from /usr/lib/libstdc++.so.6 to /usr/lib/libstdc++.so.5 and see if it works for you.
    no idea if this would actually help... but to create that link, run the following command:

    Code:
    sudo ln -s /usr/lib/libstdc++.so.6 /usr/lib/libstdc++.so.5
    so if you are up for it, try uninstalling the libstdc++5 package that you installed from jaunty, making that link, and running the ubuntuzilla-installed version of firefox, and see if it complains of anything.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •