Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Soundcore missing

  1. #1
    Join Date
    Feb 2008
    Beans
    19

    Thumbs down Soundcore missing

    How do you install soundcore driver permanently?

    My sound card works after running

    sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2

    sudo modprobe snd-emu10k1

    However, after rebooting the modules are gone. Completely. Where did they go?

    ----------------------------------------------------
    Sort of solution (from my last post)
    OK, here's what I did

    After doing the

    sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2

    and

    sudo modprobe snd-emu10k1

    I then copied the directory tree
    /lib/modules/2.6.24-xx-xxx/kernel/sounds/
    to a safe place under my directory. (cp -r)

    I guess the command would be
    cd <safe directory>
    cp -r /lib/modules/`uname -r`/kernel/sound .

    (note: probably could just copy directly out of the ../kernel subdirectory)

    Then copied it to
    /lib/modules/2.6.24-xx-xxx/
    sudo cp -r sound /lib/modules/`uname -r`/
    (don't do this if you already have a "sound" directory there

    Then I ran
    sudo depmod

    Then rebooted. The directory /lib/modules/`uname -r`/sound persisted, whereas the /lib/modules/`uname -r`/kernel/sound had not.
    Last edited by xxxYYY; October 2nd, 2009 at 06:17 PM. Reason: have partial solution

  2. #2
    Join Date
    Apr 2008
    Beans
    Hidden!
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Soundcore missing

    It has been quite a while since I have done this, but I think you
    can do this:
    Code:
    cd /etc/modules.d
    sudo nano alsa-base
    Check for the floowing line. add it if you don't find it.

    Code:
    install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS &&
     { /sbin/modprobe -Qb snd-emu10k1-synth ; }
    hit CTRL X to exit, Save and try to reboot....it nags me a bit that I am missing something..but we will try this first.

    I am back, do a lsmod and see if snd-emu10k1 is there
    if not you may want add "snd-emu10k1" (no quoates) to /etc/modules
    Code:
    cd /etc
    sudo nano modules
    Add snd-emu10k1 to the end
    CTRL X you exit, Save and ether restart Alsa or just reboot.
    Last edited by rreese6; September 26th, 2009 at 07:34 AM.

  3. #3
    Join Date
    Feb 2008
    Beans
    19

    Re: Soundcore missing

    Thank you, that line is there already

  4. #4
    Join Date
    Apr 2008
    Beans
    Hidden!
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Soundcore missing

    But when you did a reboot the module is missing?
    from lsmod | grep snd

    and is it listed in the modules file under /etc?

  5. #5
    Join Date
    Feb 2008
    Beans
    19

    Re: Soundcore missing

    Yes,
    and soundcore (.ko) and the other modules it depends on

  6. #6
    Join Date
    Feb 2008
    Beans
    19

    Re: Soundcore missing

    Yes, after reboot they're all missing, I mean

  7. #7
    Join Date
    Apr 2008
    Beans
    Hidden!
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Soundcore missing

    could you post your lsmod here?

  8. #8
    Join Date
    Apr 2008
    Beans
    Hidden!
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Soundcore missing

    do you mean the the driver file is missing from:
    /lib/modules/2.6.24-xx-xxx/kernel/sounds/
    ?? or is it that the Module is not being loaded on reboot?

    What your problem appears to me to be is that once you do the purge and reinstall then you insert the module into the kernel all is well. once you reboot and do a lsmod the snd-emu10k1 module is gone.
    Am I correct?
    If so then we just need to make sure the module loads at every boot is my thinking.
    but if lsmod shows the module loaded, then it may just be a case of setting some options for the sound card.
    Last edited by rreese6; September 26th, 2009 at 08:07 AM.

  9. #9
    Join Date
    Feb 2008
    Beans
    19

    Re: Soundcore missing

    After reboot, lsmod:
    Module Size Used by
    ac97_bus 11264 0
    snd_page_alloc 21136 0
    rfcomm 54560 2
    l2cap 35968 13 rfcomm
    bluetooth 74788 4 rfcomm,l2cap
    oss_usb 137268 0
    oss_sbxfi 54720 0
    osscore 616260 2 oss_usb,oss_sbxfi
    ppdev 18568 0
    acpi_cpufreq 18448 0
    cpufreq_userspace 14468 0
    cpufreq_conservative 17800 0
    cpufreq_powersave 10368 0
    cpufreq_stats 16032 0
    cpufreq_ondemand 18320 2
    freq_table 14080 3 acpi_cpufreq,cpufreq_stats,cpufreq_ondemand
    container 13824 0
    video 30612 0
    output 12800 1 video
    dock 20128 0
    sbs 24976 0
    sbshc 16128 1 sbs
    battery 23944 0
    iptable_filter 11776 0
    ip_tables 31720 1 iptable_filter
    x_tables 30728 1 ip_tables
    ipv6 326280 30
    aes_x86_64 34088 0
    dm_crypt 23944 0
    dm_mod 78200 1 dm_crypt
    ac 15496 0
    lp 22084 0
    loop 28676 0
    af_packet 34440 2
    usblp 24832 0
    emu10k1_gp 12800 0
    wmi_acer 18244 0
    gameport 25104 2 emu10k1_gp
    button 18080 0
    serio_raw 16260 0
    parport_pc 48296 1
    parport 51340 3 ppdev,lp,parport_pc
    shpchp 45340 0
    pci_hotplug 41776 1 shpchp
    iTCO_wdt 22480 0
    iTCO_vendor_support 12932 1 iTCO_wdt
    evdev 22144 3
    psmouse 53404 0
    pcspkr 12160 0
    ext3 156176 3
    jbd 64168 1 ext3
    mbcache 18560 1 ext3
    sg 48920 0
    sr_mod 27300 0
    cdrom 48680 1 sr_mod
    sd_mod 40448 6
    floppy 76264 0
    ahci 40452 5
    libata 183984 1 ahci
    scsi_mod 185784 4 sg,sr_mod,sd_mod,libata
    ehci_hcd 49164 0
    uhci_hcd 37024 0
    tg3 131972 0
    usbcore 177200 5 oss_usb,usblp,ehci_hcd,uhci_hcd
    thermal 26912 0
    processor 48712 4 acpi_cpufreq,thermal
    fan 13960 0
    fbcon 53504 0
    tileblit 11392 1 fbcon
    font 17280 1 fbcon
    bitblit 14592 1 fbcon
    softcursor 10880 1 bitblit
    fuse 63280

  10. #10
    Join Date
    Feb 2008
    Beans
    19

    Re: Soundcore missing

    After the "aptitude --purge..." additional modules show up:
    --------------------------------

    Module Size Used by
    snd_emu10k1 175200 0
    snd_ac97_codec 131544 1 snd_emu10k1
    ac97_bus 11264 1 snd_ac97_codec
    snd_util_mem 14592 1 snd_emu10k1
    snd_hwdep 20232 1 snd_emu10k1
    snd_pcm_oss 63136 0
    snd_pcm 107528 3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
    snd_page_alloc 21136 2 snd_emu10k1,snd_pcm
    snd_mixer_oss 28032 1 snd_pcm_oss
    snd_seq_oss 46592 0
    snd_seq_midi 19392 0
    snd_rawmidi 38560 2 snd_emu10k1,snd_seq_midi
    snd_seq_midi_event 17408 2 snd_seq_oss,snd_seq_midi
    snd_seq 74624 5 snd_seq_oss,snd_seq_midi,snd_seq_midi_event
    snd_timer 36616 3 snd_emu10k1,snd_pcm,snd_seq
    snd_seq_device 18068 5 snd_emu10k1,snd_seq_oss,snd_seq_midi,snd_rawmidi,s nd_seq
    snd 85864 14 snd_emu10k1,snd_ac97_codec,snd_util_mem,snd_hwdep, snd_pcm_oss,snd_pcm,snd_mixer_oss,snd_seq_oss,snd_ seq_midi,snd_rawmidi,snd_seq_midi_event,snd_seq,sn d_timer,snd_seq_device
    soundcore 17568 1 snd

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •