Results 1 to 8 of 8

Thread: Skype white noise problem

  1. #1
    Join Date
    Sep 2009
    Beans
    3

    Skype white noise problem

    Hi I'm complete Ubuntu newbie and I would really appreciate if sombody could help me with the issue.


    The problem:

    A loud white noise appears during some of Skype conversations. It blocks completely my voice to a callee. The Skype conversation is always ok during a call untill it is disrupted and the call disconnected (usually due to a low quality of internet connection) The noise appears ALWAYS after reestablishing a conversation.


    Attempts to fix it:

    A temporary solution is to log-out the Ubuntu session and log-in again. Unfortunately it works only until the first disconnection. I've searched forums but didn't find a right solution. For some people worked changing Skype settings to these:

    Sound In: HDA NVidia (hw:NVidia,0)
    Sound Out: pulse
    Ringing: pulse

    Unfortunately I can't change Skype sound settings for any different than "PulseAudio server (local)" for any of the three options so the solution provided is not possible for me.



    Gear:

    Cam: Logitech Pro9000 (with a built-in microphone)
    Headset: Logitech PC headset 860

    OS:
    Ubuntu 9.04
    Skype version: 2.1.0.47 (beta)

    Thank you in advance for any ideas that you wish to share with me.
    Last edited by ceeborus; September 23rd, 2009 at 10:34 PM.

  2. #2
    Join Date
    Apr 2006
    Location
    Manchester, CT, USA
    Beans
    86
    Distro
    Kubuntu

    Re: Skype white noise problem

    Since your version of Skype is the new beta version, your problem might be related with the one describred at
    http://share.skype.com/sites/linux/2...lanations.html
    (the second question, about clicking noise).

    If the fix describred there doesn't work for you, my advice is to install the stable version (2.0) of Skype using medibuntu. That's what I did to solve the noise problem.

  3. #3
    Join Date
    Sep 2009
    Beans
    3

    Re: Skype white noise problem

    Cheers for the answer. The solution from skype website unfortunately didn't work for me but I managed to install the older version of skype and there is no white noise now. Now there is another problem - my voice is not recorded by Skype. Tried different settings (now unblocked) but Skype Echo (test call service) does not play my voice. Any tips what 2 do? Thanks again.

  4. #4
    Join Date
    Aug 2009
    Beans
    56

    Re: Skype white noise problem

    I have the same problem, sometimes when I call people its just white noise (according to them), and sometimes its fine. I also have to log out or restart to fix the problem. Also when i call the skype call testing service I will just get the blaring white noise in return, but sometimes it works just fine. Really need a fix for this little peeve.

  5. #5
    Join Date
    Apr 2005
    Location
    Canada
    Beans
    245
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Skype white noise problem

    Quote Originally Posted by ceeborus View Post
    Cheers for the answer. The solution from skype website unfortunately didn't work for me but I managed to install the older version of skype and there is no white noise now. Now there is another problem - my voice is not recorded by Skype. Tried different settings (now unblocked) but Skype Echo (test call service) does not play my voice. Any tips what 2 do? Thanks again.
    In skype 2.0 I had to try all the different options for Sound In. Pulse doesn't work.
    On my installation it's Hw 2 that need to be on Sound In, and pulse for the rest.

  6. #6
    Join Date
    Sep 2009
    Beans
    3

    Re: Skype white noise problem

    The solution has been found. Its name is http://www.skype.com/go/getskype-linux-beta-static
    Download, unzip and simply run without any need for installations. Works just fine for me.

  7. #7
    Join Date
    Jan 2008
    Beans
    219

    Re: Skype white noise problem

    I would call this NOT SOLVED to me.

    I still get the same static, white noise (very loud) problem with this static version.

    With the tip provided by 'n5pwp_tux' on the skype forums
    http://forum.skype.com/index.php?sho...&#entry1968371

    that is, after killing pulseaudio, and restarting it with the -vv option (i have yet to read-up what the option is for)

    Code:
    pkill pulseaudio; sleep 2; pulseaudio -vv
    Then re-adjusting the volume levels again (because they might be askew since the last problems)

    and then restarting skype, seems, so far, to fix the problem. After that, I was able to use skype, the regular beta download (non the static archive). I imagine i'd be able to use the static version too.

    Will do more tests later.

  8. #8
    Join Date
    Apr 2005
    Location
    Canada
    Beans
    245
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Skype white noise problem

    I read this, and i tried some little things. i installed the pulseaudio tools :
    Code:
    sudo apt-get install padevchooser paman paprefs pavucontrol pavumeter
    then I played a little bit with Applications->Sound&Video->Pulseaudio Device Chooser and Volume Control to make sure that everything was set up correctly.
    Then I disable in Skype the option "Allow Skype to automatically adjust my mixer levels" and the blank noise disappeared ....

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •