Results 1 to 6 of 6

Thread: rEFIt not working with OSX 10.6.1?

  1. #1
    Join Date
    Jan 2006
    Beans
    121

    rEFIt not working with OSX 10.6.1?

    I plan to have a Karmic / Snow Leopard dual boot, and I just installed rEFIt. Much to my dismay I didn't get the rEFIt menu when I restarted my Mac (after a real shutdown). Anyone know how I can fix this?

  2. #2
    Join Date
    Sep 2009
    Beans
    3

    Re: rEFIt not working with OSX 10.6.1?

    It works for me in 10.6.1.

    cd /efi/refit
    ./enable.sh

  3. #3
    Join Date
    Jan 2006
    Beans
    121

    Re: rEFIt not working with OSX 10.6.1?

    Thanks. After I held 'C' on a reboot it started working here as well.

  4. #4
    Join Date
    Jan 2006
    Beans
    121

    Re: rEFIt not working with OSX 10.6.1?

    But the joy didn't last.

    I have installed Karmic now, but something is not right.

    When I boot, rEFIt shows me three options.

    1. OS X. This works.
    2. "Boot Linux from HD". If I choose this I get a grub command line
    3. "Boot legacy os from /dev/sda3". If I choose this, nothing at all happens. /dev/sda3 is where I installed Grub (like the install wiki on this forum says I should)

    If I choose the Partition Tool in rEFIt, it discovers something unknown and won't touch the partition table (don't remember the exact error just now).

  5. #5
    Join Date
    Sep 2009
    Beans
    4

    Re: rEFIt not working with OSX 10.6.1?

    Quote Originally Posted by Aybara View Post
    But the joy didn't last.

    I have installed Karmic now, but something is not right.

    When I boot, rEFIt shows me three options.

    1. OS X. This works.
    2. "Boot Linux from HD". If I choose this I get a grub command line
    3. "Boot legacy os from /dev/sda3". If I choose this, nothing at all happens. /dev/sda3 is where I installed Grub (like the install wiki on this forum says I should)

    If I choose the Partition Tool in rEFIt, it discovers something unknown and won't touch the partition table (don't remember the exact error just now).

    I cannot address your specific issue (I have very little experience in this area) but I can tell you that rEFIt works fine on my Mac Mini with 10.6.1. I upgraded to Snow Leopard (and then applied the update to 10.6.1) before partitioning the internal HD, installing rEFIt, and then installing Ubuntu 9.04 server on that new partition. My Grub installation went to the same place as yours (/dev/sda3). Since then I've used the "Mac side" quite a bit without issue although I only dabble on the Ubuntu side. All seems fine.

  6. #6
    Join Date
    Jan 2006
    Beans
    121

    Re: rEFIt not working with OSX 10.6.1?

    The partitioner must work differently in Karmin than in Jaunty, because when I went back to Jaunty it worked. I still have one penguin too much in my rEFIt menu, but as long as I can get to both OS X and Ubuntu I'm happy

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •