Page 4 of 4 FirstFirst ... 234
Results 31 to 34 of 34

Thread: Fixed My Flash full screen performance

  1. #31
    Join Date
    Jul 2009
    Location
    Sheffield, England
    Beans
    73
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Fixed My Flash full screen performance

    Quote Originally Posted by HeYzN View Post
    only thing that solved this issue for me - lenovo t61, ubuntu 10.04 LTS with nvidia graphics card - was to change driver for nvidia from recommended version to 173.
    issue solved on both firefox and chrome (each running their own flash plugin)

    How to:
    system -> administration -> hardware drivers
    this opened for me a window with two options for the nvidia proprietary driver
    - NVIDIA accelerated graphics driver (version 173)
    - NVIDIA accelerated graphics driver (current version) [Recommended]

    click activate button for 173 version. after install restart computer.

    flash videos now work in full screen without problems and high quality/speed.
    no need to disable hardware acceleration either.

    This worked for me too. Thanks.

  2. #32
    Join Date
    Feb 2011
    Beans
    2
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Fixed My Flash full screen performance

    Quote Originally Posted by StevenHarper View Post
    Hi I am on Ubuntu 9.04 64bit
    I am running Compiz effects
    I have a 4870 ATI card with the binary drivers installed.

    Previously iPlayer and Youtube full screen performance was very poor. In both Firefox 3.0 and Chromium.

    It appears that the problem was the flash (I use the standard ubuntu repository version) I have is not detecting the hardware excleration and is leaving it off.

    To fix this a config file is needed to turn off the hardware detection.

    basically I put the text OverrideGPUValidation = 1 in a file at /etc/adobe/mms.cfg and re-start the browser.

    Such a simple fix.

    Here is how to do it in steps

    Code:
    sudo touch /etc/adobe
    sudo gedit /etc/adobe/mms.cfg
    Paste in the text

    Code:
    OverrideGPUValidation = 1
    Save the file.

    Open a browser.

    Enjoy fast full screen video.

    Please post if this works for you : I am so pleased it has worked for me.

    *** Edit

    If this still doesn't seem smooth try right clicking on the flash object and un-checking the "enable hardware excleration" box
    Hello,
    I am new to Ubuntu and this is my first post here, I am pleased to see how far Linux has progressed since I first tried it in the 90s - back then we had to fool around with hard disk cylinder information just to get it to recognize a 2 Gig hard disk. I recently installed 10.10 on an HP Pavillion dv6700 laptop, and noticed that the memory usage was much better than Windows Vista (idle, Ubuntu uses ~250 MB, Vista eats up 1.3 Gigs). And my laptop does not seem to heat up and turn on the fan as often.

    One of the things we often do with this laptop is to watch flash videos in full screen mode, on an external monitor. For this I noticed a problem with Firefox, Chromium and Opera, until I realized it was a problem with Adobe Flash. I tried the technique of setting OverrideGPUValidation in the mms.cfg in /etc/adobe, and it worked. However I followed the instructions listed here:

    http://www.omgubuntu.co.uk/2010/06/f...-ubuntu-10-04/

    For some reason, it states to uncheck hardware acceleration in a flash video first, then create the file, then to turn hardware acceleration back on, then restart firefox. Not sure if all those steps are necessary, but it worked. For stuff like this, this is why Windows still wins on the desktop over Linux. I was about to give up this Ubuntu over this one issue, luckily these online forums are here.

    I hit one other snag in getting fullscreen flash to work: I often put my browser in the external monitor, which is connected to my laptop through the external VGA port. My laptop screen runs in 1280x800, and the monitor displays an extended desktop in 1360x768 (which for some odd reason is listed as 1280x768 in Windows Vista). When I try to run flash in fullscreen mode, the fullscreen flash then pops up on my laptop screen and my monitor is still showing the browser with the embedded flash video. How to fix this? I first just turned off my laptop and had only the monitor running: fullscreen flash worked perfectly on the external monitor. However I do want both screens running, so I tried another technique: instead of having the monitor to the right of my laptop screen, I shifted it to the left. With this configuration, fullscreen flash works on the monitor and I can still work on my laptop screen. Unfortunately, due to the different resolutions, it seems that the top bar in my Gnome desktop on the laptop screen turns completely black, where I can not see any of the icons. I can still put my mouse there and access the icons, but I have to guess where they are. This probably has to do more with the different resolutions, with the height of the left screen taking priority over the right screen.

    Any workarounds for this? I am suspecting somehow we have to configure a setting which gives the right screen priority over the left screen for fullscreen flash viewing on an external monitor.

    EDIT: I just did some further research, there is another thread on fullscreen flash appearing in the wrong monitor in another thread on Ubuntu: http://ubuntuforums.org/showthread.php?t=973631&page=2. It would seem this is a bug with desktop affects. I went to System -> Appearance -> Visual Effects and selected NONE. This did the trick. I now have fullscreen flash on an external monitor with my laptop screen intact!! This was not an easy problem. Looks like an Ubuntu Gnome bug?
    Last edited by Meneltaur; February 13th, 2011 at 06:02 AM.

  3. #33
    Join Date
    Aug 2006
    Beans
    1
    Distro
    Ubuntu 10.04 Lucid Lynx

    Exclamation Re: Fixed My Flash full screen performance

    Thanks! Worked for me also by disabling Hardware Acceleration on flash.

    To do that, just go to youtube, open a random video and set it to pause. Then right click, select "Settings" and turn off Hardware acceleration.

    That was the key issue for me!

    Ubuntu - Lucid Lynx i686 with ATI HD5870 and ATI Proprietary Fglrx Drivers (11.2)

    This is my xorg:

    Code:
    Section "ServerLayout"
    	Identifier     "aticonfig Layout"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    	Option	    "AIGLX" "on" #->Enables Xorg's AIGLX rendering technic
    EndSection
    
    Section "Module"
    	Load  "bitmap"
    	Load  "extmod"
    	Load  "int10"
    	Load  "vbe"	# slowdown compiz?
    	Load  "i2c"
    	Load  "ddc"
    	Load  "dri"
    	Load  "dri2"
    	Load  "glx"
    	Load  "GLcore"
    	Load  "dbe"
    	Load  "drm"
    	Load  "v4l"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	BusID       "PCI:1:0:0"
    	Option	    "VideoOverlay" "on"
    	Option	    "DRI"
    #	Option	    "renderAccel" "true"
    #	Option	    "UseFastTLS" "0"
    #	Option	    "AddARGBGLXVisuals" "true"
    #	Option	    "XAANoOffscreenPixmaps" "on"
    #	Option	    "TexturedVideo" "off"
    #	Option	    "CideoOverlay" "off"
    #	Option	    "OpenGLOverlay" "off"
    #	Option	    "Textured2D" "on"
    	Option	    "BackingStore" "on"
    	Option	"TripleBuffer" "True"
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Virtual	1600	1200
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        "video"
    	Mode         0666
    EndSection
    
    Section "Extensions"
    	Option	    "RENDER" "Enable"
    	Option	    "DAMAGE" "Enable"
    	Option	    "XVideo" "Enable"
    	Option	    "Composite" "Enable"
    EndSection
    Commented options (#) are yet to be tested (on my sys). Either ignore or remove them.

  4. #34
    Join Date
    Sep 2011
    Beans
    2

    Re: Fixed My Flash full screen performance

    Worked for me too, thanks!

    Lenovo t60 - Ubuntu 10.04

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •