Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Fixed My Flash full screen performance

  1. #1
    Join Date
    Sep 2006
    Location
    Leeds, UK
    Beans
    125
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Talking Fixed My Flash full screen performance

    Hi I am on Ubuntu 9.04 64bit
    I am running Compiz effects
    I have a 4870 ATI card with the binary drivers installed.

    Previously iPlayer and Youtube full screen performance was very poor. In both Firefox 3.0 and Chromium.

    It appears that the problem was the flash (I use the standard ubuntu repository version) I have is not detecting the hardware excleration and is leaving it off.

    To fix this a config file is needed to turn off the hardware detection.

    basically I put the text OverrideGPUValidation = 1 in a file at /etc/adobe/mms.cfg and re-start the browser.

    Such a simple fix.

    Here is how to do it in steps

    Code:
    sudo touch /etc/adobe
    sudo gedit /etc/adobe/mms.cfg
    Paste in the text

    Code:
    OverrideGPUValidation = 1
    Save the file.

    Open a browser.

    Enjoy fast full screen video.

    Please post if this works for you : I am so pleased it has worked for me.

    *** Edit

    If this still doesn't seem smooth try right clicking on the flash object and un-checking the "enable hardware excleration" box
    Last edited by StevenHarper; September 20th, 2009 at 10:00 PM.

  2. #2
    Join Date
    Jun 2009
    Beans
    95
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Fixed My Flash full screen performance

    When I run these two commands gedit tells me no such directory exists.

    sudo touch /etc/adobe
    sudo gedit /etc/adobe/mms.cfg

  3. #3
    Join Date
    Sep 2009
    Beans
    3

    Re: Fixed My Flash full screen performance

    Quote Originally Posted by UKBB View Post
    When I run these two commands gedit tells me no such directory exists.

    sudo touch /etc/adobe
    sudo gedit /etc/adobe/mms.cfg
    I got that same error because I didn't have an adobe directory, and the touch command creates a file instead of a directory.

    So, I first deleted the file I just created, then created a folder with the same name, and then put the mms.cfg inside it.

    sudo rm /etc/adobe
    sudo mkdir /etc/adobe
    sudo gedit /etc/adobe/mms.cfg

    Then I restarted my browser.

    BUT it still didn't do the trick.

    Anyhow, right clicking on the flash object and un-checking the "enable hardware acceleration" box slightly improved the performance, but still not good enough. I think I'm going to install the Video Download Helper extension and just download the videos I really want to see in full screen.

    LATER EDIT: Yeah, Video Download Helper extension for Firefox is a reasonable solution. You can even view videos while they're downloading.
    Last edited by gabi83tm; September 30th, 2009 at 05:58 PM.

  4. #4
    Join Date
    Aug 2009
    Beans
    31

    Re: Fixed My Flash full screen performance

    Hello guys, does anyone know how to get this fix working in Ubuntu 10.04?

    It worked great for me in 9.04, suddenly my Youtube videos played full speed in fullscreen resolution at 1080p.

    Before the fix, I couldn't even run a 360p video without it being really choppy.

    However, the same fix doesn't seem to work on 10.04... :S

  5. #5
    Join Date
    Feb 2008
    Location
    New York
    Beans
    163
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Fixed My Flash full screen performance

    same here..anyone???

  6. #6
    Join Date
    Jul 2009
    Beans
    571
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Fixed My Flash full screen performance

    Nope didn't work for me tried it on Firefox and Chrome, full screen looks like 16:9 aspect ratio. Any help? Thanks.
    It's OK, everything we know will become obsolete at some time.

  7. #7
    Join Date
    May 2010
    Beans
    3

    Re: Fixed My Flash full screen performance

    Right clicking on any flash video, then "Settings", "Display" tab (the first one) and uncheck "Enable hardware acceleration".

    That fixed the choppy poor performance Flash when in full screen. Now 720p HD flash videos (on YouTube) run smoothly in full-screen (using Intel Core 2 Quad, Intel On-Board GMA 4500 HD).

  8. #8
    Join Date
    Feb 2008
    Location
    New York
    Beans
    163
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Fixed My Flash full screen performance

    Doesn't work for ATI

  9. #9
    Join Date
    Dec 2006
    Beans
    25

    Re: Fixed My Flash full screen performance

    Anybody managed to get this working on Lucid, I have tried all these little tricks and it makes no difference. The result is still a very choppy fullscreen flash.

    I am running Lucid on a Zotac Nvidia ION chipset.

    Has anybody perhaps managed to get something playing nicely on a browser in wine, I would gladly do that as an alternative if it works.

    thanks
    Paul

  10. #10
    Join Date
    Sep 2009
    Beans
    2,330

    Re: Fixed My Flash full screen performance

    write down your settings first so if need to be set back. and try this

    5.1. The video is sluggish/has a slow response. What can I do?


    You may have set "ximagesink" ("X Window System (No Xv)") as video-output.
    This means, that your cpu is doing all the work. Change it to "xvimagesink"
    ("X Window System (X11/XShm/Xv)") in order to let your graphics card do the work.



    To change the settings, run "gstreamer-properties", click the Video tab
    and change the appropriate settings.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •