Page 8 of 8 FirstFirst ... 678
Results 71 to 74 of 74

Thread: Turn off (mute) system beep

  1. #71
    Join Date
    Jun 2007
    Location
    Melbourne, Australia
    Beans
    1,171

    Re: Turn off (mute) system beep

    Quote Originally Posted by shivku View Post
    "blacklist pcspkr" did not turn off the beep for me. I did an lsmod and picked up the module that looked closest to a pc speaker. It was "snd_pcsp".

    Next I did rmmod snd_pcsp and added it to the blacklist and now the beep has gone to hell.
    Yep, the name of the module changed in kernel 2.6.31. Well, it might have changed in 2.6.30 as well, I'm not sure, I just don't build it into my kernel anymore!

  2. #72
    Join Date
    Dec 2009
    Beans
    19

    Re: Turn off (mute) system beep

    imho, the winning lazy-friendly solution is this:

    System > Preferences > Sound

    And just tick 'Mute'.

  3. #73
    Join Date
    Feb 2011
    Location
    Tehran
    Beans
    1
    Distro
    Ubuntu

    Re: Turn off (mute) system beep

    Do not unplug your internal speaker or make boot scripts

    Edit the .inputrc file in your home directory (create it if needed) and add the line

    Code:
    set bell-style visible
    this will replace the beep by a flashing screen. You can replace 'visible' by 'none' to get nothing at all.

    You can also add (or uncomment) this line in the general /etc/inputrc file to set the bell-style for all users (overriden in ~/.inputrc).

    You have to log out to enable this setting.

    PS: this also works in xterm/konsole/gnome-terminal
    @geofs: The method you've offered didn't work for me.
    I'm using LMDE x64 (which is debian-based but very similar to ubuntu) and there was no .inputrc file in my home.
    I could find /etc/inputrc but uncommenting the line you mentioned didn't affect anything.

    Turn off (mute) system beep
    For anyone with a laptop who works in a library or other quiet area, system beeps every time you press the backspace key one too many times, or just using emacs, can be quite disturbing.

    To shut them off:
    open an xterm or terminal, and enter the two lines
    Code:
    xset b off
    xset b 0 0 0
    Hope this helps.

    note: this does not work if run before X. To have it run as default, you can place it in your .xinitrc before the windowmanager. If you're using Gnome or KDE, it is probably easier to just turn off the "System Bell" or set it to "Visable Only" in your respective settings manager.
    But the method WolfJay_83 offered worked for me too. Thank you WolfJay_83.

  4. #74
    Join Date
    Jan 2009
    Beans
    3

    Re: Turn off (mute) system beep

    None of these methods worked for my Dell Latitude E6510. The shutdown beep was driving me crazy.

    It turns out there is a hidden mixer in the volume control called, funnily enough, "Beep." If you make this visible in Volume Control preferences and mute it, the evil beep is gone. You can also probably do the same in alsamixer.

Page 8 of 8 FirstFirst ... 678

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •