Page 1 of 6 123 ... LastLast
Results 1 to 10 of 74

Thread: Turn off (mute) system beep

Hybrid View

  1. #1
    Join Date
    Jul 2005
    Location
    Waterloo, Canada
    Beans
    42

    Turn off (mute) system beep

    For anyone with a laptop who works in a library or other quiet area, system beeps every time you press the backspace key one too many times, or just using emacs, can be quite disturbing.

    To shut them off:
    open an xterm or terminal, and enter the two lines
    Code:
    xset b off
    xset b 0 0 0
    Hope this helps.

    note: this does not work if run before X. To have it run as default, you can place it in your .xinitrc before the windowmanager. If you're using Gnome or KDE, it is probably easier to just turn off the "System Bell" or set it to "Visable Only" in your respective settings manager.
    Last edited by WolfJay_83; April 2nd, 2007 at 04:58 PM. Reason: Added clarification note
    Jason Locklin
    Undergraduate Psychology Student, University of Waterloo
    Homepage

  2. #2
    Join Date
    Dec 2004
    Location
    Louisville, KY
    Beans
    300
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Turn off (mute) system beep

    Quote Originally Posted by WolfJay_83
    For anyone with a laptop who works in a library or other quiet area, system beeps every time you press the backspace key one too many times, or just using emacs, can be quite disturbing.

    To shut them off:
    open an xterm or terminal, and enter the two lines
    Code:
    xset b off
    xset b 0 0 0
    Hope this helps.
    will this disable it permanently, or do i need to run this every time i boot up?
    Thinkpad T61p: 15.4" WUXGA Screen, Core 2 Duo T9300, 4GB DDR2, 512MB Quadro 570M, 160GB 7200RPM HDD, DVD+RW, Intel 4965AGN+Bluetooth, 9 Cell Battery
    http://blog.zachtib.com

  3. #3
    Join Date
    Aug 2005
    Location
    London, Canada
    Beans
    69

    Re: Turn off (mute) system beep

    I've always just unplugged the internal speaker all together. I guess this solution is a little less drastic.

  4. #4
    Join Date
    Jul 2005
    Location
    Waterloo, Canada
    Beans
    42

    Re: Turn off (mute) system beep

    It appears to turn it off temporarily (I've been using it just when in the library). I suppose if you put it in a script to be run on bootup, you could make it perminent. I will have to put together instructions when I do that myself.

    note: its kindof hard to disconnect the pc speaker in a laptop. Also, on a PC, if your video or ram gets messed up, you won't know whats going on on bootup without the post beep.

    regards
    Jason Locklin
    Undergraduate Psychology Student, University of Waterloo
    Homepage

  5. #5
    Join Date
    Apr 2005
    Beans
    433

    Re: Turn off (mute) system beep

    You can disable system bell if in the Terminal you go to Edit->Current Profile->General and uncheck the Terminal Bell
    Or in the Configuration editor go to apps->Gnome-Terminal->Profiles->default check silent Bell.

  6. #6
    Join Date
    Nov 2004
    Beans
    177
    Distro
    Dapper Drake

    Re: Turn off (mute) system beep

    wouldn't do any good for console beep.
    Linux user #392733
    -------------------------------------
    You want to know what a computer really is, try Linux!

  7. #7
    Join Date
    Jul 2006
    Beans
    1

    Re: Turn off (mute) system beep

    Quote Originally Posted by art View Post
    You can disable system bell if in the Terminal you go to Edit->Current Profile->General and uncheck the Terminal Bell
    Or in the Configuration editor go to apps->Gnome-Terminal->Profiles->default check silent Bell.
    Great help to new Ubuntu users. Thanks very much.

  8. #8
    Join Date
    Mar 2007
    Beans
    6

    Re: Turn off (mute) system beep

    Quote Originally Posted by art View Post
    You can disable system bell if in the Terminal you go to Edit->Current Profile->General and uncheck the Terminal Bell
    Or in the Configuration editor go to apps->Gnome-Terminal->Profiles->default check silent Bell.
    Thanks a lot for this tip. The beep was annoying most of the time.

  9. #9
    Join Date
    Apr 2009
    Beans
    130

    Re: Turn off (mute) system beep

    Quote Originally Posted by art View Post
    You can disable system bell if in the Terminal you go to Edit->Current Profile->General and uncheck the Terminal Bell
    Or in the Configuration editor go to apps->Gnome-Terminal->Profiles->default check silent Bell.
    Quote Originally Posted by dragonfixed View Post
    Or Just sudo vim /etc/modprobe.d/blacklist

    and add

    blacklist pcspkr
    Thx for both of these tips. The beeping was driving me crazy in Jaunty.

  10. #10
    Join Date
    Jan 2008
    Location
    Florence, Italy
    Beans
    22
    Distro
    Ubuntu Development Release

    Re: Turn off (mute) system beep

    Hello everybody,

    I tried all the solution proposed in this topic, but none of them worked for me. My problem is that I hear the system beep when I shut down my laptop... the beep more or less overlaps with the "exit" sound.

    I disabled alert sounds in System>Preferences>Sound, did the same for the terminal and for some other applications... I also blacklisted "pcspkr" in /etc/modprobe.d/blacklist.conf... all to no avail... I see indeed that every possible beep in the normal running of Ubuntu has disappeared, but the shutdown one has not.

    I've tried to have a look at the Bios, to check if I could disable the system beep from there, but I haven't found that option. I have a Dell Inspiron 1525, maybe some of you can help me. Thanks.

Page 1 of 6 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •