Page 9 of 35 FirstFirst ... 789101119 ... LastLast
Results 81 to 90 of 342

Thread: Ipod Nano 5G with linux?

  1. #81
    Join Date
    Nov 2007
    Beans
    5

    Re: Ipod Nano 5G with linux?

    Quote Originally Posted by Okiura
    this could be the case but I did provide a download link to the version I patched against, I don't know how/if my patch will work against any other version, although it should work i'd suggest patching the one on the link i provided.

    Okiura,
    I used the latest git... I'll try your tgz now.

    Also, thanks for the information on Nano 5g

  2. #82
    Join Date
    Jan 2010
    Beans
    6

    Re: Ipod Nano 5G with linux?

    Hi all,

    First post here also, let me start by saying thanks to everyone who is working on this, I really appreciate it. I received a nano 5G for Christmas and followed all of the instructions in this thread. Things almost work but the iPod still shows 0 songs. Heres what I did:

    - Downloaded patch + latest libgpod + latest gtkpod
    - Copied patch files
    - ran ./autogen make etc
    - used iTunes (on a windows box) to reset the ipod to factory defaults
    - plugged the iPod in and started gtkpod
    - set the iPod model xC027 (8GB, silver) (with the 5G menu item)
    - checked:

    Code:
    sudo lsusb -v | grep -i Serial
      iSerial                 1 0000:00:1d.0
      iSerial                 1 0000:00:1d.1
      iSerial                 1 0000:00:1d.2
      iSerial                 1 0000:00:1d.3
      iSerial                 3 000A27001EB993EF
      iSerial                 1 0000:00:1d.7
    Code:
    cat /media/IPOD/iPod_Control/Device/SysInfo
    ModelNumStr: xC027
    FirewireGuid: 000A27001EB993EF
    Then add 2 songs:

    Code:
    ** (gtkpod:4080): CRITICAL **: itdb_splr_validate: assertion `at != ITDB_SPLAT_UNKNOWN' failed
    libitdbprep: itdb_sqlite_generate_itdbs called with file /media/IPOD/iPod_Control/iTunes/iTunesCDB and uuid 000A27001EB993EF
    itlp directory='/media/IPOD/iPod_Control/iTunes/iTunes Library.itlp'
    *.itdb files will be stored in '/media/IPOD/iPod_Control/iTunes/iTunes Library.itlp'
    [mk_Dynamic] Processing '/tmp/filea2rjxN/Dynamic.itdb'
    [mk_Dynamic] creating table structure
    [mk_Dynamic] - processing 2 tracks
    [mk_Dynamic] done.
    [mk_Extras] Processing '/tmp/filea2rjxN/Extras.itdb'
    [mk_Extras] re-building table structure
    [mk_Extras] done.
    [mk_Genius] Processing '/tmp/filea2rjxN/Genius.itdb'
    [mk_Genius] re-building table structure
    [mk_Genius] done.
    library_persistent_id = 0x0402f8595753de1b
    [mk_Library] Processing '/tmp/filea2rjxN/Library.itdb'
    [mk_Library] building table structure
    [mk_Library] compiling SQL statements
    [mk_Library] - inserting into "version_info"
    [mk_Library] - inserting into "genre_map"
    [mk_Library] - inserting songs into "item_to_container"
    [mk_Library] - inserting playlist 'IPOD' into "container"
    [mk_Library] - inserting songs into "item_to_container"
    [mk_Library] - inserting playlist 'Podcasts' into "container"
    library_persistent_id = 0x0402f8595753de1b
    device name = IPOD
    [mk_Library] - inserting into "db_info"
    [mk_Library] - processing 2 tracks
    [mk_Library] - inserting into "track_artist"
    [mk_Library] - inserting into "track_artist"
    [mk_Library] 3 sqlite3_step returned 19
    [mk_Library] done.
    [mk_Locations] Processing '/tmp/filea2rjxN/Locations.itdb'
    [mk_Locations] re-building table structure
    [mk_Locations] Processing 2 tracks...
    [mk_Locations] done.
    Finally eject the nano and... no songs.

    thoughts?

    Thanks.

  3. #83
    Join Date
    Dec 2008
    Beans
    40

    Re: Ipod Nano 5G with linux?

    Quote Originally Posted by vizzini View Post
    Any ideas?

    CU
    Ruppi

    Hi,

    You have done everything correct and the gtkpod out put looks as I would expect it too... almost every thing in the output is being done on the PC before it is coppied to the Ipod, all the databases appear to being created correctly, it's the copying to the Ipod bit is where it looks like it is failing, you should have:

    Code:
    itdbprep: copying 'Dynamic.itdb'
    itdbprep: copying 'Extras.itdb'
    itdbprep: copying 'Genius.itdb'
    itdbprep: copying 'Library.itdb'
    itdbprep: copying 'Locations.itdb'
    itdbprep: copying 'Locations.itdb.cbk'
    At the end but I don't see it in what you have posted and that ties in with what you said about the database file not being updated. My patch only changes the way the database files are created not the way they are copied so I'm not sure on this one... but I'll see what help I can be.

    With the Ipod connected can you run:

    Code:
    mount | grep /media
    Also check the /tmp/[tmp_database_dir] folder on your PC (you need to get the full name form the gtkpod output) see if the files are still there and try and manually copy them, however I don' think they will be there

    Okiura

  4. #84
    Join Date
    Dec 2008
    Beans
    40

    Re: Ipod Nano 5G with linux?

    Quote Originally Posted by mortfrog View Post

    thoughts?

    Thanks.
    Same issue as Vizzini

  5. #85
    Join Date
    Jan 2010
    Beans
    6

    Re: Ipod Nano 5G with linux?

    This is the output from mount:
    Code:
    mount | grep media
    /dev/sdb1 on /media/IPOD type vfat (rw,nosuid,nodev,uhelper=devkit,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,flush)
    I checked tmp and it is empty before you click save. Then as soon as save is done again it is empty again. I'm not sure how to grab the files during the save process before they are deleted.

    Thanks again

  6. #86
    Join Date
    Dec 2008
    Beans
    40

    Re: Ipod Nano 5G with linux?

    Quote Originally Posted by mortfrog View Post
    This is the output from mount:
    Code:
    mount | grep media
    /dev/sdb1 on /media/IPOD type vfat (rw,nosuid,nodev,uhelper=devkit,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,flush)
    I checked tmp and it is empty before you click save. Then as soon as save is done again it is empty again. I'm not sure how to grab the files during the save process before they are deleted.

    Thanks again
    Darn the output is as I would expect, it not a problem with the way it is mounted... i couldn't copy them b4 they were removed either was was more to check if there left behind as the're not copied to the Ipod.

    can you try with a un-patched build and see if they are copied, it will show 0 songs after but it should still try and copy the databases as I never changed any of that code.

    Okiura,
    Last edited by Okiura; January 2nd, 2010 at 07:44 PM.

  7. #87
    Join Date
    Jan 2010
    Beans
    6

    Re: Ipod Nano 5G with linux?

    I tried reverting back and it still appeared that i was having the same not copying problem so I'm poking through itdb_sqlite.c now. I just commented out the comand which removes the tmp directory, so now i have the files, but where do i copy them onto the ipod?

  8. #88
    Join Date
    Sep 2007
    Beans
    1

    Re: Ipod Nano 5G with linux?

    Quote Originally Posted by mortfrog View Post
    I tried reverting back and it still appeared that i was having the same not copying problem so I'm poking through itdb_sqlite.c now. I just commented out the comand which removes the tmp directory, so now i have the files, but where do i copy them onto the ipod?
    You should copy them at:
    <mount point>/iPod_Control/iTunes/iTunes\ Library.itlp/

    I had the same problem witch others have mentioned: it didn't copy the *.itdb files back to the ipod. The cause of the problem was that firewireGuid at the SysInfo file disappeared (as expected ) after restoring the ipod with iTunes.

    You'll probably notice that the file Locations.itdb.cbk is missing from the tmp directory, which is the reason libgpod does not copy any of the files back.

  9. #89
    Join Date
    Jan 2008
    Location
    Manchester UK
    Beans
    13,657
    Distro
    Ubuntu

    Re: Ipod Nano 5G with linux?

    Code:
    gtkpod: error while loading shared libraries: libgpod.so.4: cannot open shared object file: No such file or directory
    What have I done wrong?

    I have compiled the patched libgpod from the link.

    I have built gtkpod - the latest version from the git repository.
    Code:
    locate libgpod
    /usr/lib/libgpod.so.4
    /usr/lib/libgpod.so.4.1.0
    /usr/lib/hal/scripts/libgpod-callout
    /usr/share/doc/libgpod-common
    /usr/share/doc/libgpod4
    /usr/share/hal/fdi/policy/20thirdparty/20-libgpod-sysinfo-extended.fdi
    /usr/share/locale-langpack/en_GB/LC_MESSAGES/libgpod.mo
    /var/lib/dpkg/info/libgpod-common.list
    /var/lib/dpkg/info/libgpod-common.md5sums
    /var/lib/dpkg/info/libgpod4.list
    /var/lib/dpkg/info/libgpod4.md5sums
    /var/lib/dpkg/info/libgpod4.postinst
    /var/lib/dpkg/info/libgpod4.postrm
    /var/lib/dpkg/info/libgpod4.shlibs
    /var/lib/dpkg/info/libgpod4.symbols

  10. #90
    Join Date
    Jan 2010
    Beans
    6

    Re: Ipod Nano 5G with linux?

    Quote Originally Posted by nothingspecial View Post
    What have I done wrong?
    try:
    Code:
    cd libgpod/
    sudo make uninstall
    sudo make clean
    ./configure --prefix=/usr/
    sudo make
    sudo make install

Page 9 of 35 FirstFirst ... 789101119 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •