Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Firefox font suddenly ugly

  1. #11
    Join Date
    Jun 2008
    Beans
    16

    Smile Re: Firefox font suddenly ugly

    Quote Originally Posted by dumblebee100 View Post
    I think you are feeling the effect of anti aliasing in firefox menus ..

    because firefox from 3.5 and after do not take settings from general settings ...

    edit the file

    /etc/fonts/conf.avail

    10-antialias.conf

    change anti alias from TRUE to false

    now enjoy firefox with crisp fonts
    Thanks! That worked for me when upgrading from 9.04 to 9.10. Sweet.

  2. #12
    Join Date
    Aug 2008
    Location
    UK
    Beans
    Hidden!

    Re: Firefox font suddenly ugly

    i know this is'nt gonna be much help, but Firefox is a GTK app
    and KDE 4x has a 'QT4-gtk engine' which can help GTK apps fit in to KDE but sadly, it screws Firefox.. at least it used to in Jaunty.. by not shutting Firefox, resulting in a 'firefox is already runng' type of error
    good job Konqueror is actually really quite good in Karmic ..

  3. #13
    Join Date
    Sep 2009
    Location
    Finland
    Beans
    12
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Firefox font suddenly ugly

    Umm, is it possible to make Firefox use the "best contrast" option? Or something? I don't like full antialiasing, but don't want to disable it either...
    Last edited by ~unknown; October 31st, 2009 at 02:17 PM.

  4. #14
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,049

    Re: Firefox font suddenly ugly

    I don't get how the fonts are supposed to look? That looks pretty good to me, it's how I have it set up.

    If it's still wrong after setting GTK apps to use the KDE font (in System Settings -> Appearance -> GTK Styles), you'll probably want to set up your own ~/.fonts.conf. You can set up fonts and antialiasing as you please in there. Those settings will override those in /etc/fonts/conf.d/*.

    Example of my ~/.fonts.conf (typo remedied):
    Code:
    <?xml version='1.0'?>
    <!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
    
    <fontconfig>
    
      <!-- GENERAL OPTIONS
        -->
      <match target="font">
        <edit mode="assign" name="rgba">		<!-- subpixel rendering color order -->
          <const>rgb</const>
        </edit>
      </match>
      <match target="font">
        <edit mode="assign" name="antialias">	<!-- antialiasing -->
          <bool>true</bool>
        </edit>
      </match>
      <match target="font">
        <edit mode="assign" name="autohint">	<!-- autohinting -->
          <bool>false</bool>
        </edit>
      </match>
      <match target="font">
        <edit mode="assign" name="hinting">		<!-- hinting -->
          <bool>true</bool>
        </edit>
      </match>
      <match target="font">
        <edit mode="assign" name="hintstyle">	<!-- style of hinting: hintfull/hintmedium/hintslight/hintnone -->
          <const>hintfull</const>
        </edit>
      </match>
      <match target="font">
        <edit mode="assign" name="embeddedbitmap">	<!-- font bitmaps, mainly for unicode purposes -->
          <bool>true</bool>
        </edit>
      </match>
    
    
      <!-- FONT REPLACEMENT
    	Some fonts look positively ugly so changing them to the virtual sans-serif, sans and monospace
        -->
      <!-- serif -->
      <match target="pattern">
        <test name="family" qual="any">
          <string>Times</string>
        </test>
        <edit mode="assign" name="family">
          <string>serif</string>
        </edit>
      </match>
      <match target="pattern">
        <test name="family" qual="any">
          <string>Nimbus Roman No9 L</string>
        </test>
        <edit mode="assign" name="family">
          <string>serif</string>
        </edit>
      </match>
    
      <!-- sans-serif -->
      <match target="pattern">
        <test name="family" qual="any">
          <string>Bitstream Vera</string>
        </test>
        <edit mode="assign" name="family">
          <string>sans-serif</string>
        </edit>
      </match>
      <match target="pattern">
        <test name="family" qual="any">
          <string>Bitstream Vera Sans</string>
        </test>
        <edit mode="assign" name="family">
          <string>sans-serif</string>
        </edit>
      </match>
      <match target="pattern">
        <test name="family" qual="any">
          <string>Helvetica</string>
        </test>
        <edit mode="assign" name="family">
          <string>sans-serif</string>
        </edit>
      </match>
      <match target="pattern">
        <test name="family" qual="any">
          <string>Nimbus Sans L</string>
        </test>
        <edit mode="assign" name="family">
          <string>sans-serif</string>
        </edit>
      </match>
    
      <!-- monospace -->
      <match target="pattern">
        <test name="family" qual="any">
          <string>Bitstream Vera Sans Mono</string>
        </test>
        <edit mode="assign" name="family">
          <string>monospace</string>
        </edit>
      </match>
      <match target="pattern">
        <test name="family" qual="any">
          <string>Courier</string>
        </test>
        <edit mode="assign" name="family">
          <string>monospace</string>
        </edit>
      </match>
      <match target="pattern">
        <test name="family" qual="any">
          <string>Nimbus Mono L</string>
        </test>
        <edit mode="assign" name="family">
          <string>monospace</string>
        </edit>
      </match>
    
    
      <!-- VIRTUAL FONTS
    	The font order which makes up the virtual fonts serif, sans-serif and monospace.
    	In Karmic, will follow each font for further fallbacks (defined below and in other fonts/conf.d/ files)
        -->
      <alias>
        <family>serif</family>
        <prefer>
          <family>Times New Roman</family>		<!-- main serif font -->
          <family>Kochi Mincho</family>
        </prefer>
      </alias>
      <alias>
        <family>sans-serif</family>
        <prefer>
          <family>Arial</family>
          <family>DejaVu Sans</family>		<!-- main sans-serif font -->
          <family>Kochi Gothic</family>
        </prefer>
      </alias>
      <alias>
        <family>monospace</family>
        <prefer>
          <family>DejaVu Sans Mono</family>		<!-- main monospace font -->
          <family>Kochi Gothic</family>
        </prefer>
      </alias>
    
    
      <!-- FALLBACKS
          Mainly for unicode purposes; as soon as a font doesn't contain a character, it'll try with the next one on this list
        -->
      <alias>
        <family>Times New Roman</family>
        <prefer>
          <family>Times New Roman</family>
          <family>Kochi Mincho</family>
          <family>Sazanami Mincho</family>
        </prefer>
      </alias>
    
      <alias>
        <family>Arial</family>
        <prefer>
          <family>Arial</family>
          <family>Kochi Gothic</family>
        </prefer>
      </alias>
    
      <alias>
        <family>DejaVu Serif</family>
        <prefer>
          <family>DejaVu Sans</family>
          <family>Kochi Mincho</family>
        </prefer>
      </alias>
    
      <alias>
        <family>DejaVu Sans</family>
        <prefer>
          <family>DejaVu Sans</family>
          <family>Kochi Gothic</family>
        </prefer>
      </alias>
    
      <alias>
        <family>DejaVu Sans Mono</family>
        <prefer>
          <family>DejaVu Sans Mono</family>
          <family>Kochi Gothic</family>
        </prefer>
      </alias>
    
      <alias>
        <family>Courier New</family>
        <prefer>
          <family>Courier New</family>
          <family>Kochi Gothic</family>
        </prefer>
      </alias>
    
    </fontconfig>
    Do note that it's set up to use Times New Roman for the Serif virtual font, DejaVu Sans for Sans-serif and DejaVu Sans Mono for Monospace. Also the Kochi series of fonts for unicode fallback, to get good unicode bitmap coverage so CJK (Chinese/Japanese/Korean) fonts aren't drawn as fuzzy vertexes at lower font sizes (<17).

    If you don't have those installed it'll just listen to system-specific /etc/fonts/conf.d/* files. Saving this file should make changes apply immediately to newly started programs (and reloaded Firefox pages).
    Last edited by Zorael; May 18th, 2011 at 02:55 PM. Reason: typo
    ...

  5. #15
    Join Date
    Oct 2009
    Location
    Hamburg, Germany
    Beans
    2
    Distro
    Ubuntu Karmic Koala (testing)

    Exclamation Re: Firefox font suddenly ugly

    Hi,

    the problem semms to be the missing font "Bitstream Vera".
    It has been removed silenty without any replacements by Ubuntu.
    (Anybody knows why? )

    If you using old config stuff (on upgrade) every application using this font
    looks very ugly. Especially if it using a monospace font of Bitstream Vera.

    You can simply install it from launchpad https://launchpad.net/ubuntu/karmic/...am-vera/1.10-7 or replace the fontsetting for every application by another font.
    (and again: does anybody knows the official replacement font for Bitstream Vera?)
    EDIT: I found the answer for the second question here: https://issues.foresightlinux.org/browse/FL-370

    denk_mal
    Last edited by denk_mal; November 3rd, 2009 at 09:23 AM.

  6. #16
    Join Date
    Apr 2006
    Beans
    5

    Re: Firefox font suddenly ugly

    Its pretty clear there is a difference of opinion here! Going on what everyone has said dumblebee, Capa Pinbacker and Zorael all view having anti-aliasing off as the desired outcome, whereas SirSigma was saying his fonts looked screwed because the AA got turned off and he wants it back on.

    DrKay remove the file ~/.fonts.conf (thanks SirSigma), I just did and everything is back in its antialiased beauty again

  7. #17
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,049

    Re: Firefox font suddenly ugly

    Quote Originally Posted by =NickJ= View Post
    Its pretty clear there is a difference of opinion here! Going on what everyone has said dumblebee, Capa Pinbacker and Zorael all view having anti-aliasing off as the desired outcome, whereas SirSigma was saying his fonts looked screwed because the AA got turned off and he wants it back on.

    DrKay remove the file ~/.fonts.conf (thanks SirSigma), I just did and everything is back in its antialiased beauty again
    To be specific, I was trying to make him check the contents of his ~/.fonts.conf file to see if they were forcing any undesired settings. It's not a binary blob, it's humanly readable if you read the tags and do a bit of guesswork. :3
    ...

  8. #18
    Join Date
    Mar 2009
    Beans
    232

    Re: Firefox font suddenly ugly

    Quote Originally Posted by =NickJ= View Post
    Its pretty clear there is a difference of opinion here! Going on what everyone has said dumblebee, Capa Pinbacker and Zorael all view having anti-aliasing off as the desired outcome, whereas SirSigma was saying his fonts looked screwed because the AA got turned off and he wants it back on.

    DrKay remove the file ~/.fonts.conf (thanks SirSigma), I just did and everything is back in its antialiased beauty again
    That worked to get antialiased fonts for certain application elements (like the menus, etc.) but it didn't work for getting them in rendered web pages. Weird.

    Has anyone successfully gotten antialiased fonts for web pages content? I have the DejaVu family set as my fonts with pages not allowed to choose their own fonts.

    I should add that antialiasing works fine in Chromium!
    Last edited by nortexoid; January 25th, 2010 at 05:51 PM.

  9. #19
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,049

    Re: Firefox font suddenly ugly

    Quote Originally Posted by nortexoid View Post
    That worked to get antialiased fonts for certain application elements (like the menus, etc.) but it didn't work for getting them in rendered web pages. Weird.

    Has anyone successfully gotten antialiased fonts for web pages content? I have the DejaVu family set as my fonts with pages not allowed to choose their own fonts.

    I should add that antialiasing works fine in Chromium!
    Could you post a screenshot that shows antialiased and non-antialiased text?

    I think you're referring to non-full hinting.
    ...

  10. #20
    Join Date
    Jan 2011
    Beans
    12

    How to turn off anti-alias/ ClearType/ sub-pixel smoothing

    Zorael, 31/10/09, this works -- note filename INCludes the dot, ie. "~/.fonts.conf" -- Zorael's post one time includes it, one time omits it.

    Trial and error with exactly how to combine the settings. For me:
    anti-aliasing=false
    autohint=false
    hinting=true
    hintstyle=hintfull

    When you've changed a setting, a second or two later, you'll notice some applications re-render with the new settings.

    Without being able to do a side-by-side comparison, this now looks just like Windows with ClearType turned off. Except not brilliant in Terminal. F/fox, Rythmbox, and TextPad, a Wine/Windows text editor, all brilliantly crisp.

    You need to restart F/fox for the settings to take effect across the board, eg. in menus & address bar; or just F5/refresh your web page for the document window to pick up the new settings, if it hasn't already.

    Cloink.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •