Page 1 of 6 123 ... LastLast
Results 1 to 10 of 56

Thread: skype video issue

  1. #1
    Join Date
    Jul 2008
    Location
    Berkeley
    Beans
    65
    Distro
    Ubuntu 10.04 Lucid Lynx

    skype video issue

    Skype audio works fine. When I try to video connect, they can see me, but I just get a jumbled mess of mostly white with a few random pink lines. When I try the video test, I hit the "Test" button, and the little black test video screen remains, but the "Test" button itself disappears, becoming a small transparent rectangle (so I see my desktop or firefox or whatever is immediately behind the Options window). Any guesses on how to fix it?

    If this is covered by some other thread, forgive me and please point me to it, but all the threads I can find have other problems with Skype video.

    I'm running 8.04 64-bit, btw, and updating to the latest version of Skype had no impact on the problem.

    I do recall the video test working fine when I first got Skype back in... June I think... but I don't recall what I've changed since then.

    Thanks!
    System76 Serval | nVidia 512 MB GeForce 8600M GT | Realtek ALC 268 | Core 2 Duo T9300 2.5 GHz 800 MHz FSB 6 MB L2 | 4 GB - 2 x 2 GB DDR2 667 MHZ | 200 GB 7200 RPM SATA

  2. #2
    Join Date
    Jul 2008
    Location
    Berkeley
    Beans
    65
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: skype video issue

    *bump*
    System76 Serval | nVidia 512 MB GeForce 8600M GT | Realtek ALC 268 | Core 2 Duo T9300 2.5 GHz 800 MHz FSB 6 MB L2 | 4 GB - 2 x 2 GB DDR2 667 MHZ | 200 GB 7200 RPM SATA

  3. #3
    Join Date
    Sep 2009
    Beans
    3

    Re: skype video issue

    Dont know if this is your problem sounds a bit like it
    HTML Code:
    http://www.cairo-dock.org/bg_topic.php?t=2156&pos=0

  4. #4
    Join Date
    May 2008
    Location
    Cluj, Romania
    Beans
    1,292

    Re: skype video issue

    Go here:

    http://forum.skype.com/index.php?showtopic=411441

    Find my post there. It might fix ur problem. Correct the path of the library, its different on 64 bit systems i guess. Also u might need some packages to install.

    I think the command for 64 bit is:

    LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype.real

    Just copy-pase it in a terminal.

  5. #5
    Join Date
    Jul 2008
    Location
    Berkeley
    Beans
    65
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: skype video issue

    Thanks, grad; this looks promising. However, "locate" finds no "compat.so" file, and no "libv4l" directory. Synaptic only gets one hit for "libv4l", and it's an extension library for something called "ruby". searching for "v4l" and "video4linux" get more hits, but all similar things - plugins and extensions for other things to work with v4l, not v4l itself. One difference is your post says you're running 9.04, and I'm on 8.04 (because 9.04 apparently hates my hard drive). Any thoughts on why I can't find v4l?

    Wikipedia says that v4l is closely tied to the linux kernel, and has been around since much earlier versions of the kernel than mine... and my flash works, so I imagine I have it in some sense, but I can't find it.
    System76 Serval | nVidia 512 MB GeForce 8600M GT | Realtek ALC 268 | Core 2 Duo T9300 2.5 GHz 800 MHz FSB 6 MB L2 | 4 GB - 2 x 2 GB DDR2 667 MHZ | 200 GB 7200 RPM SATA

  6. #6
    Join Date
    Jul 2008
    Location
    Berkeley
    Beans
    65
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: skype video issue

    So, at <http://ubuntuforums.org/showthread.php?p=7987358>, hardy is not listed. so to what library do you think I should point? Or maybe this hints that it's a different issue, since I installed the hardy version of Skype.
    System76 Serval | nVidia 512 MB GeForce 8600M GT | Realtek ALC 268 | Core 2 Duo T9300 2.5 GHz 800 MHz FSB 6 MB L2 | 4 GB - 2 x 2 GB DDR2 667 MHZ | 200 GB 7200 RPM SATA

  7. #7
    Join Date
    Jul 2007
    Location
    California
    Beans
    3
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: skype video issue

    *bump*

  8. #8
    Join Date
    Aug 2009
    Beans
    181
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: skype video issue

    This is what I did to get it work:
    From synaptic install lib32v4l-0
    If you installed from skype's website (the new beta) there will be no skype.real but only a skype executable. You need to rename it to skype.real
    If you already have a skype.real don't worry about it.
    Next, change/create the file skype to
    Code:
    #!/bin/bash
    LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so /usr/bin/skype.real
    Make it executable.
    Run skype from terminal. Test webcam.

    EDIT: Just realized there's no lib32v4l package in hardy. Sorry, maybe you could try intrepid's package? Actually I doubt you can because it depends on some newer packages. It's worth a try at least.
    http://packages.ubuntu.com/search?keywords=lib32v4l-0
    On the other hand you could try building it.
    Last edited by tudor117; October 25th, 2009 at 05:47 PM. Reason: no hardy package

  9. #9
    Join Date
    Apr 2007
    Beans
    31

    Re: skype video issue

    Additional solution (not related to cairo or QT?).

    For 32-bit Karmic Koala, I found this thread & solution. I have included the preload for the /usr/lib and the /usr/lib32. For me the former works and I assume the latter works for 64 bit (as skype runs in 32 bit).

    Thread: http://forum.skype.com/index.php?showtopic=411441

    ig-88 posted the lib32 solution (Part 1) and Part 2 was posted by the_wOndErEr57 and gradinaruvasile (yes, I had to see my solution twice before I realized that lib32 and lib were not the same...<grin>).

    Solution:

    Part 1 posted was:

    i use a "046d:08d9 Logitech, Inc. QuickCam IM/Connect" on ubuntu 9.04 amd64. the webcam just shows garbage while testing and simply shows nothing in calls.

    a workaround is to move /usr/bin/skype to /usr/bin/skype.real
    install lib32v4l-0 via apt-get and create a new /usr/bin/skype with the following content:
    CODE
    #!/bin/bash
    LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype.real
    #################

    Part 2 Posted was:

    QUOTE (gradinaruvasile @ Fri Aug 28 2009, 17:15)
    Go to the original post
    I have a
    0ac8:305b Z-Star Microelectronics Corp. ZC0305 WebCam

    on Ubuntu 9.04 and it is working only with the ld_preload thingie mentioned before.
    BUT the path is incorrect (maybe a distro thing?) the correct command is this one:

    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

    ****************

    In summary,
    1. sudo mv the /usr/bin/skype binary to /usr/bin/skype.real
    2. sudo gedit /usr/bin/skype
    (or your favorite text editor instead of gedit)
    3. copy & past into the editor the following

    #!/bin/bash
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype.real

    4. enter "sudo chmod 755 /usr/bin/skype" without quotes to make the script file executable
    5. start skype via the menu and test the video

  10. #10
    Join Date
    Dec 2004
    Beans
    1,029
    Distro
    Xubuntu 15.04 Vivid Vervet

    Re: skype video issue

    install lib32v4l-0 via apt-get
    What repository is this in (for Jaunty)?

Page 1 of 6 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •