Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Grub2, vga=791, Where to edit?

  1. #11
    Join Date
    Dec 2006
    Location
    USA
    Beans
    348
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Grub2, vga=791, Where to edit?

    I just found this post which was very helpful:

    http://harrison3001.blogspot.com/200...ps-to-set.html

    Basically, there are three steps:

    1. Edit /etc/default/grub and change:

    Code:
    GRUB_GFXMODE=1280x800
    to the desired resolution.

    2. Edit /etc/grub.d/00_header

    and modify lines to look like this:

    Code:
    set gfxmode=${GRUB_GFXMODE}
    set gfxpayload=keep
    insmod gfxmod
    insmod ${GRUB_VIDEO_BACKEND}
    3. Run "sudo update-grub"

    The generated grub.cfg file in /boot/grub should now have the proper settings.
    Keith
    Open.nfo

  2. #12
    Join Date
    Aug 2005
    Location
    Adelaide
    Beans
    196
    Distro
    Ubuntu Development Release

    Re: Grub2, vga=791, Where to edit?

    This gives me
    Code:
    error: unknown command 'terminal'
    at boot...

    But that could be the failed update that everyone is having.
    I get the blinking cursor of update goodness at the same time.

    Bad timing I guess
    Last edited by blakamin; September 16th, 2009 at 02:17 AM.

  3. #13
    Join Date
    Dec 2006
    Location
    USA
    Beans
    348
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Grub2, vga=791, Where to edit?

    But that could be the failed update that everyone is having.
    I get the blinking cursor of update goodness at the same time.
    Hmm. That would be my guess. I put off rebooting yesterday because of the problems with udev, etc.

    If you still get the same error messages after applying the updates, perhaps post your grub.cnf file and I can see if anything looks out of place.
    Keith
    Open.nfo

  4. #14
    Join Date
    Feb 2008
    Location
    Japan
    Beans
    31
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Grub2, vga=791, Where to edit?

    I have the same resolution 1280x800 on my DELL M1330, however when I tried editing the 00_headers file I only get garbled graphics in the terminals and shutdown screens. It also happens with 1024x768.

    Any suggestions?

  5. #15
    Join Date
    Aug 2005
    Location
    Adelaide
    Beans
    196
    Distro
    Ubuntu Development Release

    Re: Grub2, vga=791, Where to edit?

    double post, please delete
    see my last post...
    Last edited by blakamin; September 29th, 2009 at 10:28 AM. Reason: see last post

  6. #16
    Join Date
    Aug 2005
    Location
    Adelaide
    Beans
    196
    Distro
    Ubuntu Development Release

    Re: Grub2, vga=791, Where to edit?

    Quote Originally Posted by munooka View Post
    I have the same resolution 1280x800 on my DELL M1330, however when I tried editing the 00_headers file I only get garbled graphics in the terminals and shutdown screens. It also happens with 1024x768.

    Any suggestions?
    try 800x600... there is a command to find out you panel VBE resolution, but I cant remember what it was... http://en.wikipedia.org/wiki/VESA_BIOS_Extensions

    edit:
    Code:
    hwinfo --framebuffer

  7. #17
    Join Date
    Aug 2005
    Location
    Adelaide
    Beans
    196
    Distro
    Ubuntu Development Release

    Re: Grub2, vga=791, Where to edit?

    Now that the boot hassles are over...


    In /etc/default/grub
    all i did was change and uncomment
    Code:
    set gfxmode=1024x768
    then run update-grub (to be sure)

    And

    In /etc/grub.d/00_header
    All I did was add the BOLD piece where it is in this code
    Code:
    if loadfont `make_system_path_relative_to_its_root ${GRUB_FONT_PATH}` ; then
      set gfxmode=${GRUB_GFXMODE}
      set gfxpayload=keep
    IT HAS TO GO UNDER "set gfxmode..." to work!!!!


    then run update-grub again.

    Big thanks to pwnedd


    My grub.cfg has this in it
    Code:
    if loadfont /usr/share/grub/unicode.pf2 ; then
      set gfxmode=1024x768
      set gfxpayload=keep
      insmod gfxterm
      insmod vbe
      if terminal_output gfxterm ; then true ; else
        # For backward compatibility with versions of terminal.mod that don't
        # understand terminal_output
        terminal gfxterm
      fi
    Crossing fingers and going for 2 reboots


    EDIT: WORKED!! I think, hard to tell without usplash start and finish. I get no terminal text at beginning but no screen mess on shutdown!

    Big thanks to pwnedd
    Last edited by blakamin; September 29th, 2009 at 10:33 AM.

  8. #18
    Join Date
    Feb 2008
    Location
    Japan
    Beans
    31
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Grub2, vga=791, Where to edit?

    sudo hwinfo --framebuffer

    showed that my card supports 1280x800x8/24 both these settings and all other settings I have tried scrambles the tty terminals with set gfxpayload=keep (tried 640x480, 800x600, 1024x768 with or without the x8/x24 suffix). Only the 640x480x8 setting works so far. Maybe something to do with the Nvidia card in my lappy?

    Anyway thanks for the suggestions.

  9. #19
    Join Date
    Aug 2005
    Location
    Adelaide
    Beans
    196
    Distro
    Ubuntu Development Release

    Re: Grub2, vga=791, Where to edit?

    Broken again by a "pre-RC update". Great....

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •