I just found this post which was very helpful:

http://harrison3001.blogspot.com/200...ps-to-set.html

Basically, there are three steps:

1. Edit /etc/default/grub and change:

Code:
GRUB_GFXMODE=1280x800
to the desired resolution.

2. Edit /etc/grub.d/00_header

and modify lines to look like this:

Code:
set gfxmode=${GRUB_GFXMODE}
set gfxpayload=keep
insmod gfxmod
insmod ${GRUB_VIDEO_BACKEND}
3. Run "sudo update-grub"

The generated grub.cfg file in /boot/grub should now have the proper settings.