Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: How to disable user list in log-in screen?

  1. #1
    Join Date
    Sep 2009
    Beans
    77

    How to disable user list in log-in screen?

    I don't want Ubuntu to list the available users in the log-in screen. I want the old behavior back, where the user had to enter the user name before entering the password. At least that should be an easily configurable option. I have tried setting /apps/gdm/simple-greeter/disable_user_list to true, but that doesn't help.

  2. #2
    Join Date
    May 2009
    Location
    The Netherlands
    Beans
    15
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How to disable user list in log-in screen?

    Open System->Administration->Login Window. Select the Local tab.
    Change the theme to one without a list.

    Them click close

    Hope it helps
    Last edited by BadBoy4Live; September 11th, 2009 at 04:47 PM.

  3. #3
    Join Date
    Sep 2009
    Beans
    77

    Re: How to disable user list in log-in screen?

    Thanks, but I don't have "Login Window" in my System Administration menu. I have Login Screen, but that doesn't have this option.

  4. #4
    Join Date
    Apr 2008
    Location
    Pennsylvania
    Beans
    324
    Distro
    Ubuntu Karmic Koala (testing)

    Re: How to disable user list in log-in screen?

    This has been covered 100 times here already, but Karmic's GDM does not have that option available yet. As of right now the only things you can change are auto/timed logins. This will/should be changed by the time the official release comes in October.

  5. #5
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,838
    Distro
    Ubuntu Development Release

    Re: How to disable user list in log-in screen?

    Quote Originally Posted by BadBoy4Live View Post
    Open System->Administration->Login Window. Select the Local tab.
    Change the theme to one without a list.

    Them click close

    Hope it helps
    If you were using karmic you would know that this is not possible, as yet.

  6. #6
    Join Date
    May 2008
    Beans
    1,020

    Re: How to disable user list in log-in screen?

    Quote Originally Posted by Seventh Reign View Post
    This has been covered 100 times here already, but Karmic's GDM does not have that option available yet. As of right now the only things you can change are auto/timed logins. This will/should be changed by the time the official release comes in October.
    Probably even more but it's being ridiculous to logon as "vboxadd"
    OB-untu. #!crunchbang

  7. #7
    Join Date
    Sep 2009
    Beans
    1

    Re: How to disable user list in log-in screen?

    I had some luck executing the following in a terminal:
    Code:
    sudo gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults \
    --type bool --set /apps/gdm/simple-greeter/disable_user_list true
    Perhaps this will work for you?

    (source: http://forums.fedoraforum.org/showthread.php?t=205633)
    Last edited by twobturtle; September 26th, 2009 at 01:46 PM. Reason: attribution

  8. #8
    Join Date
    Jun 2009
    Beans
    5

    Talking Re: How to disable user list in log-in screen?

    Quote Originally Posted by twobturtle View Post
    I had some luck executing the following in a terminal:
    Code:
    sudo gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults \
    --type bool --set /apps/gdm/simple-greeter/disable_user_list true
    Perhaps this will work for you?

    (source: http://forums.fedoraforum.org/showthread.php?t=205633)
    twobturtle, you're a star! Just what I was looking for, and worked fine in the beta that I downloaded/installed yesterday. I did run a full update which changed an awful lot of the files installed from the original ISO, but other than that, this partition is still pretty much as it came "out of the box".

    Thanks again,
    Dox.

  9. #9
    Join Date
    Jun 2005
    Beans
    69

    Re: How to disable user list in log-in screen?

    Disregard - checking the box as user or admin doesn't work. For the life of me I thought it used to. Oh well.

    You can do this with the GConf config editor (as admin):

    apps->gdm->simple-greeter

    Check the "disable user list" box.
    Last edited by Akita; October 13th, 2009 at 11:46 PM. Reason: Doesn't or no longer works.

  10. #10
    Join Date
    Apr 2008
    Beans
    275
    Distro
    Ubuntu 10.04 Lucid Lynx

    Cool Re: How to disable user list in log-in screen?

    I agree that this is an annoying change. I can't understand why things like this are arbitrarily changed from one release to the next. If I'd wanted a face greeter, I'd have turned it on already. I'm happy to type my username. Not to mention I consider it a security risk to have all usernames exposed for anyone to see. Grr!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •