I had this installed previously, using the deb packages. I migrated to beryl, so removed the compiz packages, and now it's pretty well broken.

The deb packages indeed depend on compiz, which in turn seems to depend on csm, which I can't find anywhere.

The error I get when I try to run ./configure --with-gtk --with-xft
is the follwing:
checking for gtk+-2.0 >= 2.0.1 glib-2.0 >= 2.0.1... Package gtk+-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gtk+-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gtk+-2.0' found Package glib-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `glib-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'glib-2.0' found
configure: error: Library requirements (gtk+-2.0 >= 2.0.1 glib-2.0 >= 2.0.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.