Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: can't properly install nvidia drivers version 190

  1. #21
    Join Date
    Jan 2006
    Beans
    616
    Distro
    Ubuntu Development Release

    Re: can't properly install nvidia drivers version 190

    I've cracked down the dependency issue I think. However, I still don't get why some people arent be affected by this...
    • nvidia-glx-190 replaces nvidia-glx-185
    • nvidia-185-libvdpau depends on nvidia-glx-185
    • libxine1-bin depends on nvidia-185-libvdpau
    • libxine1-x depends on libxine1-bin
    • libxine1 depends on libxine1-x
    • phonon-backed-xine depens on libxine1
    • kdebase-runtime depends on phonon-backed-xine

    So there it is! installing nvidia-glx-190 from the vdpau ppa should inevitably get kdebase-runtime uninstalled! I'll try to see if I can get any further than this...
    ...

  2. #22
    Join Date
    Jan 2006
    Beans
    616
    Distro
    Ubuntu Development Release

    Re: can't properly install nvidia drivers version 190

    Just contacted Brandon Snider, the man in charge of the vdpau ppa (he answered a mail in less than a minute )

    This is what he mentioned:

    That's exactly right because I built the libxine packages against the 185 driver, which Nvidia considers to be the current stable driver.You'll have to do some trickery if you want to use the 190 driver with KDE.
    Soooooo, it seems kde is incompatible with this build of the 190 driver...bummer...
    ...

  3. #23
    Join Date
    Jan 2007
    Beans
    3,202

    Re: can't properly install nvidia drivers version 190

    I'm not sure whether there's a 4-leaf clover under my desk, or what -- I just came across this thread and kind of broke out in a sweat.

    I don't know anything about "vdpau" -- apparently it is not important to my use of the computer. However, I'm running Kubuntu 9.10 64-bit, and using the Beta nVidia 190.18.03 driver from here:

    http://www.nvnews.net/vbulletin/showthread.php?t=122606

    I have a GTX 260 that displays on a big Samsung 1100 CRT.

    I ran updates last night, which was pretty major (231 updated packages and 5 new ones) and included the new 2.6.28-9 kernel, and then I booted the new kernel and reinstalled the nVidia driver like I always do, and it works just fine, along with Compiz and Emerald. plasma-desktop still seems a little crash-prone (possibly caused by Compiz & Emerald, rather than KDM), although I haven't been running on the new kernel long enough to say whether it is better, worse, or about the same. So, I guess I was happy being oblivious to the problem reported on this thread.
    Last edited by dabl; September 2nd, 2009 at 04:44 PM.
    Intel Core i7-950 / Asus P6X58D-E / Nvidia GTX480 / siduction 64-bit on OCZ Revodrive SSD / KDE4.10.2/ Kubuntu 13.04

  4. #24
    Join Date
    Jan 2006
    Beans
    616
    Distro
    Ubuntu Development Release

    Re: can't properly install nvidia drivers version 190

    dabl, you don't have any problems since you're directly using the nvidia installer, wich does not provide the libxine packages that dont allow me to install from the ppa.

    Im also interested on this xine packages, cause they are compiled with vdpau support, and I dont think there's an easy way to get them without this ppa.
    ...

  5. #25
    Join Date
    Feb 2005
    Location
    Madison, WI
    Beans
    23
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: can't properly install nvidia drivers version 190

    I was having the same problem with trying to install the 190 drivers. Thanks for finding the cause of it. Did Brandon Snider give any type of time frame for when we might expect 190 support?

  6. #26
    Join Date
    Jan 2006
    Beans
    616
    Distro
    Ubuntu Development Release

    Re: can't properly install nvidia drivers version 190

    He didn't mentioned that directly, but from his words, Im guessing he might package it when 190 becomes officially stable...
    ...

  7. #27
    Join Date
    Mar 2008
    Beans
    27

    Re: can't properly install nvidia drivers version 190

    I had a similar issue this evening with my jaunty install -- I installed the 190 driver set from the vdpau PPA so I could run the Cuda2.3 SDK, and Apt/Synaptic/et al kept wanting to downgrade my nVidia drivers back to 185 so they could install the VDPAU version of libxine1.

    I've worked around this by just installing the nVidia drivers from the PPA:

    Code:
    $ cat /etc/apt/preferences
    Package: nvidia-190-*
    Pin: release o=LP-PPA-nvidia-vdpau
    Pin-Priority: 600
    
    Package: nvidia-glx-190
    Pin: release o=LP-PPA-nvidia-vdpau
    Pin-Priority: 600
    
    Package: nvidia-settings-190
    Pin: release o=LP-PPA-nvidia-vdpau
    Pin-Priority: 600
    
    Package: *
    Pin: release o=LP-PPA-nvidia-vdpau
    Pin-Priority: -1000
    After this, run:
    Code:
    $ sudo apt-get clean
    $ sudo apt-get update
    $ sudo apt-get dist-upgrade
    (APT should tell you that nothing needs upgrading)

    What this does is "pins" the packages from the nvidia-vdpau PPA. The first three lines make sure that the nvidia-190-whatever, GLX and settings panel packages take priority, and the last pinning stops any other packages from the vdpau repository from being installed.

    The catch is that when (if?) the VDPAU-capable Xine is released, you'll have to add the relevant pinnings to /etc/apt/preferences...

  8. #28
    Join Date
    Sep 2009
    Beans
    64

    Re: can't properly install nvidia drivers version 190

    The exact problem is:
    kde-runtime -> libxine1 -> libxine-x -> libxine-bin -> f*u*c*k*e*d coz libxine-bin is build against nvidia-185-libvdpau

    and no the solution from philpem did not help

    so the problem isn*t the nvidia-driver it is libxine-bin .... at least for my depency graph

    OFFTOPIC: Does anyone get sound with xine and libvdpau support when using DVB-S? I get sound drop offs all the time?

    i also don't get why libxine1 isn't just an suggested or recommended package of kde-runtime

    maybe someone can suggest an solution or post an bugreport to kde-runtime package maintainer may be that would be the easiest solution but i will go to bed now ...

    for now i'll try the binary installer from nvidia ... hope that will help


    maybe someone can suggest an solution or post an bugreport to kde-runtime package maintainer may be that would be the easiest solution but i will go to bed now ...
    Last edited by ubongo2008; September 10th, 2009 at 11:06 PM. Reason: to tired to go on today =)

  9. #29
    Join Date
    Jan 2007
    Location
    Connecticut
    Beans
    1,629
    Distro
    Ubuntu Development Release

    Re: can't properly install nvidia drivers version 190

    Quote Originally Posted by lithorus View Post
    I use this ppa and have no problems with all the latest packages :

    (yes, it's supposed to say jaunty)
    http://ubuntuforums.org/showpost.php...7&postcount=18

    hey that worked for me using jaunty!

    i had been trying for weeks getting the 190.* drivers installed....kept running into that wall with the kde and xine stuff. added the repo from the link above and #'ed out the other nvida repos....bingo, the only kde package that was uninstalled in the process was kdelive, which doesn't affect anything that i need. it installed some other xine & kde packages and right now all seems good. vdpau is working properly with both xine and mplayer.

    looks like there are karmic packages there as well.

    thanks lithorus.
    MOTHERBOARD: GIGABYTE GA-990FXA-UD5, CPU: AMD FX-8150 Zambezi
    MEMORY: G.SKILL Ripjaws Z Series 32GB (4 x 8GB),
    VIDEO CARD: ASUS GTX480
    SSDs: Kingston HyperX 3K 120Gb, PNY XLR 120Gb
    OS: Ubuntu Release Candidate, openSuse, Win8.



Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •