Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: No sound in Karmic Koala

Hybrid View

  1. #1
    Join Date
    Aug 2009
    Location
    Chilliwack, BC, Canada
    Beans
    12
    Distro
    Ubuntu Karmic Koala (testing)

    No sound in Karmic Koala

    Hey, just upgraded from Jaunty to Karmic and as soon as my machine rebooted from the upgrade I'm completely without sound, and can't even add the volume control, it says (Deprecated) beside it.

    I've done a couple searchs, and found people with the same problem, but no results anyone know what the cause of this is?

  2. #2
    Join Date
    May 2009
    Beans
    1,934
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: No sound in Karmic Koala

    Quote Originally Posted by Tarkers View Post
    Hey, just upgraded from Jaunty to Karmic and as soon as my machine rebooted from the upgrade I'm completely without sound, and can't even add the volume control, it says (Deprecated) beside it.

    I've done a couple searchs, and found people with the same problem, but no results anyone know what the cause of this is?
    Have you filed a bug report through launchpad?

    Once the fix is found, it will happen in a future release.

    Stay tuned as someone may post a way to fix it yourself.

  3. #3
    Join Date
    Aug 2009
    Location
    Chilliwack, BC, Canada
    Beans
    12
    Distro
    Ubuntu Karmic Koala (testing)

    Re: No sound in Karmic Koala

    I couldn't quite figure out how to file the bug with launchpad, I seem to have got in a login loop through UbuntuOne

    Anyways, I hope someone can help me out, I've been working on this most of the day and can't find any resolution.

  4. #4
    Join Date
    May 2007
    Location
    The New Forest
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: No sound in Karmic Koala

    moved to karmic forum
    Forum Social IRC Channel
    Xubuntu IRC Support
    Xubuntu Support

    Please do not PM me about Registration issues without having been asked to. I will tell you to post here

  5. #5
    Join Date
    Aug 2009
    Location
    Norwich, Norfolk, England
    Beans
    11
    Distro
    Ubuntu

    Re: No sound in Karmic Koala

    I've been experiencing a lot of issues with sound under Karmic as well.

    • Initial install of Alpha 2 sound worked
    • Install of Alpha 3 sound broke later I discovered it was working but only through headphones nothing I tried would make it work through the laptop speakers
    • Nearing the end of Alpha 3 there was a kernel update and then a pulse audio update this fixed the issue.
    • Updating to Alpha 4 totally broke the sound for the system.

    I haven't managed to fix the issue myself but I think its something to do with a driver or kernel module not being loaded. Unfortunally after the problem was solved I deleted all the logs and notes I had releating to the issue.

    In your case you might want to try following the step by step on here http://ubuntuforums.org/showthread.php?t=205449 to see if it can solve your issue or at least diagnose exactly what the problem is.
    Last edited by chronosMark; August 18th, 2009 at 09:13 AM.

  6. #6
    Join Date
    Aug 2009
    Location
    Chilliwack, BC, Canada
    Beans
    12
    Distro
    Ubuntu Karmic Koala (testing)

    Re: No sound in Karmic Koala

    Quote Originally Posted by chronosMark View Post
    I've been experiencing a lot of issues with sound under Karmic as well.

    • Initial install of Alpha 2 sound worked
    • Install of Alpha 3 sound broke later I discovered it was working but only through headphones nothing I tried would make it work through the laptop speakers
    • Nearing the end of Alpha 3 there was a kernel update and then a pulse audio update this fixed the issue.
    • Updating to Alpha 4 totally broke the sound for the system.

    I haven't managed to fix the issue myself but I think its something to do with a driver or kernel module not being loaded. Unfortunally after the problem was solved I deleted all the logs and notes I had releating to the issue.

    In your case you might want to try following the step by step on here http://ubuntuforums.org/showthread.php?t=205449 to see if it can solve your issue or at least diagnose exactly what the problem is.
    Hey ChronosMark, I'm following those instructions, I'm not sure if you're very familiar with the steps yourself but I figured I should ask here anyways and someone might know. following those steps it directs me to the ALSA project to see if they have my chipset there (Which they should, sound was fine in Jaunty) anyways, I can't seem to find the mentioned dropdown to search for any chipsets, did their website change somewhere along the way? If anyone knows where I can search for my chipset that would be awesome.

    Edit: here's my driver information, I figured I might as well throw it in here too.

    00:10.2 Multimedia audio controller: nVidia Corporation MCP51 AC97 Audio Controller (rev a2)
    Subsystem: Biostar Microtech Int'l Corp Device 8213
    Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
    I/O ports at dc00 [size=256]
    I/O ports at d800 [size=256]
    Memory at fe02c000 (32-bit, non-prefetchable) [size=4K]
    Capabilities: <access denied>
    Kernel driver in use: Intel ICH
    Kernel modules: snd-intel8x0

    I notice it's using Intel ICH for a driver, which used to be listed as a sound device in Jaunty, but I didn't use it since it also had another one that did work.
    Last edited by Tarkers; August 18th, 2009 at 02:40 PM. Reason: Adding more information

  7. #7
    Join Date
    Feb 2006
    Beans
    24
    Distro
    Ubuntu Karmic Koala (testing)

    Re: No sound in Karmic Koala

    Quote Originally Posted by Tarkers View Post
    Hey, just upgraded from Jaunty to Karmic and as soon as my machine rebooted from the upgrade I'm completely without sound, and can't even add the volume control, it says (Deprecated) beside it.

    I've done a couple searchs, and found people with the same problem, but no results anyone know what the cause of this is?

    had a similar problem on a fresh installed Karmic (thinkpad t61).
    deleted ~/.pulse
    ( rm -r ~/.pulse )
    and restarted pulseaudio
    ( killall pulseaudio )

    solved for me (make sure speakers and headphones are not muted:
    alsamixer

    (the square underneath the headphones & speakers should be green by clicking "m")
    hope that helps

  8. #8
    Join Date
    Aug 2009
    Location
    Norwich, Norfolk, England
    Beans
    11
    Distro
    Ubuntu

    Re: No sound in Karmic Koala

    Quote Originally Posted by curley_sue View Post
    deleted ~/.pulse
    ( rm -r ~/.pulse )
    and restarted pulseaudio
    ( killall pulseaudio )
    This fixed my sound thanks curely_sue.

  9. #9
    Join Date
    Apr 2007
    Beans
    Hidden!

    Re: No sound in Karmic Koala

    Yes, for some reason the sound got muted after the update I did (included rc6 kernel). You can right-click the volume control applet -> sound preferences, and check if the audio is muted in the master volume or applications one. This did it for me.

  10. #10
    Join Date
    Apr 2007
    Beans
    1,110
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: No sound in Karmic Koala

    this is going to be a problem for audigy users since you still need alsa-utils from jaunty and not from karmic to force enable audigy as the primary audio recorder. I had issues with mic not wanting to record so I had to kill and uinstall pulseaudio. and install ...

    ill post some notes. It's mixed up a bit but its what I currently use to fix all the encarnations of ubuntu for my sound card and the only way i managed to get audio working. In karmic koala, something new happened. I cannot change the boot sound or use the theme sound since it all now runs through pulseaudio sound manager which i think really sucks at the moment.

    Code:
    ********************************************************************************
    ********************************************************************************
    ********************************************************************************
    jaunty removing pulseaudio******************************************************
    ********************************************************************************
    #killall pulseaudio
    #sudo apt-get remove pulseaudio
    #sudo apt-get install esound
    #sudo apt-get install gnome-alsamixer
    #sudo apt-get install
    #install jaunty alsa-utils_1.0.18-1ubuntu11_amd64.deb
    #sudo rm /etc/X11/Xsession.d/70pulseaudio (do not do this just incase)
    #Reboot system
    
    use gnome-alsamixer to keep a check on only tone, mic boost, audigy analog/digital output jack
    for alsamixer mic to work, i bumped up the mic record and analog mix rec up to work, I #alsamixer or created a button to execute #gnome-terminal --execute alsamixer
    ********************************************************************************
    ********************************************************************************
    ********************************************************************************
    test audio in also terminal*****************************************************
    ********************************************************************************
    #speaker-test -Dplug:surround51 -c6 -twav
    #speaker-test -Dplug:surround51 -c6 -l1 -twav
    #speaker-test -Dplug:surround40 -c4 -l1 -twav
    #speaker-test -Dplug:surround51 -c6 -l1 -twav
    #speaker-test -Dplug:surround71 -c8 -l1 -twav
    ********************************************************************************
    ********************************************************************************
    ********************************************************************************
    pulseaudio 5.1******************************************************************
    ********************************************************************************
    #sudo gedit /etc/pulse/daemon.conf
    
    Uncomment the line containing:
    default-sample-channels = 2
    
    and replace '2' with '6' (if you have a 7.1 card, replace '2' with '8')
    Restart the window manager and enjoy the new sound!
    ********************************************************************************
    ********************************************************************************
    ********************************************************************************
    mic fix*************************************************************************
    ********************************************************************************
    #sudo apt-get install asoundconf-gtk
    So then I created a script
    
    ##!/bin/bash
    #sleep 10 && asoundconf set-default-card Audigy2;
    
    and forced executable and forced it to autoboot in sessions under preferences.  Now my sound recorder works
    
    other commands
    #asoundconf set-default-card Audigy2
    #asoundconf list
    #
    
    
    on another note, i did an install of openAl in synaptics.  All this was necessery to get sound in quake wars working and also mic.  without this, it is totally impossible

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •