Page 2 of 9 FirstFirst 1234 ... LastLast
Results 11 to 20 of 85

Thread: Realtek rtl8192e wireless not seen

  1. #11
    Join Date
    Nov 2009
    Beans
    114
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek rtl8192e wireless not seen

    Another update of sorts for this chipset.

    I replied to realtek with my issues with the last driver they sent me, dated 0106.2009 and included my errors from the terminal, and my research into why that particular driver would not compile.

    They have now replied back with a new driver attached dated 1029.2009. Hopefully this one will compile properly and work so that we can get away from ndiswrapper. They seem very eager to help and support this chipset in linux.

    I will give this driver a try today and report back with my results.

  2. #12
    Join Date
    Nov 2009
    Beans
    114
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek rtl8192e wireless not seen

    Success!

    The new driver from realtek works fine, and better than the windows driver through ndiswrapper.

    The file size is too large to upload here so I'm not sure what avenues I can take to get this driver to anyone that needs/wants it. If a mod or admin can tell me where I can/should upload this driver, please reply or send me a PM.

    I may just set up a rapidshare link or something if there is no better option.

    I will post back later with the link to download, depending on what I figure out.

  3. #13
    Join Date
    Nov 2009
    Beans
    114
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek rtl8192e wireless not seen

    Ok, I have uploaded it to rapidshare for the time being. Unfortunately I don't have a rapidshare account so their site says it can be downloaded 10 times.

    Hopefully that will be enough to find somewhere more permanent to host the file for those that need it.

    Link: http://rapidshare.com/files/30793587...09.tar.gz.html

    MD5: 379F53A4B81A478506A64E49FDBC8126


    And, for anyone that would like to know the steps I went through to compile and install the driver, here is what I did. Not sure if I made too many steps or not enough, but my experience is still limited with linux. It worked for me, hopefully it will work for everyone else.

    First, I downloaded the file and extracted it to a folder.

    Then since I was using the windows wireless driver with ndiswrapper, I opened network manager, and disconnected from my router.

    Then I opened ndsiwrapper and removed the windows driver. Then went to synaptic and removed the three entries for ndsiwrapper. I marked them for complete removal so there was no chance of the ndiswrapper driver hanging on to the wireless device.

    Then rebooted and and checked to make sure my wireless was no longer detected.

    Then open a terminal, and cd to the folder where the driver is extracted.

    Then.

    Code:
    sudo make
    then it compiled, but 'sudo make install' gave errors, so i did.

    Code:
    sudo su
    and that gave me a root prompt, then.

    Code:
    make install
    Then rebooted again.

    When it rebooted, it didn't detect my wireless, but lspci -vv showed my wireless device using the new driver. So, after a few attempts at trying to start up the wireless, I finally, from a terminal, cd to the driver directory again, then.

    Code:
    sudo ./wlan0up
    And away it went. Connected and working.

    Haven't tried another reboot yet to see if it will automatically detect it on subsequent boots, but that will be the next order of business.

    Good luck everyone!

  4. #14
    Join Date
    Apr 2009
    Beans
    42

    Re: Realtek rtl8192e wireless not seen

    Evening,
    Toshiba A505D-S6958
    RTL8192e
    AMD Turion X2
    ATI Radeon
    4GB RAM
    Ubuntu 9.0.4

    Thanks!! I downloaded it, followed your instructions and it seems to be doing well. Ony a few questions though...
    1. My RTL8192e is seen as WLAN1 when I run iwconfig:
    lo no wireless extensions.

    eth0 no wireless extensions.

    pan0 no wireless extensions.

    wlan1 802.11bgn Nickname:"rtl8192E"
    Mode:Managed Frequency=2.422 GHz Access Point: Not-Associated
    Bit Rate:1 Mb/s
    Retryn RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff
    Link Quality=10/100 Signal level=0 dBm Noise level=-100 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    Should I set the wireless config for Ad hoc or Infrastructure? ON my home network it connects with WEP and is set to infrastructure...When I tried it at work, connections were very hard to maintain even thoug there was a strong signal. Our wireless guest network there does not use security but is limited with what you can access...
    Thanks again, looking forward to hearing more good news!!
    Tony ...

  5. #15
    Join Date
    Nov 2009
    Beans
    114
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek rtl8192e wireless not seen

    Don't have an answer for why it is wlan1 instead of wlan0, but I don't think it really matters as long as it works. It could possibly be that ndiswrapper may still have ahold of wlan0.

    I think the ad-hoc/infrastructure setting is more of a router side setting rather than a driver setting, however i'm not completely clear on that.

    My wireless wouldn't automatically start on boot and I had to start it manually every time. I have since installed wicd from the repositories and it in turn removes network manager, I'm hoping that will solve my isseue.

  6. #16
    Join Date
    Nov 2009
    Beans
    6

    Re: Realtek rtl8192e wireless not seen

    I shall try this on my Toshiba u500 later today and give you an update.

  7. #17
    Join Date
    Nov 2009
    Beans
    114
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek rtl8192e wireless not seen

    OK! Figured it out!

    Once the driver is installed, to get the wireless to start on boot you need to edit your /etc/modules file.

    Code:
    sudo gedit /etc/modules
    Then simply add r8192e_pci on a line and save the file.

    Code:
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.
    r8192e_pci
    When you reboot, your wireless should start automatically.

  8. #18
    Join Date
    Nov 2009
    Beans
    6

    Re: Realtek rtl8192e wireless not seen

    So, I'm having some problems with it. The driver installed, following the instructions, and having to do a ./wlan0up each time, but when I do, it doesn't find any networks where I know there are some. Also adding that line to the modules file does not do anything for me, and I have to do a ./wlan0up each time, and it doesn't find any networks anyways.

    Back to ndiswrapper for me I guess...

  9. #19
    Join Date
    Nov 2009
    Beans
    114
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek rtl8192e wireless not seen

    I wonder if it has to do with you using 64bit and this is the 32bit driver?

    Did you make sure you removed ndiswrapper (complete removal) and reboot so ndiswrapper lets go of the device?

    I also removed network manager and installed wicd in an earlier step, wonder of that would help?

    You might want to do like me and e-mail realtek and see if they have a 64 bit driver, that might be the issue on its own.

    It should work, I'm sure we can find a way.

  10. #20
    Join Date
    Jun 2008
    Beans
    27

    Re: Realtek rtl8192e wireless not seen

    Quote Originally Posted by Dude-PWB- View Post

    Link: http://rapidshare.com/files/30793587...09.tar.gz.html

    MD5: 379F53A4B81A478506A64E49FDBC8126

    File will not download any more, says it was downloaded to many times. Can you upload it again. That is what it said you need to do.

    Thanks, Mike

Page 2 of 9 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •