Page 19 of 38 FirstFirst ... 9171819202129 ... LastLast
Results 181 to 190 of 378

Thread: Asus T91 linux installation

  1. #181
    Join Date
    Nov 2009
    Location
    Queensland, Australia
    Beans
    54
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus T91 linux installation

    I love being able to set a long-short tap combo to emulate a right click. However, a word of warning: Doing this causes crashes in at least gimp: Holding and dragging won't paint when right-click emulation is set up and after a short while it crashes everything (only alt+prt-scr+REISUB works, and even that doesn't after a while).

  2. #182
    Join Date
    Aug 2009
    Beans
    6

    Re: Asus T91 linux installation

    Quote Originally Posted by DrPotoroo View Post
    I love being able to set a long-short tap combo to emulate a right click. However, a word of warning: Doing this causes crashes in at least gimp: Holding and dragging won't paint when right-click emulation is set up and after a short while it crashes everything (only alt+prt-scr+REISUB works, and even that doesn't after a while).
    How did you get that set up?

  3. #183
    Join Date
    Nov 2009
    Location
    Queensland, Australia
    Beans
    54
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus T91 linux installation

    Quote Originally Posted by virati View Post
    How did you get that set up?
    I followed the instructions at http://www.ced-network.net/blog/2009...ntu-904jaunty/ under the section "Configuring the touchscreen events".

    I think that something about the "longtouch" settings messes with programs where you click and drag to do something. I have turned it off again now because I do like being able to use gimp to draw up diagrams on the touchscreen.

  4. #184
    Join Date
    Nov 2009
    Location
    Queensland, Australia
    Beans
    54
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus T91 linux installation - next G pairing

    After installing blueman I was able to pair with my next G phone using bluetooth and get internet access. However, it then mysteriously stopped working: the connection would say it was successful but I couldn't actually connect to anything. The solutions seems to have been setting my netbook back to "untrusted" in my phone settings so that I had to acknowledge each initial connection request on the phone. After that it works again.

    Edit: Actually, forget all that. It later stopped working again, and then I got it to work with the netbook "trusted" again. Must be another problem.
    Last edited by DrPotoroo; January 25th, 2010 at 05:45 AM. Reason: Correction

  5. #185
    Join Date
    Jan 2010
    Location
    Netherlands
    Beans
    3
    Distro
    Ubuntu UNR

    Re: Asus T91 linux installation

    Quote Originally Posted by kgingeri View Post
    Hey I got multi-touch working by install this fdi file and restarting, then going to System Prefs -> Mouse and clicking scrolling settings (these had no effect previously)

    I don't have it working for the screen yet tho :/
    Could you clarify the way you made this work? The .fdi file included does not seem to be the one where you made your two finger scrolling work.

    Does anyone know how to enable the mult touchpad on the T91MT?

  6. #186
    Join Date
    Nov 2008
    Location
    Southern Ontario, Canada
    Beans
    296
    Distro
    Ubuntu UNR

    Re: Asus T91 linux installation

    Quote Originally Posted by XeoNiCaLiTy View Post
    Could you clarify the way you made this work? The .fdi file included does not seem to be the one where you made your two finger scrolling work.

    Does anyone know how to enable the mult touchpad on the T91MT?
    Seems my attachments got lost in post #163 - I've put them there again.

    Here are the two files I have mod'd and am currently running with (see attached and rename without ".txt" - ie 'mv <filename>.txt <filename>'.
    Copy into place by using 'sudo cp <filename>.fdi /usr/share/hal/fdi/policy/20thirdparty' - both files in that folder) and reboot

    EDIT: BTW two finger works for me vertically and horizontally

    EDIT: NOTE! This is for the trackpad only!

    EDIT2: Thought I should include my /etc/X11/xorg.conf file also, as there can be conflicts between fdi defs and xorg.conf (at least that what I have found)...
    Code:
    Section "Device"
            Identifier      "GMA500"
            Option 		"AccelMethod" "EXA"
            Option 		"MigrationHeuristic" "greedy"
            Option 		"IgnoreACPI" "yes"
            Driver 		"psb"
    EndSection
    
    Section "DRI"
        Mode    0666
    EndSection
    That's it - no more and no less!
    And also my /etc/default/grub file (be sure to run 'update-grub' after edits)
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    # items are zero based 1 per line as displayed in the grub menu
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT="1"
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet nosplash mem=786mb"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"
    (tho this has little to do with the touch pad, more with performance of the display)
    Attached Files Attached Files
    Last edited by kgingeri; February 16th, 2010 at 07:00 PM. Reason: Added info

  7. #187
    Join Date
    Jan 2010
    Location
    Netherlands
    Beans
    3
    Distro
    Ubuntu UNR

    Re: Asus T91 linux installation

    Quote Originally Posted by kgingeri View Post
    Seems my attachments got lost in post #163 - I've put them there again.

    Here are the two files I have mod'd and am currently running with (see attached and rename without ".txt" - ie 'mv <filename>.txt <filename>'.
    Copy into place by using 'sudo cp <filename>.fdi /usr/share/hal/fdi/policy/20thirdparty' - both files in that folder) and reboot

    EDIT: BTW two finger works for me vertically and horizontally

    EDIT2: Thought I should include my /etc/X11/xorg.conf file also, as there can be conflicts between fdi defs and xorg.conf (at least that what I have found)...
    Code:
    Section "Device"
            Identifier      "GMA500"
            Option         "AccelMethod" "EXA"
            Option         "MigrationHeuristic" "greedy"
            Option         "IgnoreACPI" "yes"
            Driver         "psb"
    EndSection
    
    Section "DRI"
        Mode    0666
    EndSection
    That's it - no more and no less!
    And also my /etc/default/grub file (be sure to run 'update-grub' after edits)
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    # items are zero based 1 per line as displayed in the grub menu
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT="1"
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet nosplash mem=786mb"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"
    (tho this has little to do with the touch pad, more with performance of the display)
    Worked like a charm.

    We have only a couple of issues left:

    Sleep
    Hibernate
    Touch screen (flicks, rotate +90+90+90 instead of +90-90, multitouch)

    Will post when I fix one of these!

  8. #188
    Join Date
    Jan 2010
    Beans
    1

    Re: Asus T91 linux installation

    I am running Karmic 2.6.32-17 - the latest as of this post - and I have no idea if this will work for anything else.
    I am running 2.6.31-18-generic and it worked for me too. Thanks!

    I did the following steps from the provided instructions
    1. Install the video psb drivers via instructions in blog post
    2. do "sudo apt-get install xserver-xorg-input-evtouch"
    3. download the source/binaries from the attachment of post #171
    4. do "tar -xvzf xf86-input-evtouch-0.8.8-T91MT.tar.gz"
    6. do "sudo cp 50-asustek.fdi /usr/share/hal/fdi/policy/20thirdparty/50-asustek.fdi"

    7. restart and hope best .. didn't helped. (Was it supposed to be enough ? I understood so from post #171)

    8. do "cd xf86-input-evtouch-0.8.8-T91MT"

    9. do "sudo cp /usr/lib/xorg/modules/input/evtouch_drv.so /usr/lib/xorg/modules/input/evtouch_drv.so.save"
    10. do "sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.save"
    11. do "sudo cp ./.libs/evtouch_drv.so /usr/lib/xorg/modules/input/evtouch_drv.so"
    12. do "sudo cp ./xorg.conf /etc/X11/"
    13. Shutdown and restart, and it was working.

    Again thanks for SamT91MT and kgingeri

  9. #189
    Join Date
    Aug 2009
    Beans
    22

    Re: Asus T91 linux installation

    Quote Originally Posted by XeoNiCaLiTy View Post
    We have only a couple of issues left: Sleep, Hibernate, Touch screen (flicks, rotate +90+90+90 instead of +90-90, multitouch)
    What is the current status of sleep/hibernate? Working never/sometimes/often?

    Also, has anyone upgraded the SSD (likely voiding the warranty) to 64Gb or larger?

    scott

  10. #190
    Join Date
    Jan 2010
    Beans
    2

    Re: Asus T91 linux installation

    Hi,

    I have been following this thread and is really thankful for all the great info.
    Suspend has worked for me all the time time, the problem has been that the when resuming the wireless was completely dead.

    I did spend som time and found some old issues and copied something that worked before.

    http://forum.eeebuntu.org/viewtopic.php?f=3&t=4136

    The short story to get it working for me was adding
    "pciehp.pciehp_force=1 pciehp.pciehp_poll_mode=1" to the end of /etc/default/grub.conf default boot string. And running update-grub.

    Now suspend works with psb and touch screen.

    Do not know if this is required but I'm using the latest compat-wireless from linuxwireless.org
    (http://www.orbit-lab.org/kernel/comp...33-rc5.tar.bz2)
    (The changelog from end of december describes suspend issues with ath9k, and therefore was this updated one of the first ones i did).

    Someone might try the added boot string with backport version of linux wireless from ubuntu.

    Unfortunate I have had one freeze, do not know if it is from wireless or the touch screen.

    /markus

Page 19 of 38 FirstFirst ... 9171819202129 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •