Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: compiling

  1. #1
    Join Date
    May 2008
    Location
    India
    Beans
    297
    Distro
    Ubuntu 11.04 Natty Narwhal

    compiling

    Code:
    appy@appy-desktop:~/sphinx2$ ./configure – prefix=/usr
    configure: WARNING: you should use --build, --host, --target
    configure: WARNING: invalid host type: –
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... mawk
    checking whether make sets $(MAKE)... yes
    checking for style of include used by make... GNU
    checking for –-gcc... no
    checking for gcc... gcc
    checking for C compiler default output file name... configure: error: C compiler cannot create executables
    See `config.log' for more details.
    help me out

  2. #2
    Join Date
    Apr 2008
    Location
    Greece, Athens
    Beans
    576
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: compiling

    Code:
    sudo apt-get install build-essential
    ("make" is not installed)
    8.10 on HDX16-1050ev
    #22144
    My Ubuntu Blog

  3. #3
    Join Date
    May 2008
    Location
    India
    Beans
    297
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: compiling

    i cannot get u

  4. #4
    Join Date
    Apr 2008
    Location
    Greece, Athens
    Beans
    576
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: compiling

    You must install other packages in order to be able to compile. What you have to do is run a terminal (<alt>+F2 then type "gnome-terminal") and in the terminal type
    Code:
    sudo apt-get install build-essential
    The error you get means that you miss the "make" package. Installing the build-essential package with the above command you won't have this problem
    8.10 on HDX16-1050ev
    #22144
    My Ubuntu Blog

  5. #5
    Join Date
    May 2008
    Location
    India
    Beans
    297
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: compiling

    got it
    but then dis
    Code:
    appy@appy-desktop:~/sphinx2$ ./configure – prefix=/usr
    configure: WARNING: you should use --build, --host, --target
    configure: WARNING: invalid host type: –
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... mawk
    checking whether make sets $(MAKE)... yes
    checking for style of include used by make... GNU
    checking for –-gcc... no
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables... 
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking dependency style of gcc... gcc3
    checking for library containing strerror... none required
    checking for –-gcc... gcc
    checking whether we are using the GNU C compiler... (cached) yes
    checking whether gcc accepts -g... (cached) yes
    checking for gcc option to accept ANSI C... (cached) none needed
    checking dependency style of gcc... (cached) gcc3
    checking for gcc option to accept ANSI C... none needed
    checking how to run the C preprocessor... gcc -E
    checking for egrep... grep -E
    checking for ANSI C header files... yes
    checking whether byte ordering is bigendian... no
    checking return type of signal handlers... void
    checking build system type... Invalid configuration `–': machine `–' not recognized

  6. #6
    Join Date
    Apr 2008
    Location
    Greece, Athens
    Beans
    576
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: compiling

    Use "-prefix=/usr". You have a space between "-" and "prefix..."
    8.10 on HDX16-1050ev
    #22144
    My Ubuntu Blog

  7. #7
    Join Date
    May 2008
    Location
    India
    Beans
    297
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: compiling

    Code:
    appy@appy-desktop:~/sphinx2$ ./configure –prefix=/usr
    configure: error: invalid variable name: –prefix

  8. #8
    Join Date
    Apr 2008
    Location
    Greece, Athens
    Beans
    576
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: compiling

    ./configure --prefix=/usr
    8.10 on HDX16-1050ev
    #22144
    My Ubuntu Blog

  9. #9
    Join Date
    Aug 2007
    Location
    Manchester, UK
    Beans
    10,285
    Distro
    Ubuntu

    Re: compiling

    I thought it was
    Code:
    --prefix=/usr

  10. #10
    Join Date
    May 2008
    Location
    India
    Beans
    297
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: compiling

    what should be the last line of the confi?

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •