Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Atheros ar928x - Was sort of working, now is entirely gone

  1. #11
    Join Date
    Mar 2007
    Location
    Kansas City metro
    Beans
    596
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros ar928x - Was sort of working, now is entirely gone

    @legolover64:
    See this thread.
    http://ubuntuforums.org/showthread.php?t=1238766

    It helped me solve my problem. It seems jockey is blacklisting atheros drivers if you try using proprietary driver then switching back.

    I also think I found another source for downloading a .deb package for your madwifi driver. Problem is I need to go to another installation to see if the history is still there from getting it a week ago.

    I'll repost later.
    Reading Sticky Threads is informative and saves time.



  2. #12
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Atheros ar928x - Was sort of working, now is entirely gone

    I don't know how orthodox this would be, but perhaps we can try something? I was thinking we could set up a screen session on the box, and have you SSH into it. There's currently nothing important on the computer, so it wouldn't bother me if you were poking around as root. Then, we could post what we found on the forums for future people with this card/computer. If this isn't appropriate, please let me know, but it seemed like an interesting idea...
    The thread mentioned by djchandler above seems worth looking into to (I noticed that strange /etc/modprobe.d/blacklist-ath_pci.conf file the other day; I didn't realize it was there before), but if that doesn't help, I'm happy to try ssh'ing in and see if I can figure anything out. Just send me the IP address and login credentials by private message, and please make sure port forwarding on your router is set up appropriately if applicable.

  3. #13
    Join Date
    Mar 2007
    Location
    Kansas City metro
    Beans
    596
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros ar928x - Was sort of working, now is entirely gone

    http://madwifi-project.org/ just has source code. I must have downloaded the .deb of compiled code from the site that is down now (madwifi.org).
    Reading Sticky Threads is informative and saves time.



  4. #14
    Join Date
    Oct 2006
    Beans
    19

    Re: Atheros ar928x - Was sort of working, now is entirely gone

    Quote Originally Posted by pytheas22 View Post
    The thread mentioned by djchandler above seems worth looking into to (I noticed that strange /etc/modprobe.d/blacklist-ath_pci.conf file the other day; I didn't realize it was there before), but if that doesn't help, I'm happy to try ssh'ing in and see if I can figure anything out. Just send me the IP address and login credentials by private message, and please make sure port forwarding on your router is set up appropriately if applicable.
    Thanks for the thread djchandler! And, thanks again pytheas22 for walking me through everything.

    Unfortunately, after adding ath_pci, ath_hal and ath9k, still no dice. I tried removing ath_pci from the excluded list, but it unfortunately does not work :/. In either of those configurations, there is no wireless interface within ifconfig, leaving the system to only work on ethernet for the network.

    I am going to hook up the machine to SSH later tonight, and forward 22 through to the computer. I will PM you with the details, pytheas22. Thanks again for all your help!

  5. #15
    Join Date
    Feb 2005
    Beans
    30

    Re: Atheros ar928x - Was sort of working, now is entirely gone

    I don't know if this is helpful, but I have no problem with the wifi of my T1028M with Karmic Koala Netbook Remix.
    Although it did not work in live-cd mode, it worked after installation & updating via ethernet (before the update, nm-applet would crash while connecting).
    See also
    http://ubuntuforums.org/showthread.php?t=1275975

  6. #16
    Join Date
    Mar 2007
    Location
    Kansas City metro
    Beans
    596
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Atheros ar928x - Was sort of working, now is entirely gone

    Finally got an answer from launchpad on the Jockey bug that is blacklisting the driver.

    OK, thanks. Jockey should look into this file as a special case, unless
    it's a conffile (I have to check).

    ** Changed in: jockey (Ubuntu)
    Importance: Undecided => Low

    ** Changed in: jockey (Ubuntu)
    Status: Incomplete => Triaged

    --
    jockey not restoring ath5k driver from blacklist
    https://bugs.launchpad.net/bugs/413781
    You received this bug notification because you are a direct subscriber
    of the bug.
    Stay tuned.

    @beke,
    When you combined threads, it dragged all the subscribers of those threads into the new combined thread. I suggest you use that feature sparingly. Somehow I don't think that's supposed to happen. If you are doing this to try to cross-post, it is contrary to the terms of service.
    See:
    http://ubuntuforums.org/index.php?page=policy

    If you're trying to avoid cross-posting, I don't think it worked correctly.

    I don't think I have seen this occur on this forum before. Suggest you contact the moderators to see how it is supposed to work.

    djc
    Last edited by djchandler; September 28th, 2009 at 04:11 PM. Reason: additions
    Reading Sticky Threads is informative and saves time.



Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •