Results 1 to 4 of 4

Thread: various recording problems

  1. #1
    Join Date
    Feb 2007
    Location
    Vienna, Austria
    Beans
    144
    Distro
    Ubuntu Development Release

    Question various recording problems

    Hi guys,

    I have a couple of issues that prevent me from recording my songs and I'm hoping you could help me with it. I'm currently using Jokosher, but I have the same problem with other multitrack programs such as audacity.

    First of all, I start by importing a drum track done with Hydrogene. That works pretty well, but the first beat is cut, so it starts a split of a second late. That is not too bad though, I can live with that.

    The next thing is that whenever I add another instrument, say a guitar, and start recording via a microphone plugged in to the mike-out of my laptop, it also records the drum track again on the guitar track. It is as if the computer would not only record the input from the microphone, but also the output of the soundcard. How can I stop this?

    Also, there is always a delay for the guitar track (or whatever track I add), but I guess this is caused by the kernel, afaik. Is there an easy solution for this, other than moving the tracks around until they fit?

    Many thanks for your help!

  2. #2
    Join Date
    Dec 2006
    Beans
    1,541

    Re: various recording problems

    Quote Originally Posted by Lorenz View Post
    Hi guys,

    I have a couple of issues that prevent me from recording my songs and I'm hoping you could help me with it. I'm currently using Jokosher, but I have the same problem with other multitrack programs such as audacity.

    First of all, I start by importing a drum track done with Hydrogene. That works pretty well, but the first beat is cut, so it starts a split of a second late. That is not too bad though, I can live with that.

    The next thing is that whenever I add another instrument, say a guitar, and start recording via a microphone plugged in to the mike-out of my laptop, it also records the drum track again on the guitar track. It is as if the computer would not only record the input from the microphone, but also the output of the soundcard. How can I stop this?

    Also, there is always a delay for the guitar track (or whatever track I add), but I guess this is caused by the kernel, afaik. Is there an easy solution for this, other than moving the tracks around until they fit?

    Many thanks for your help!
    Hi, without a dedicated audio interface, you'll need Ubuntu Studio 8.04 and its real-time kernel, to have lag-free recording. And in the preference or options pages of Jokosher/audacity etc, you will have to experiment with the options to monitor your first track, while recording a second track. Once you install 8.04 (or Studio64, JAD, Musix, or avlinux2) upgrade the apps you use, and make connections in qjackctl. The audacity connection only appears after pressing the record button, and select what device to record, using its preferences recording pages. Its input is called portaudio, in the qjackctl panel, press the pause button while you connect things, press it again to resume recording. Not sure about jokosher, probably similar.

    In the meantime, in qjackctl, open the settings panel, and set the priority to 70, and see if that helps with the lag. It won't help unless the apps you use are connected in qjackctl. Ardour is another recording option worth spending the time on in the long run, and is fully functional with qjackctl.

    Cheers
    Cheers

  3. #3
    Join Date
    Apr 2008
    Location
    Ireland
    Beans
    270
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: various recording problems

    The sky above the port was the color of television, tuned to a dead channel.

  4. #4
    Join Date
    Feb 2007
    Location
    Vienna, Austria
    Beans
    144
    Distro
    Ubuntu Development Release

    Re: various recording problems

    Thank you both for your answers!
    Audio production is probably one of those topics were Linux is still really behind Windows and obviously miles behind Apple. Quite a pity that a rather simple task such as multi-track recording is almost impossible with a vanilla Ubuntu configuration.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •