Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Filesharing via crossover cable

  1. #1
    Join Date
    Nov 2007
    Beans
    26
    Distro
    Ubuntu 11.04 Natty Narwhal

    Filesharing via crossover cable

    I'm trying two connect two ubuntu 9.04 boxes (desktop/laptop) via a crossover cable. I've pulled it off with the same two boxes under 8.10 (on both), but I don't remember how. I've created a samba share on the desktop that I can connect to from a virtual machine on the same box (via the wireless card).
    I can connect to same share from the laptop by using Places -> Computer -> and changing the Location to the IP of the wireless card of the desktop, but it never asks for authentication (perhaps because the two systems have the same username).

    Yet, I cannot get any connection to work via the crossover cable.
    I think I'm missing something in the configuration of the wired connection (IPv4 settings maybe?).

    I tried setting the IPv4 settings to 'shared to other computers', but it seems to assign the same IP on both machines.

    I've spent a few days racking my brains, but I'm lost. Any ideas?
    Thanks!

  2. #2
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Filesharing via crossover cable

    What IP addresses are you using for the crossover-connected machines? (Check via ifconfig -a in a terminal on each machine.)
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad] [Sub-forum]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  3. #3
    Join Date
    Nov 2007
    Beans
    26
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Filesharing via crossover cable

    Iowan,
    This is part of my problem, as it depends on the Ipv4 settings I use. I think I used DHCP before, but when I use it in 9.04 the machines don't even connect to each other.

    If I use 'Local-link only' the desktop is assigned to 169.254.7.72 and the lap at 169.254.10.69, and I've tried a dozen ways of connecting with these, different, IPs to no avail. In fact, I can't even ping the IP of the other machine (listed as the IP in ifconfig for device eth0).

    If I set IPv4 to 'Shared with other computers' it assigns the same IP on both machines of 10.42.43.1. If I connect to this IP with these settings, it only opens the shares on the local machine. I can ping, but I assume that I'm pinging the same machine.

    Thank you
    Last edited by mpm; August 3rd, 2009 at 03:23 AM. Reason: added info

  4. #4
    Join Date
    Jul 2008
    Beans
    62
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Filesharing via crossover cable

    Try setting the second system with this static IP.
    Code:
    10.42.43.2

  5. #5
    Join Date
    Dec 2006
    Beans
    1,133
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Filesharing via crossover cable

    Have you ever configured any firewall on either of the systems? If so make sure to open the appropriate ports for whatever you decide to use for file sharing. Most versions of linux from the last few years have working zero-config networking that you mentioned and will automatically assign ip addresses in the 169.254.x.x range. The machines will also be accessible by by name with a tld name of .local, i.e. hostname.local. Make sure all your systems have unique host names and are not using the installed default of "ubuntu"

    IME it is hard to beat ssh for simple file sharing between linux/unix machines. Just install the openssh-server package on one or both systems. The sshfs packages is also recommended. After the server is installed and running on machine A, from machine B you can just select Main Menu/Places/Connect to Server, choose ssh as the type, fill in the fields and follow the prompts.

    The sshfs packages gives you cli tools to mount a remote system (or a directory of a remote system) and have it appear as a local directory, similar to how the mount command works.
    Last edited by lswb; August 3rd, 2009 at 03:45 AM.
    There are no dumb questions, just dumb answers.

  6. #6
    Join Date
    Nov 2007
    Beans
    26
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Filesharing via crossover cable

    I changed the IP on the lap via 'ifconfig eth0 10.42.43.2' then went to Network Go To:smb://10.42.43.1. I Even tried it the other way around. No luck. I get:
    Error: Failed to retrieve share list from server
    Please select another viewer and try again.
    Seems I can't ping either.

  7. #7
    Join Date
    Nov 2007
    Beans
    26
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Filesharing via crossover cable

    lswb,
    I have a firewall running but I'm keeping close tabs on it. Seeing a blocked connection would make me quite happy.
    I tried ssh also with gFTP but am not sure about how to set the IPv4 settings, as the assigned IPs change. I can get gFTP to connect to the same machine (when it assigns the same IP to both machines) quite easily and transfer files. I can also use it with a wireless connection, but I can't get it to recognize the ethernet device.

  8. #8
    Join Date
    Jul 2008
    Beans
    62
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Filesharing via crossover cable

    You might have to make the whole connection static. Try editing your /etc/network/interfaces file to look like this

    The main system
    Code:
    auto (network card)
    iface (network card) inet static
         address 173.16.0.1
         netmask 255.255.255.0
    The other system
    Code:
    auto (network card)
    iface (network card) inet static
         address 173.16.0.2
         netmask 255.255.255.0
    Hope this works for you.

  9. #9
    Join Date
    Nov 2007
    Beans
    26
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Filesharing via crossover cable

    LinuxRules1,
    Sorry for being a noob, but what do you mean by (network card)?
    lspci lists:
    00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
    and,
    00:08.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01) (this is the wireless card right?)
    what part of this should I use?
    I tried it using 'eth0' for (network card) but this did not change the output of ifconfig
    Last edited by mpm; August 3rd, 2009 at 04:23 AM.

  10. #10
    Join Date
    Dec 2006
    Beans
    1,133
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Filesharing via crossover cable

    I have no way to test at the moment, but a few things occur to me. You mention a wireless network, make sure that any wireless adapters are shut off or wireless networking disabled when using the crossover cable. IIRC NetworkManager dislikes more than one interface. BTW, make sure that it really is a crossover cable!

    If I was going to troubleshoot this on my own systems, the 1st thing I would do is restore /etc/network/interfaces to OEM, i.e. the only contents would be
    Code:
    auto lo
    iface lo inet loopback
    If there are no Windows boxes to be concerned with forget about samba for now and just try to get the machines to ping each other successfully, then try ssh or ftp or some other reliable linux/unix service.

    My preference would be to let avahi/zero-config do its thing and use the self-assigned 169.254.x.x addresses unless you have some reason to do otherwise. If I couldn't ping using the 169.254.x.x addresses within a moment or 2 of plugging in the crossover cable, I'd try shutting down Network Manager and trying again. In 9.04 the command is "sudo /etc/init.d/NetworkManager stop" and to restart it just change "stop" to "start"
    There are no dumb questions, just dumb answers.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •