Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Can't install Adobe AIR 1.5

  1. #1
    Join Date
    Aug 2009
    Beans
    1

    Can't install Adobe AIR 1.5

    I had Ubuntu 8.10 with Adobe AIR 1.5 and I upgraded to 9.04. After I use computer-janitor and remove all proposed packages. It remove all AIR applications (from /opt) and remove Adobe AIR. When a install Adobe AIR 1.5 i see:
    Code:
    An error occurred while installing Adobe AIR. Installation may not be allowed by your administrator. Please contact your administrator.
    And installation is abored but in /opt where are Adobe AIR/Versions/1.0 etc. In menu there aren't any AIR icons and Synaptic tell that adobeair1.0 package damaged and must do sudo apt-get install -f . When I entered sudo apt-get install -f adobeair1.0 package is remove. Second package abobe-certs is good.
    How can I repair it? How can I install Adobe AIR 1.5?

  2. #2
    Join Date
    May 2009
    Beans
    1,934
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: Can't install Adobe AIR 1.5

    Quote Originally Posted by diniox View Post
    I had Ubuntu 8.10 with Adobe AIR 1.5 and I upgraded to 9.04. After I use computer-janitor and remove all proposed packages. It remove all AIR applications (from /opt) and remove Adobe AIR. When a install Adobe AIR 1.5 i see:
    Code:
    An error occurred while installing Adobe AIR. Installation may not be allowed by your administrator. Please contact your administrator.
    And installation is abored but in /opt where are Adobe AIR/Versions/1.0 etc. In menu there aren't any AIR icons and Synaptic tell that adobeair1.0 package damaged and must do sudo apt-get install -f . When I entered sudo apt-get install -f adobeair1.0 package is remove. Second package abobe-certs is good.
    How can I repair it? How can I install Adobe AIR 1.5?
    Do you have root privileges? You need to set that up to install.

  3. #3
    Join Date
    Dec 2008
    Beans
    10

    Re: Can't install Adobe AIR 1.5

    I'm having the exact same problem.

    I had installed Adobe Air and tWhirl several months ago, and twhirl was running fine. I ran an upgrade to the latest Linux kernel, then ran the janitor, and it removed some unused .debs - among them adobeair1.0 and twhirl.

    When I restarted, twhirl looked like it had been removed completely, so I went to the twhirl website http://www.twhirl.org/ to reinstall. The installer is supposed to automatically install air 1.5, but it throws the error diniox gets (although a few times it's just thrown a general error, something like "installation could not be completed, please try again").

    At this point there's an error icon in the gnome panel, and on mouseover it reads:

    "An error occured, please run Package Manager from the right-click menu or apt-get in a terminal to see what is wrong. The error message was: ' Error: BrokenCount > 0'This usually means that your installed packages have unmet dependencies"

    I click on it and it opens the update manager, which says it can only run a partial upgrade. I tell it to do say, and it says it will remove adobeair1.0, which I allow. This appears to work fine. But I've gotten nowhere!

    At this point, the whole process can be repeated - I try to install twhirl, the installer throws an error when installing air1.5, the package manager wants to run a partial upgrade to remove air1.0, it does so.

    I'm guessing that either adobeair1.0 isn't being removed properly, or that the latest kernel upgrade (which diniox would have done too, as he just upgraded to 9.04 last week) screws with air somehow.

    Please help!

  4. #4
    Join Date
    Jan 2008
    Beans
    1

    Exclamation Re: Can't install Adobe AIR 1.5

    I have exactly the same problem after running the Computer Janitor.

    "An error occurred while installing Adobe AIR. Installation may not be allowed by your administrator. Please contact your administrator."

    I have even enable Administrator Login, logged in as root and that didn't even worked.(same error)

    I am at the point of reinstalling ubuntu, but hoping for a solution before I do that.

    Searched the internet for a solution for 5 days now.

  5. #5
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: Can't install Adobe AIR 1.5

    anybody figure this out having same problem after using computer janitor. When I try to install it leaves adobe air as broken in synaptic.

  6. #6
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: Can't install Adobe AIR 1.5

    SOLVED!! Delete the adobe-cert package from synaptic. If not there check the etc/opt folder and delete the Adobe folder. Air will install after this. Make sure you did complete removal of broken package also from your previous tries. Enjoy

  7. #7
    Join Date
    Feb 2008
    Beans
    2

    Smile Re: Can't install Adobe AIR 1.5

    Quote Originally Posted by rjpilla View Post
    SOLVED!! Delete the adobe-cert package from synaptic. If not there check the etc/opt folder and delete the Adobe folder. Air will install after this. Make sure you did complete removal of broken package also from your previous tries. Enjoy
    Brilliant! This worked 100% for me! Thank you, thank you!

  8. #8
    Join Date
    Jan 2008
    Beans
    6

    Re: Can't install Adobe AIR 1.5

    that didn't work for me because I manually deleted all traces I could find of anything Adobe/AIR releated, but finally fixed it with this command:

    Code:
    sudo dpkg --purge adobe-certs
    what a pain this whole process was.

  9. #9
    Join Date
    Jul 2006
    Location
    North Georgia, NA
    Beans
    211
    Distro
    Ubuntu Development Release

    Re: Can't install Adobe AIR 1.5

    I didn't have any trouble installing AIR, but then it's not able to install any apps. The install of an app proceeds to where you click Open or Save. If Open, the process dies quickly. If Save and then install the saved file, that process dies quickly. I'm running Karmic A6 now, but the problem developed with Jaunty.

    Lane
    Lane Lester
    The Web Doctor

  10. #10
    Join Date
    Sep 2008
    Beans
    8

    Re: Can't install Adobe AIR 1.5

    ...Same problem: Used the Computer Janitor; it messed up Air. Uninstalled adobe-certs and reinstalled Air successfully. Now I cant install the ikitesurf.air (wind monitoring app for kitesurfers). Pull down menu includes an Adobe Air app installer, but nothing happens when I try and launch the utility. Pls help.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •