Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: System Whine/Mouse Noise Through Speakers

  1. #1
    Join Date
    Jul 2006
    Location
    California
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    System Whine/Mouse Noise Through Speakers

    [v9.04]

    C-Media CMI 8738 [Ubuntu-identified]

    Good board, but when I hook up speakers to the MB's audio line out, they have a constant high-pitched whine and various system racket coming through the speakers -- mouse growl when rolled, drives racket, etc.

    Music and sound comes out, but this racket makes listening unpleasant.

    Any thoughts on this? Drivers, board defects, what?

    As always, thanks for any help.

    00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
    Subsystem: ASUSTeK Computer Inc. Device 80e2
    Flags: bus master, stepping, medium devsel, latency 32, IRQ 10
    I/O ports at a400 [size=256]
    Capabilities: <access denied>
    Kernel driver in use: C-Media PCI
    Last edited by Bezmotivnik; July 31st, 2009 at 12:58 PM.
    Knows difference between vibrato and tremolo.

  2. #2
    Join Date
    Apr 2007
    Location
    Denmark
    Beans
    2,860
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: System Whine/Mouse Noise Through Speakers

    Maybe the Jack?
    Did you try headphones?
    Lenovo Ideapad Flex 15

  3. #3
    Join Date
    Jul 2006
    Location
    California
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: System Whine/Mouse Noise Through Speakers

    Quote Originally Posted by Ringi View Post
    Maybe the Jack?
    No, that wouldn't explain the symptoms, but I checked anyway. It seems fine.
    Did you try headphones?
    Yeah, identical noise problem from that output jack.
    Knows difference between vibrato and tremolo.

  4. #4
    Join Date
    Apr 2007
    Location
    Denmark
    Beans
    2,860
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: System Whine/Mouse Noise Through Speakers

    It could be wrong type of Jack:
    http://en.wikipedia.org/wiki/TRS_connector
    Lenovo Ideapad Flex 15

  5. #5
    Join Date
    Jul 2006
    Location
    California
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: System Whine/Mouse Noise Through Speakers

    Quote Originally Posted by Ringi View Post
    It could be wrong type of Jack:
    No, it's fine.

    The stereo output works and I get sound -- I just get all this other system noise, too.

    I went into alsamixer and boosted the gain, which helped the S/N ratio, but the noise is still unchanged -- just less in the overall signal.
    Last edited by Bezmotivnik; July 31st, 2009 at 01:38 PM.
    Knows difference between vibrato and tremolo.

  6. #6
    Join Date
    Aug 2006
    Beans
    841

    Re: System Whine/Mouse Noise Through Speakers

    theres nothing you can do about it...its intereference, probably due to bad design of the hardware....(mainboard, or sound subsystem).

    maybe...and its a BIG maybe, replacing the PSU would help.

  7. #7
    Join Date
    Jun 2009
    Location
    South Leicester, UK
    Beans
    95
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: System Whine/Mouse Noise Through Speakers

    I've had this a fair bit, it could be to do with a noisy motherboard or psu.

    I fixed it by unplugging nearby electrical appliances. If you're connected through an extension cable this could also be noisy. I think the noise was still there but it wasn't nearly as bad as it was, and I was able to record with a very acceptable s/n ratio.

  8. #8
    Join Date
    Jul 2006
    Location
    California
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: System Whine/Mouse Noise Through Speakers

    Quote Originally Posted by madnessjack View Post
    I've had this a fair bit, it could be to do with a noisy motherboard or psu.
    How could a PSU possibly cause mouse and hard drive noise?

    Bad board design, yeah, though this is pretty extreme for a high-end (if old) ASUS momboard.

    I fixed it by unplugging nearby electrical appliances. If you're connected through an extension cable this could also be noisy. I think the noise was still there but it wasn't nearly as bad as it was, and I was able to record with a very acceptable s/n ratio.
    Again, I don't see how this could produce mouse and drive noise.

    External noise sources aren't the problem here; it's a clean AC line that's running through several filters in my (non-Linux) recording studio.
    Knows difference between vibrato and tremolo.

  9. #9
    Join Date
    Jun 2009
    Location
    South Leicester, UK
    Beans
    95
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: System Whine/Mouse Noise Through Speakers

    Because sound gets converted from electricity, so any interference will affect it

  10. #10
    Join Date
    Jun 2009
    Beans
    812

    Re: System Whine/Mouse Noise Through Speakers

    "00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)"

    Is it yours?
    23 oss_cmpci pci13f6,111 CMedia CM8738/CM8768
    http://mercurial.opensound.com/?file...devlists/Linux

    It might be interesting to try another sound system and
    see if it produces noise too.

    Another Ubuntu 9.04 in dual boot,
    and install OSS4
    https://help.ubuntu.com/community/OpenSound

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •