Page 1 of 5 123 ... LastLast
Results 1 to 10 of 50

Thread: Cups 1.2 or higher required ?

  1. #1
    Join Date
    Aug 2005
    Beans
    253

    Cups 1.2 or higher required ?

    I recently installed Ubuntu 9.4 on a laptop.... sorted out the wireless chip, thought everything was ok....
    however the Lexmark printer is not working...

    I have followed these instructions which appear to be full of hope:-
    http://forums.linux-foundation.org/r...p?29,9780,9780

    When I run the installer I get the error

    Code:
    The installer has detected the operating system does not meet CUPS minimum version requirements. Please install CUPS version 1.2 or higher and run the installer again.
    I checked in synaptic and found (or assume) to be running a higher version of Cups
    Cups 1,3,9-17 ?????

    Help please
    John in
    Scotland

  2. #2
    Join Date
    Jun 2009
    Location
    NSW Australia
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Talking Solution:

    I had the same problem (Ubuntu 9.04, CUPS version 1.3.9) and I wanted to get my Lexmark X2630 printer working. Do this in the terminal (but change home/nathan/downloads to the path of the .zip you downloaded):

    Code:
    cd '/home/nathan/downloads'
    unzip 'lexmark-inkjet-08-driver-1.0-1.i386.deb.sh.zip'
    ./lexmark-inkjet-08-driver-1.0-1.i386.deb.sh --noexec --target lexmark_install
    Now we have extracted the files and you need to fix "is_cups_version_ok" function near the end of the 'lexmark_install/config/run.lua' file. It's quite easy - just open it in a text editor and insert '--[[' and '--]]' like this:

    Code:
    function is_cups_version_ok()
        local bRet = true
        --[[local packager = get_system_packaging()
        local tmp_path = g_mysecurepath
        local busehome = false
        
        if tmp_path ~= nil and os.fileexists(tmp_path) then
             use home        
            if os.fileexists(tmp_path .. '/cups_packages_072006') then
                os.remove(tmp_path .. '/cups_packages_072006')
            end        
            
            if os.fileexists(tmp_path .. '/cups_packages_072006') then        
                tmp_path = install.gettempdir()
            else
                busehome = true
            end        
        else
            tmp_path = install.gettempdir()
        end
    
        if packager == "rpm" then
            os.execute('rpm -qa|grep cups > ' .. tmp_path .. '/cups_packages_072006')
            cups_packages = shell_execute('cat ' .. tmp_path .. '/cups_packages_072006')
            if cups_packages ~= nil and #cups_packages > 0 then
                for _,cupspackage in pairs(cups_packages) do
                    cups_item = hyphen_replace(cupspackage)
                    if string.find(cups_item,'cups_1.1.')==1 then
                        bRet = false
                        break
                    end
                end
            else
                bRet = false 
            end
        elseif packager == "dpkg" then
            os.execute("dpkg -l | grep cups | awk '{print $2$3}' > " .. tmp_path .. "/cups_packages_072006")
            cups_packages = shell_execute('cat ' .. tmp_path .. '/cups_packages_072006')
            if cups_packages ~= nil and #cups_packages > 0 then
                for _,cupspackage in pairs(cups_packages) do
                    cups_item = cupspackage
                    if string.find(cups_item,'cups1.1.')==1 or string.find(cups_item,'cupsys1.1.')==1 then
                        bRet = false
                        break
                    end
                end
            else
                bRet = false 
            end
        else
    
        end
        
        if busehome == true then
             os.remove(tmp_path .. '/cups_packages_072006')
        end
        --]]
        return bRet
    end
    Now the file is fixed, it's time to install it:
    Code:
    cd '/home/nathan/downloads/lexmark_install'
    sudo ./startupinstaller.sh
    Note: it will install without checking your cups version. So make sure you have cups version above 1.2 - if you want to find what cups version you have just type 'http://localhost:631/' into your web browser address bar.
    Last edited by nathan726; October 2nd, 2009 at 02:52 AM.

  3. #3
    Join Date
    Jul 2008
    Location
    Woodstock Cape Town RSA
    Beans
    983
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Solution:

    Great stuff. I think Lexmark patched their X2650 driver. Because they asked me to download it again and assured me it would work on 64bit. Installer runs without the cups problem but clearly does not support 64!!!!!

  4. #4
    Join Date
    Jul 2008
    Location
    Woodstock Cape Town RSA
    Beans
    983
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Solution:

    I opened the installer and see that there is some attempt to cater for 64bit architecture

    Code:
    CURRENT_ARCH=`uname -m`
        # iX86 --> x86
        echo $CURRENT_ARCH | grep "i.86" >/dev/null && CURRENT_ARCH="x86"
    
        # Solaris uses i86pc instead of x86 (or i*86), convert
        echo $CURRENT_ARCH | grep "i86pc" >/dev/null && CURRENT_ARCH="x86"   
    
    	# Some platforms use x86_64, some amd64...lets just stick to one :)
    	echo $CURRENT_ARCH | grep "amd64" >/dev/null && CURRENT_ARCH="x86_64" # Convert amd64 --> x86_64
    	
        echo "CPU Arch: $CURRENT_ARCH"
    but it doesn't work, just defaults to 32bit and fails to install.

  5. #5
    Join Date
    Aug 2005
    Beans
    253

    Re: Cups 1.2 or higher required ?

    Now we have extracted the files, you need to edit "is_cups_version_ok" function in the 'lexmark_install/config/run.lua' file so that it will return true no matter what. Just open it in a text editor and add '--[[' and '--]]' like this:
    I only have one file in the archive ?
    deb.sh ?

    I can not find 'Lexmark_install/config/run.lua ?????????

    help

  6. #6
    Join Date
    Jun 2009
    Location
    NSW Australia
    Beans
    124
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cups 1.2 or higher required ?

    Quote Originally Posted by afrodeity View Post
    but it doesn't work, just defaults to 32bit and fails to install.
    Sorry, I don't have a clue when it comes to 64bit installs... maybe this driver is 32bit only??

    Quote Originally Posted by its_jon View Post
    I only have one file in the archive ?
    deb.sh ?

    I can not find 'Lexmark_install/config/run.lua ?????????

    help
    Yep after you extract the .zip file you do have a .sh file, but that ain't the end of the story. The .sh file is an executable archive.
    You can extract it's contents - open the terminal and then "cd" to the directory which has your .sh file and extract it's contents using this code, like I mentioned above:
    Code:
    ./lexmark-inkjet-08-driver-1.0-1.i386.deb.sh --noexec --target lexmark_install
    You will then have all the files extracted to a to the "lexmark_install" folder.

  7. #7
    Join Date
    Nov 2008
    Location
    Flanders
    Beans
    35
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Cups 1.2 or higher required ?

    I have the same issue. I switched to Ubuntu 9.04 64 bit I can't do anything with my Lexmark X2650 since the existing driver only works with 32 bit. I can't use getlibs either since the driver is not .deb but in a script .sh

  8. #8
    Join Date
    Nov 2008
    Location
    Flanders
    Beans
    35
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Cups 1.2 or higher required ?

    I found the solution for the missing 64 bit linux driver of my Lexmark X2650. I guess there will be an similar solution for all people with a Lexmark X-series printer and a 64-bit Ubuntu system.
    You need a part of the code that Nathan726 used in this thread (thanks for that, by the way...)

    Now, here's the complete solution
    ---------------------------------
    * download lexmark-inkjet-08-driver-1.0-1.i386.deb.sh.zip for Ubuntu 32 bit from the Lexmark website
    * unzip 'lexmark-inkjet-08-driver-1.0-1.i386.deb.sh.zip'
    * enter in a terminal: sudo ./lexmark-inkjet-08-driver-1.0-1.i386.deb.sh --noexec --target lexmark_install
    * Now go to your directory lexmark_install
    * In that directory you'll find a file named arch.tar Unzip that file.
    * Once unzipped you'll find lexmark-inkjet-08-driver-1.0-1.i386.deb
    * Ok, now download and install the program getlibs from http://frozenfox.freehostia.com/cappy/ (just get getlibs-all.deb and install) Getlibs is a wonderful tool that takes care of all the missing 32 bit libs automatically.
    * enter in a terminal: sudo getlibs -i lexmark-inkjet-08-driver-1.0-1.i386.deb
    * now your Lexmark should do its job ...

  9. #9

    Re: Cups 1.2 or higher required ?

    safety concern is the most need ful of the lot

  10. #10
    Join Date
    Jul 2008
    Location
    Woodstock Cape Town RSA
    Beans
    983
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Cups 1.2 or higher required ?

    Quote Originally Posted by Magic_Spehar View Post
    I found the solution for the missing 64 bit linux driver of my Lexmark X2650. I guess there will be an similar solution for all people with a Lexmark X-series printer and a 64-bit Ubuntu system.
    You need a part of the code that Nathan726 used in this thread (thanks for that, by the way...)

    Now, here's the complete solution
    ---------------------------------
    * download lexmark-inkjet-08-driver-1.0-1.i386.deb.sh.zip for Ubuntu 32 bit from the Lexmark website
    * unzip 'lexmark-inkjet-08-driver-1.0-1.i386.deb.sh.zip'
    * enter in a terminal: sudo ./lexmark-inkjet-08-driver-1.0-1.i386.deb.sh --noexec --target lexmark_install
    * Now go to your directory lexmark_install
    * In that directory you'll find a file named arch.tar Unzip that file.
    * Once unzipped you'll find lexmark-inkjet-08-driver-1.0-1.i386.deb
    * Ok, now download and install the program getlibs from http://frozenfox.freehostia.com/cappy/ (just get getlibs-all.deb and install) Getlibs is a wonderful tool that takes care of all the missing 32 bit libs automatically.
    * enter in a terminal: sudo getlibs -i lexmark-inkjet-08-driver-1.0-1.i386.deb
    * now your Lexmark should do its job ...
    Doing this installed some libraries but what then? Sorry to be a complete nonse, but I also tried the original installer which still doesn't install.

    Code:
     sudo getlibs -i lexmark-inkjet-08-driver-1.0-1.i386.deb
    [sudo] password for afrodeity: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    ia32-libs is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
    Installing libraries ...

Page 1 of 5 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •