Quote Originally Posted by edd07 View Post
Ok, I tried to upgrade GRUB and it didn't work (it booted me into a grey screen with a black rectangle on the center of the screen), so I added the option to old-school grub's menu.lst.

So, you're saying KMS will break this solution? Or will I have to do something else when it's enabled?

EDIT: Nevermind, it doesn't work. Seems like my laptop is trying really hard to blind me
I had the same problem and fixed it easily by adding "nomodeset acpi_backlight=vendor" as sugested to the kernel line of GRUB2
To try it once, press 'e' on the boot screen to edit your grub boot command and add those after "quiet splash". Keep in mind it's not the last line, but probably the one above it.