Results 1 to 9 of 9

Thread: Application start very slowly

  1. #1
    Join Date
    Sep 2007
    Location
    Earth
    Beans
    110
    Distro
    Ubuntu

    Application start very slowly

    I'm running Ubuntu 12.10 with GNOME 3 (although the situation was no different with Unity). Starting application takes a long time for the first time (starting chrome can take up to 10 seconds whereas it takes much less in Windows 8 on the same machine).
    Desktop effects are slow also. E.g. when I activate activity panel the transition is slow at first, but if I do it again immediately it will be smoother.

    Is there anything I can do about that? Does installing Ubuntu on my first partition help make it faster? (it's already on a primary partition, but the first primary partition is occupied by useless Windows 8)

    System specs: Intel Core i7 CPU M 620 @ 2.67GHz × 4

  2. #2
    Join Date
    Mar 2011
    Beans
    680

    Re: Application start very slowly

    What GPU do you have? Hard drive? Is this a fairly fresh install or have you installed many programs?

    Slowness can be caused by a lot of stuff, it's good to get as much info as possible.
    sig

  3. #3
    Join Date
    Jul 2006
    Location
    Castrum, Germania Secunda
    Beans
    1,071

    Re: Application start very slowly

    You can supply the needed info as follows:
    https://sites.google.com/site/easyli...re-information

    Apart from "deep probing" this buggy behaviour, you might try if installing new microcode helps, too:
    https://sites.google.com/site/easyli...ject/microcode

    Installing new microcode should be quite safe, without any negative side effects whatsoever.

  4. #4
    Join Date
    Sep 2007
    Location
    Earth
    Beans
    110
    Distro
    Ubuntu

    Re: Application start very slowly

    Quote Originally Posted by Pjotr123 View Post
    You can supply the needed info as follows:
    https://sites.google.com/site/easyli...re-information

    Apart from "deep probing" this buggy behaviour, you might try if installing new microcode helps, too:
    https://sites.google.com/site/easyli...ject/microcode

    Installing new microcode should be quite safe, without any negative side effects whatsoever.
    There you go. It seems that I am not running Ubuntu on a primary partition.
    It is an almost fresh install. I have added a few application like Skype and NetBeans
    Attached Files Attached Files

  5. #5
    Join Date
    Jul 2006
    Location
    Castrum, Germania Secunda
    Beans
    1,071

    Re: Application start very slowly

    Is your Nvidia card running on the restricted driver? If not, install the restricted driver:
    https://sites.google.com/site/easyli...issing-drivers

    Primary or logical partition doesn't matter. That has no effect at all on the performance.

  6. #6
    Join Date
    Jul 2012
    Beans
    Hidden!

    Re: Application start very slowly

    Quote Originally Posted by lordfkiller View Post
    I'm running Ubuntu 12.10 with GNOME 3 (although the situation was no different with Unity). Starting application takes a long time for the first time (starting chrome can take up to 10 seconds whereas it takes much less in Windows 8 on the same machine).
    Desktop effects are slow also. E.g. when I activate activity panel the transition is slow at first, but if I do it again immediately it will be smoother.

    Is there anything I can do about that? Does installing Ubuntu on my first partition help make it faster? (it's already on a primary partition, but the first primary partition is occupied by useless Windows 8)

    System specs: Intel Core i7 CPU M 620 @ 2.67GHz × 4
    I have read a few threads since 12.10 came out relating to it's slowness,
    if i find one i will post a link to it.

  7. #7
    Join Date
    Sep 2007
    Location
    Earth
    Beans
    110
    Distro
    Ubuntu

    Re: Application start very slowly

    Quote Originally Posted by Pjotr123 View Post
    Is your Nvidia card running on the restricted driver? If not, install the restricted driver:
    https://sites.google.com/site/easyli...issing-drivers

    Primary or logical partition doesn't matter. That has no effect at all on the performance.
    Yes I am running Nvidia's own driver. Although the driver on repos didn't work for me, I downloaded from Nvidia website directly.
    Installing the driver made OS start-up slower. I think a couple of errors happen once I login. Ubuntu splash screen disappeared too.

  8. #8
    Join Date
    Jul 2006
    Location
    Castrum, Germania Secunda
    Beans
    1,071

    Re: Application start very slowly

    Does the performance improve when you use this other desktop:
    https://sites.google.com/site/easyli...ct/alternative

  9. #9
    Join Date
    Sep 2007
    Location
    Earth
    Beans
    110
    Distro
    Ubuntu

    Re: Application start very slowly

    Okay. I installed a fresh Ubuntu as my system was so unstable after installing and removing Unity and GNOME Shell several times.

    The problem with slow (first time only) application start-up remains and it seems to be independent of the desktop environment used.

    But slow desktop effects had a different cause: NVIDIA PowerMizer. With PowerMizer, GPU clocks go to level 0 (almost 1/5 of the max clock frequency for my card) when there is no graphics intensive app running. So when I activate Activities menu, the effects are not smooth the first time. It then jumps to level 2(max) and all 3D effects start working. But within a minute or so it goes back to level 0 and so on.

    Here's how I disabled PowerMizer: http://askubuntu.com/questions/23257...dia-powermizer

    Update: I changed my driver to the latest experimental NVIDIA driver and 3D effects work much better now - no bugs or issues so far
    Last edited by lordfkiller; January 3rd, 2013 at 06:40 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •