I'm using a GeForce 7300GT on Ubuntu 8.04, and I'm trying to make it so that but my CRT and my television display the same thing. I don't care if they have the same resolution or not I just want to make them both display. I originally did this in 7.10 really easily, but it's proved much harder in 8.04.

The card is not detecting the TV plugged into the svideo (I tried GNOME's System Resolution, Nvidia Settings, and forcing S-Video usage with xrandr), even though the computer is directly plugged into the television. I edited the xorg and added a ConnectedMonitor line which allowed me to force it to output to the TV (but only with 96.43.xx drivers) and that worked fine but it disabled the CRT. I tried having both the CRT and the TV in the ConnectedMonitor line but it still just output to the TV and disabled the CRT. However, when I hit CTRL+ALT+F1 to get a text based session, it always appears on the CRT, whether the graphical one was on the CRT or not. When the CRT was not the graphical screen the text session is very strangely colored. By editing the ConnectedMonitor line I'm able to use either display one at a time, so I know they both work. Also, both of them are using the same resolution, so I don't think that xorg is disabling one of them because the resolution is not supported.

Please advise on how to fix.

Here is my xorg.conf:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Tue Jan 22 19:53:46 PST 2008

Section "ServerLayout"
Identifier "Layout0"
screen 0 "Screen0" 0 0
Inputdevice "Keyboard0" "CoreKeyboard"
Inputdevice "Mouse0" "CorePointer"

Section "Files"
Rgbpath "/usr/X11R6/lib/X11/rgb"

Section "Module"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
Load "v4l"

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
Identifier "Monitor0"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1280x1024"
Horizsync 31.5 - 64.0
Vertrefresh 56.0 - 65.0
# Gamma 1
# modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
# modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
# modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
# modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
# modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
# modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync

Section "Device"
Identifier "Device0"
Driver "nvidia"
Boardname "nvidia"
Busid "PCI:1:0:0"
Option "TwinView" "True"
Option "TwinViewOrientation" "Clone"
Option "MetaModes" "Monitor0: 800x600, TV-0: 800x600"
Option "HorizSync" "Monitor0: 30-81; TV-0: 30-50"
Option "VertRefresh" "Monitor0: 56-76; TV-0: 60"
Option "ConnectedMonitor" "TV-0"
Option "TVStandard" "NTSC-M"
Option "TVOutFormat" "SVIDEO"
Option "NoLogo" "True"
Option "TVDACLoadDetect" "TRUE"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
Defaultdepth 24
Option "TwinView" "True"
Option "MetaModes" "800x600"
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"