Results 1 to 7 of 7

Thread: Comiz quit working on startup

  1. #1
    Join Date
    Aug 2008
    Location
    Shady Cove, OR
    Beans
    53
    Distro
    Ubuntu 12.04 Precise Pangolin

    Compiz quit working on startup

    So, to keep it short I broke my X recently on my Jaunty machine. I ran the dpkg-reconfigure routine and restored my config and I also removed and reinstalled the proprietary ATI video drivers (from ATIs site, not the Ubuntu ones that never work for me). Now, I can boot into the system again and everything is fine except I have to either open a terminal to run compiz or use fusion-icon and tell it to "Reload Window Manager" each time.

    What can I do to make certain that Compiz loads on startup each time? I already have a startup command for fusion icon (fusion-icon --no-start) but I still have to tell it to reload before I get compositing. Any help would be appreciated. THANKS!
    Last edited by 68pontiac; July 29th, 2009 at 08:50 PM.
    "Hell hath no fury at all."

  2. #2
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,424
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Compiz quit working on startup

    I think setting the /desktop/gnome/applications/window_manager/default key in gconf-editor to /usr/bin/compiz will do this.
    None but ourselves can free our minds

  3. #3
    Join Date
    Aug 2008
    Location
    Shady Cove, OR
    Beans
    53
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz quit working on startup

    Thank you for the reply. Compiz is already set up as the default window manager in Configuration Editor.

    As it stands now it reads:
    Code:
    current compiz
    default /usr/bin/compiz
    Any other suggestions? I feel that this may be in some way related to me recently installing the fusion-icon package but I have removed it completely and the problem still persists. I'm thinking I might completely remove Compiz and reinstall it if I can't think of any better idea.
    "Hell hath no fury at all."

  4. #4
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,424
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Compiz quit working on startup

    Rather than running your fusion-icon at startup, you could run
    Code:
    compiz --replace
    at startup instead. It seems like an overkill solution, though.

    Otherwise, you could change the current key to /usr/bin/compiz, too.
    None but ourselves can free our minds

  5. #5
    Join Date
    Aug 2008
    Location
    Shady Cove, OR
    Beans
    53
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Comiz quit working on startup

    I'll give that suggestion a go and report the results. I just don't get why I'd have to do this now but never had to do it before I broke X. Is there any configuration stuff regarding Compiz in X11.conf ?
    "Hell hath no fury at all."

  6. #6
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,424
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Compiz quit working on startup

    Actually, the newer way of doing things is with the fake window manager gnome-wm (which should be selected by the /desktop/gnome/session/required_components/windowmanager GConf key). If that's set to metacity, for example, then metacity is what will be loaded instead.

    This is what gnome-wm's man page says:

    DESCRIPTION
    The gnome-wm script invokes the user selected window manager. If the
    user has not chosen a window manager it will launch a GNOME compliant
    window manager.

    The user can overwrite the selection of a window manager by setting the
    WINDOW_MANAGER environment variable. If a --default-wm option is given
    the script uses that window manager in case WINDOW_MANAGER is not set.
    gnome-wm is a script that's stored in /usr/bin. You could edit it with a text editor run as root if it turns out that the DEFWM= line has anything in it..
    None but ourselves can free our minds

  7. #7
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,424
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Comiz quit working on startup

    Quote Originally Posted by 68pontiac View Post
    I just don't get why I'd have to do this now but never had to do it before I broke X.
    Because you broke X.

    Most scripts have fallback values. I'd imagine that when you broke X the fallback of metacity was selected and stored somewhere. When you fixed it, you probably did something different to the scripts that got run when the system was first installed, and so that value wasn't updated. Your task is to pretend to be the scripts, so that you can change the appropriate value
    None but ourselves can free our minds

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •