Results 1 to 4 of 4

Thread: 9.04 ATI Radeon HD 3500 dual monitor problems

  1. #1
    Join Date
    Nov 2008
    Beans
    4

    9.04 ATI Radeon HD 3500 dual monitor problems

    Hey
    Update: I made a mistake when typing my card name its a ATI Radeon HD 3650
    I cant get my ATI card to work with both my screens at the right resolutions and graphics are very slow. I have 2 Samsung Sync Masters one 17 inch which has a max resolution of 1280x1024 and one 24 inch that has a max resolution of 1920x1200. But they are both stuck at 1280x1024. If i change the resolution in my xorg.conf i just get a blank screen on both screens and have to boot into console and use my old conf. Also on my 17 inch monitor when i move a window it leaves a image each time where the window was. Im using the latest driver from ATIs site of today
    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Virtual 2560 1024
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "aticonfig Layout"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    BusID "PCI:1:0:0"
    EndSection

    Section "ServerFlags"
    Option "DontZap" "False"
    EndSection
    Thank You
    Last edited by xxlginger; July 2nd, 2009 at 07:58 PM.

  2. #2
    Join Date
    Nov 2008
    Beans
    4

    Re: 9.04 ATI Radeon HD 3500 dual monitor problems

    Ok so i went back to the open drivers.
    Both my screens work now, but of course i cant get compiz to work..
    Any one got a idea of how to get compiz and both my screens working?
    Thanks

  3. #3
    Join Date
    Nov 2008
    Beans
    4

    Re: 9.04 ATI Radeon HD 3500 dual monitor problems

    Im almost there with the open drivers and compiz on my duel screens.
    Here what happens when i do "compiz --replace" now.

    xxlginger@emily:~$ compiz --replace
    Checking for Xgl: not present.
    xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
    Detected PCI ID for VGA:
    Checking for texture_from_pixmap: not present.
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: present.
    Checking for non power of two support: present.
    Checking for Composite extension: present.
    Checking screen 1Comparing resolution (3200x1200) to maximum 3D texture size (2048): Checking for Software Rasterizer: present.
    Software rasterizer detected, abortingaborting and using fallback: /usr/bin/metacity
    As you can see it fails on this line "Software rasterizer detected, abortingaborting and using fallback: /usr/bin/metacity"

    Heres my latest xorg.conf

    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    SubSection "Display"
    Virtual 3200 1200
    EndSubSection
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "ati"
    Option "UseFBDev" "true"
    Option "XAANoOffscreenPixmaps"

    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection
    Any one got any idea on how to fix it?
    I will update this tread when i get it working
    Thanks Again

  4. #4
    Join Date
    Nov 2008
    Beans
    4

    Re: 9.04 ATI Radeon HD 3500 dual monitor problems

    Ok think ive got it.
    The problem is that xorg is using virtual monitors. You can see that here "Checking for Software Rasterizer: present.
    Software rasterizer detected, abortingaborting and using fallback: /usr/bin/metacity". So so all i have to do is edit my xorg.conf without using Rasterizer i hope.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •