Results 1 to 4 of 4

Thread: Yet another flash player question

  1. #1
    Join Date
    Aug 2007
    Beans
    3

    Yet another flash player question

    Just for grins, I am working on getting Mythbuntu up and running. While awaiting my TV card to come in the mail, I am trying to get flash working properly. There are issues...

    I have separate X-screens configured, running my desktop display to a 46" TV set. On my first attempt streaming flash video, nothing worked. All video was jumpy and stuttering on full-screen view. After purging the system of everything flash-non-free, ndiswrapper, etc. and installing flash 10.0.22.87 64 bit alpha I see some progress. For instance, tv.com and cbs.com work fine now in full screen mode (didn't before). Other sites, particularly Hulu are still jumpy/stuttering in full screen. I'm not sure if this is the fault of Hulu, the flash player, or the kernel itself. I have been googling extensively the past few days, nothing else seems to help at all.

    I am running Mythbuntu 64 bit on kernel 2.6.28. My graphics card is nvidia GeForce 8800 GTS. My xorg.conf file (if it matters) is as follows:

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildd@crested) Sun Feb 1 20:25:37 UTC 2009

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder62) Tue Mar 24 06:15:32 PST 2009
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Screen0" 0 0
    Screen 1 "Screen1" RightOf "Screen0"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "0"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "keyboard"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Samsung SyncMaster"
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 75.0
    EndSection

    Section "Monitor"
    Identifier "Monitor1"
    VendorName "Unknown"
    ModelName "SAMSUNG"
    HorizSync 26.0 - 76.0
    VertRefresh 23.0 - 60.0
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 8800 GTS"
    BusID "PCI:3:0:0"
    Screen 0
    EndSection

    Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 8800 GTS"
    BusID "PCI:3:0:0"
    Screen 1
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Configured Video Device"
    Monitor "Configured Monitor"
    DefaultDepth 24
    Option "UseEvents" "1"
    Option "DPI" "100x100"
    Option "NoLogo" "1"
    SubSection "Display"
    Depth 24
    Modes "nvidia-auto-select"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "Screen"

    # Removed Option "metamodes" "DFP-0: 1920x1080 +0+0"
    # Removed Option "metamodes" "DFP-0: nvidia-auto-select +0+0; DFP-0: 1920x1080 +0+0"
    Identifier "Screen1"
    Device "Device1"
    Monitor "Monitor1"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "DFP-0: 1920x1080 +0+0; DFP-0: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Any help would be appreciated. I would really like to get hulu working.

    I'm having a hard enough time convincing my wife of the merits of Linux...

  2. #2
    Join Date
    Feb 2008
    Location
    Pittsburgh PA
    Beans
    90
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Post Re: Yet another flash player question

    Quote Originally Posted by joab View Post
    I am running Mythbuntu 64 bit on kernel 2.6.28.
    Run 32-bit, if your not over 4gigs of ram, their is no reason to use 64-bit. Your have more problems. Flash for 64-bit is Alpha software, they haven't even officially made it public testing or beta. Your best results are going to be through a 32-bit distribution. At least for a media player.
    And using the Adobe Flash plugin.

    Note 64-bit is great as a server, which is were it is tried and true. I just don't see it as a viable desktop machine yet. But again, its much better at sql then 32 bit imo, though having more then 4gigs of ram certainly helps on the server side of things.

    You could always dual-boot a 32/64 o/s if you really want to have full 64, but still have a stable machine when you just want to get a task done, like a watch a video.
    Last edited by ronaldprettyman; July 1st, 2009 at 04:33 PM.

  3. #3
    Join Date
    Jul 2007
    Location
    Connecticut USA
    Beans
    1,865
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Yet another flash player question

    Quote Originally Posted by ronaldprettyman View Post
    Run 32-bit, if your not over 4gigs of ram, their is no reason to use 64-bit. Your have more problems. Flash for 64-bit is Alpha software, they haven't even officially made it public testing or beta. Your best results are going to be through a 32-bit distribution. At least for a media player.
    And using the Adobe Flash plugin.

    Note 64-bit is great as a server, which is were it is tried and true. I just don't see it as a viable desktop machine yet. But again, its much better at sql then 32 bit imo, though having more then 4gigs of ram certainly helps on the server side of things.

    You could always dual-boot a 32/64 o/s if you really want to have full 64, but still have a stable machine when you just want to get a task done, like a watch a video.
    Please don't spread FUD about 64bit. The OP is asking for help with 64 bit ubuntu, therefore we should help him with his problem and not tell him what he should be using. 64 bit ubuntu is very stable and suitable to do everything you need to do. It is also noticeably faster on some computers. Also, if you do a search for 64 vs. 32 bit, you will see that 64 bit is inherently more stable than 32 bit. I do not know where you got your assumptions from, but they are not correct.

    The flash file for 64bit also works beautifully.

    Here is the 64 bit flash. Just extract it and put the libflashplayer.so file into your .mozilla/plugins folder. (go to home folder and do Ctrl-h to show the hidden .mozilla folder. Also, if there is no plugins folder, create one)
    Last edited by HappyFeet; July 1st, 2009 at 08:09 PM.

  4. #4
    Join Date
    Aug 2007
    Beans
    3

    Re: Yet another flash player question

    Thank you, Happy Feet, but that is exactly what I did.

    libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz

    downloaded, unzipped, libflashplayer.so placed in .mozilla/plugins folder.

    As I said, no flash worked without stuttering before I installed this version of flash; afterwards I at least got a couple of sites working.

    That's what I'm trying to figure out. Why did installing 10.0.22.87 flash make some sites work (cbs.com, tv.com) and didn't help with others (hulu in particular).

    By the way, I didn't mention before that my CPU is an AMD Athlon 64 X2 6000+ 3.0 Ghz, the MB is an Asus M2N-SLI Deluxe, and I have 4 GB of Crucial memory

    thanks again,
    m

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •