Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: no init found, Try passing init=bootarg and then some

  1. #21
    Join Date
    Sep 2010
    Beans
    3

    Re: no init found, Try passing init=bootarg and then some

    Hello, I have the same problem with "try passing init=bootarg".
    I managed to fix it by booting into liveUSB and using e2fsck command but the problem always appear a few days later. I really dont know why this is happening and I dont want to use liveUSB every second day...could someone help me please?

  2. #22
    Join Date
    Sep 2010
    Beans
    3

    Re: no init found, Try passing init=bootarg and then some

    just hit the F2 or F12 button (Boot setup or something like that) ,choose BOOT options and choose CD or USB as 1st boot priority

  3. #23
    Join Date
    Apr 2011
    Beans
    4

    Re: no init found, Try passing init=bootarg and then some

    So I just resolved that crappy problem and heres what I did:

    First I installed ubuntu on a seperate hard drive and ran that as primary hard drive. then I opened terminal and entered:

    sudo fdisk -l

    The errored hard drive was sdb1. I then entered:

    sudo fsck /dev/sdb1

    There were questions i answered yes to then booted normally after it finished. everything was normal exccept I have to choose a different version of ubuntu at startup. I havent had any problems so far but this was just an hour ago. Good luck and hope this helps.

  4. #24
    Join Date
    Feb 2008
    Beans
    6

    Re: no init found, Try passing init=bootarg and then some

    Any other fixes that dont require a second hard drive?

  5. #25
    Join Date
    May 2011
    Location
    San Anto
    Beans
    1

    Unhappy Re: no init found, Try passing init=bootarg and then some

    i to have gotten mount: mounting/devon/root/dev failed:no such file or directory then TARGET filesystem doesnt have requested /sbin/init
    Busybox v1.15.3 (ubuntu 1:1.15.3-1ubuntu5) built-in shell (ash) enter help for a list of commands
    initramfs


    PLEASE HELP ME WHAT DO I DO ITS DRIVING ME CRAZY I COMMUNICATEWITH MY PARENTS THREW SKYPE MY FATHER IS ILL SO IF SOMEOME COULD PLEASE HELP ME THANK YOU

  6. #26
    Join Date
    Sep 2010
    Beans
    20

    Re: no init found, Try passing init=bootarg and then some

    Same No init found problem, using Ubuntu 10.04 LTS, tried
    ubuntu@ubuntu:~$ sudo e2fsck -C0 -p -f -v /dev/sda1

    417 inodes used (0.86%)
    1 non-contiguous file (0.2%)
    0 non-contiguous directories (0.0%)
    # of inodes with ind/dind/tind blocks: 0/0/0
    Extent depth histogram: 407
    73815 blocks used (37.94%)
    0 bad blocks
    0 large files

    401 regular files
    7 directories
    0 character device files
    0 block device files
    0 fifos
    0 links
    0 symbolic links (0 fast symbolic links)
    0 sockets
    --------
    408 files
    ubuntu@ubuntu:~$ sudo e2fsck -C0 -p -f -v /dev/sda3
    e2fsck: Device or resource busy while trying to open /dev/sda3
    Filesystem mounted or opened exclusively by another program?
    I suppose problem is with sda3, what is the solution? because of this sda3 even boot_info_script is not working it hangs when it starts working on sda3.
    "Life is the art of drawing sufficient conclusions from insufficient premises"

  7. #27
    Join Date
    Nov 2006
    Beans
    4

    Re: no init found, Try passing init=bootarg and then some

    Today I moved a computer across a desk and changed the monitor. On boot I got the 'no init found' etc. DryChilli's post sorted my encrypted volume error out. BTW fs is ext4 as I have seen posted elsewhere.

    Thanks a lot. Top man.

    Tim.



    Quote Originally Posted by DryChili View Post
    Hi!

    I had the problem too, but it was my fault. My computer hung, so I switched it off. Afterwards I got this error.

    To fix it is easy. Just boot from a USB-stick or CD and do fsck.

    Some instructions:

    List your partitions:
    Code:
     ls /dev/sd*
    If you haven't got an encrypted disk just do (where sda5 is the corrupted partition):
    Code:
    fsck /dev/sda5
    If you are using an encrypted hard-disk (i do) do

    Code:
    sudo cryptsetup luksOpen /dev/sda5 something
    where sda5 is the encrypted partition and someting is the name under which you will find the partition (/dev/mapper/something).

    The install Lvm and look for volumes :

    Code:
    sudo apt-get install lvm2
    sudo pvscan
    sudo vgscan
    The last command should list the at least one volume-group
    Enable it or the ones you're interested in

    Code:
    sudo vgchange -a y groupname
    Now list the logical volumens

    Code:
    sudo lvscan
    Your drive you're interested in should now appear under /dev/mapper

    do a fsck

    Code:
    sudo fsck /dev/mapper/logical-volume
    Lots of errors! Off course you want to have them all fixed. REBOOT!
    This worked for me!

    Best regards!

  8. #28
    Join Date
    Mar 2009
    Beans
    7

    Re: no init found, Try passing init=bootarg and then some

    Quote Originally Posted by andddlay View Post
    This post led me to the answer:

    http://ubuntuforums.org/showpost.php...05&postcount=2

    I ran a live CD, opened terminal, and typed in "sudo fsck /dev/sda7" (where my ubuntu partition was located)

    Thanks so much for this! Worked a treat.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •