Quote Originally Posted by amjjawad View Post
Hi,

Lubuntu 11.10 is the main OS which is supposed to control the whole thing. I know that because:
1- It's the first choice on the menu even though I can see the menu but when I press Enter blindly, it boots to Lubuntu 11.10
2- I'm very careful when it comes to Multi-Booting Systems.

I can't see the menu at all even when I press and hold "Shift" key.

I'm using GRUB Customizer by the way and I installed GRUB to the MBR of sda but that did not change anything.

I guess I need to use the other program (forgot the name) to re-install GRUB and if that didn't help then I need to post the output of the booting script.

Thank you
Did you try setting the /boot/grub/grub.cfg timeout to -1 ? That should force Grub to display the menu.