Results 1 to 1 of 1

Thread: Nvidia drivers stop working after installing 'linux-server' package.

  1. #1
    Join Date
    May 2007
    Location
    USA
    Beans
    73
    Distro
    Ubuntu

    [SOLVED] Nvidia drivers stop working after installing 'linux-server' package.

    Looks like my tinkering has got me into trouble.

    I recently installed intrepid onto a freshly formatted HDD, and easily upgraded to jaunty. I've had GB of ram since I've had this machine, but only 3GB are recognized. I thought I'd do something about that and follow the advice of several helpful people over in this thread. All I did was open a terminal and type,

    Code:
    sudo apt-get install linux-server
    I then restarted, and when starting up, I was notified that the NVIDA drivers couldn't start, and it asked if I wanted to start in low-graphics mode. I wasn't really surprised. I am assuming that installing 'linux-server' changes my kernel, and that my nvidia drivers are not configured for said kernel? I thought it would be easy to get back up and running again from System>Administration>Hardware Drivers, but it doesn't look like that's the case. Going to System>Administration>Harware Drivers shows both available drivers as not activated, and try as I might, I can't get either driver to become activated.

    Upon starting Nvida X Server Settings, I am greeted with,

    Code:
    You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.
    Did what it said, got some warnings, no improvements.

    My CRT display is making a very high pitched screech that gives me a headache, and the refresh rate hurts my eyes. On the up side, my system now sees all 4 GB of ram!

    What I'm thinking of doing next is going to nvidia.com and just downloading the nvidia drivers from there, but I'm not sure if that's a good move, or if it will just mess up my system even more. What should I do?

    *Edit:

    Thanks to ericab for the quick and simple fix:

    Code:
    sudo apt-get install linux-headers-server
    Last edited by insanity54; June 18th, 2009 at 09:51 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •