Page 42 of 108 FirstFirst ... 3240414243445292 ... LastLast
Results 411 to 420 of 1077

Thread: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

  1. #411
    Join Date
    Oct 2009
    Beans
    20

    Re: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

    okay ill be the first to confirm that it works now..

    thanx falk ur the man!

  2. #412
    Join Date
    Nov 2009
    Beans
    7

    Re: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

    i got it to work thz guys for teh help now if only ya could get rid of r3/l3 things for i can use that for right clicks and left clicks that would be awesome
    Okiura if u still want the info u ask before, ill give it to u i dont kno if its still relevant since its working already

  3. #413
    Join Date
    May 2009
    Beans
    25
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

    Just updated to 1.0.3 and it works on PS3, DS3 and 9.10. Many thanks falkTX.

    A question though: with gnome profile, for instance, left axis, right axis, x and o behave as expected, as mouse, scroller, left and right click, respectively. I'm not quite sure what to expect, but no other buttons seem to work. Shouldn't they work according to the profile? For example, R2=End.

    And in keyboard mode, excepting x and o, the buttons return numbers.

    Sorry if I'm missing something obviuos.

    One more question (indirecly related to QtSixA): This Authorization request dialog, I keep getting it despite having ticked Always grant access.
    Last edited by ps3mhome; November 10th, 2009 at 08:54 PM.

  4. #414
    Join Date
    Nov 2007
    Location
    Portugal
    Beans
    1,155

    Re: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

    Quote Originally Posted by ps3mhome View Post
    Just updated to 1.0.3 and it works on PS3, DS3 and 9.10. Many thanks falkTX.

    A question though: with gnome profile, for instance, left axis, right axis, x and o behave as expected, as mouse, scroller, left and right click, respectively. I'm not quite sure what to expect, but no other buttons seem to work. Shouldn't they work according to the profile? For example, R2=End.

    And in keyboard mode, excepting x and o, the buttons return numbers.

    Sorry if I'm missing something obviuos.

    One more question (indirecly related to QtSixA): This Authorization request dialog, I keep getting it despite having ticked Always grant access.
    The 1.0.3 doesn't have the synaptics PS3 bug fixed anymore (debian policy violation). Maybe it's because of that..? I don't really know.
    You should enable the "Toggle On/Off" option if running in the PS3. Does it still return numbers even with the L3/R3 thing?
    I can't really support any PS3 stuff since I don't have one. You have to wait for others to comment about it.

    What's about the authorization dialog? Not sure I get your point..

  5. #415
    Join Date
    May 2009
    Beans
    25
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

    Quote Originally Posted by falkTX View Post
    The 1.0.3 doesn't have the synaptics PS3 bug fixed anymore (debian policy violation). Maybe it's because of that..? I don't really know.
    You should enable the "Toggle On/Off" option if running in the PS3. Does it still return numbers even with the L3/R3 thing?
    I can't really support any PS3 stuff since I don't have one. You have to wait for others to comment about it.

    What's about the authorization dialog? Not sure I get your point..
    (The "Toggle On/Off" is enabled). I press R3 for keyboard mode, then all buttons except x and o (which work properly) return numbers. It was the same with 1.0.2.

    Sorry about the unclear writing; even failed to come up with the question. With the DS3 disconnected, pressing the PS button to connect results in an "Authorization request" dialog asking whether the PLAYSTATION(R)3 Controller (00:21:4F:XX:XX:XX) should be granted access to "00001124-0000-..." (the computer I guess). There is also a checkbox "Always grant access". I tick the checkbox and click Yes to grant access. The DS3 connects and works. If I later Disconnect and then press the PS button, I have to go through the "Authorization request" dialog again, despite having ticked "Always grant access". Why? (I cannot respond to "Authorization request" dialog using the DS3, since the DS3 is disconnected.)
    Last edited by ps3mhome; November 11th, 2009 at 08:02 PM.

  6. #416
    Join Date
    Nov 2007
    Location
    Portugal
    Beans
    1,155

    Re: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

    Quote Originally Posted by ps3mhome View Post
    (The "Toggle On/Off" is enabled). I press R3 for keyboard mode, then all buttons except x and o (which work properly) return numbers. It was the same with 1.0.2.

    Sorry about the unclear writing; even failed to come up with the question. With the DS3 disconnected, pressing the PS button to connect results in an "Authorization request" dialog asking whether the PLAYSTATION(R)3 Controller (00:21:4F:XX:XX:XX) should be granted access to "00001124-0000-..." (the computer I guess). There is also a checkbox "Always grant access". I tick the checkbox and click Yes to grant access. The DS3 connects and works. If I later Disconnect and then press the PS button, I have to go through the "Authorization request" dialog again, despite having ticked "Always grant access". Why? (I cannot respond to "Authorization request" dialog using the DS3, since the DS3 is disconnected.)
    Ooh...
    That happens on Gnome, not KDE.
    It is the bluetooth manager detecting an "untrusted device" (the Sixaxis), and just shows that dialog everytime...
    I know that if you grant full access (I even tried setting it manually), it ignores yours settings and ask for authorization again.

    If you don't use bluetooth for anything else you could remove the Gnome bluetooth manager:
    Code:
    sudo apt-get remove bluez-gnome gnome-bluetooth
    This is a bug somewhere in BlueZ or the applet itself.
    If you don't mind, maybe you could report a bug about it..?

    Not sure about the buttons and numbers thing though. Anyone else has this issue?
    Last edited by falkTX; November 11th, 2009 at 08:50 PM.

  7. #417
    Join Date
    May 2009
    Beans
    25
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

    Quote Originally Posted by falkTX View Post
    Ooh...
    That happens on Gnome, not KDE.
    It is the bluetooth manager detecting an "untrusted device" (the Sixaxis), and just shows that dialog everytime...
    I know that if you grant full access (I even tried setting it manually), it ignores yours settings and ask for authorization again.

    If you don't use bluetooth for anything else you could remove the Gnome bluetooth manager:
    Code:
    sudo apt-get remove bluez-gnome gnome-bluetooth
    This is a bug somewhere in BlueZ or the applet itself.
    If you don't mind, maybe you could report a bug about it..?

    Not sure about the buttons and numbers thing though. Anyone else has this issue?
    Thanks falkTX. I would like to do it, but how do I report a bug?

    About the numbers, it is not random numbers or so, a given button return the same digit consistently. So maybe it would be possible to find the mapping. And, as I said, R2=End, L2=Home, L1=Menus, and so on, don't work at all, when in mouse mode.

  8. #418
    Join Date
    Dec 2008
    Beans
    2

    Re: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

    Hi falkTX!
    I'm also having the same problem that ps3mhome has. The button mapping is not the one as the one that is stated in the fdi file. I even tried to setup my own profile but, instead of actually returning the keys that I configured, it just returned the numbers from 0 to 9 (e.g., if I pressed circle it would return me 9)

  9. #419
    Join Date
    May 2009
    Beans
    25
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

    Quote Originally Posted by DanielBC View Post
    Hi falkTX!
    I'm also having the same problem that ps3mhome has. The button mapping is not the one as the one that is stated in the fdi file. I even tried to setup my own profile but, instead of actually returning the keys that I configured, it just returned the numbers from 0 to 9 (e.g., if I pressed circle it would return me 9)
    Hi DanielBC. We seem to have the same problem just getting the digits 0-9 in keyboard mode. In the Gnome profile, in mouse mode, R2=End, L2=Home, L1=Menus and so on, do not work for me, nothing seems to happen. Do they work for you?

  10. #420
    Join Date
    Nov 2007
    Location
    Portugal
    Beans
    1,155

    Re: HOW-TO: Connect Sixaxis to Ubuntu trough bluetooth mode

    This is probably related to the PS3 synaptics bug.

    Try this:
    Code:
    sudo apt-get remove xserver-xorg-input-synaptics
    Then restart.
    Does it still return numbers instead of the real keys?

Page 42 of 108 FirstFirst ... 3240414243445292 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •