Results 1 to 6 of 6

Thread: PowerPC Compatibility

  1. #1
    Join Date
    Jun 2009
    Beans
    3

    PowerPC Compatibility

    Hello! New to the Ubuntu forums, in fact I'm new to Ubuntu full stop and have a question regarding compatibility on a Powerbook G4.

    I am guessing that my question might have already been answered somewhere in the depths of these forums, but I can't find an exact answer, hence this post.

    I have a G4 with a 1.67 Ghz cpu and dual layer superdrive and high res screen. It is one of, if not THE very last version of the G4 PPC to be released.

    I have installed Ubuntu 9.04 relavitely successfully so far (strange screen sync problems during install, but usable enough to get through), but I am unable to get the wireless and screen graphics working properly.

    Are there major comptibility issues that mean I should look at an older version? Or is there a set of patches/upgrades aimed specifically for that release of the G4?

    Thanks in advance for any help!

    Cheers

  2. #2
    Join Date
    May 2008
    Location
    Ohio
    Beans
    11
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: PowerPC Compatibility

    Well,

    First off welcome eventdecay

    What version of Ubuntu are you trying get to function properly?

  3. #3
    Join Date
    Jun 2009
    Beans
    3

    Re: PowerPC Compatibility

    Hey kzersatz, thanks!

    I have installed Ubuntu 9.04 'Jaunty Jackalope'.

    I have managed to get wireless working now using b43-fwcutter, but still have some minor issues with hibernation/sleep mode not waking up properly and video issues during boot. Also the boot time is a little longer than expected (i.e. slower than OSX).

    I am hoping I can get everything working well enough to not need to switch back to OSX.

    Any help/pointers to appropriate drivers and software will be much appreciated.

    Cheers!

  4. #4
    Join Date
    Jun 2009
    Location
    NATO area
    Beans
    Hidden!

    Re: PowerPC Compatibility

    i use pbbuttonsd, eject, cpudynd and my own recompiled kernel.

  5. #5
    Join Date
    Mar 2006
    Location
    The Internet
    Beans
    1,817
    Distro
    Ubuntu

    Re: PowerPC Compatibility

    This link has some good general powerpc issue info:

    https://wiki.ubuntu.com/PowerPCFAQ

  6. #6
    Join Date
    Jun 2009
    Beans
    3

    Re: PowerPC Compatibility

    Thanks Barba. I downloaded pbbuttonsd buy 9.04 already had a new version installed and my eject button works ok so I skipped downloading 'eject'.

    Do I need cpudynd? If so, can you point me to a link for a debian type package? Sorry I just dont know how to manually install stuff yet.

    stmiller, Read the FAQ already, but not much info on my specific problems.

    Still cant fix the sleep mode not waking up and also... Flash doesnt work either! Anyone know a good powerpc flash plugin please?

    So far though I think Ubuntu is great. And I guess it would be a lot better (as far as compatibility is concerned) if I was installing it on an Intel machine.

    Thanks guys n girls!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •