Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Acer Travelmate Internal Mic not working

  1. #1
    Join Date
    Jun 2009
    Beans
    156

    Acer Travelmate Internal Mic not working

    Hi!

    So far I have got to say, Ubuntu is a real pleasure to use. When I remember my earlier attempts (years ago) in Linux the situation is so much better now.

    Anyway one little thing is bothering me and that's the internal microphone in my TravelMate 8104. The speakers worked out of the box, only Skype didn't like them so much, so I installed the PulseAudio stuff (http://www.ubuntugeek.com/sound-solu...nty-users.html) and indeed Speakers are doing just fine everywhere.
    Now my laptop has two possible input sources, the first one is a simple mic jack and the other one the built-in mic. Unfortunately I don't have an external mic so I have to rely on the built-in one. I already tried different settings (there I have a switch for Front Mic) in my volume control when capture was set to Alsa (which I updated to v1.0.20). In the PulseAudio Volume Control I only have one input device and this clearly is the mic jack (touching it with my headphones jack it gives me signals).

    Now a few bits of information.
    lspci | grep Audi:
    Code:
    00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
    Ubuntu v9.04

    If you need more information, feel free to request.

    Thanks in advance,
    Arno

    P.S: This might also be related to: https://bugs.launchpad.net/linux/+bug/280644

    [edit]Problem solved completely[/edit]

    [edit]Karmic Koala: http://ubuntuforums.org/showpost.php...2&postcount=11[edit]
    Last edited by Azrael3000; November 1st, 2009 at 11:09 AM. Reason: Karmic Solution

  2. #2
    Join Date
    Jun 2009
    Beans
    156

    Re: Acer Travelmate Internal Mic not working


  3. #3
    Join Date
    Jun 2009
    Beans
    156

    Re: Acer Travelmate Internal Mic not working

    alright. After searching more I finally clicked the right link. Suprisingly enough it's here on the forum.

    http://ubuntuforums.org/showpost.php...25&postcount=7

    So don't choose the acer model but the 6stack-digout.

    On my laptop this resulted in horrible Feedback if my cans weren't plugged in. To cope with that I reduced front-mic volume to 0 and mic volume to 100 (in alsamixer). Input Source has to be Front Mic.

    A help for noobs (like me) press <ctrl><tab> once you are in alsamixer to see all settings.

    I also followed this guide to set up PulseAudio: http://www.ubuntugeek.com/sound-solu...nty-users.html
    works like a charm.

    The only thing that's left for me is Skype (working - see edit @ bottom of post). At the moment I can't select PulseAudio as option in Sound-In/Out or Ringing. I know that I was able to do it a few days ago and I think the problem should be solved by that. I will report back on that.

    Thx to everybody (especially daimadoshi85 & markbuntu)
    Arno

    //Edit:
    Okay Skype is now working to.
    I did:
    2. Then edit or create your asound.conf file

    sudo gedit /etc/asound.conf

    and add the following lines. Click save once added.

    pcm.pulse {
    type pulse
    }
    ctl.pulse {
    type pulse
    }
    pcm.!default {
    type pulse
    }
    ctl.!default {
    type pulse
    }

    3. Edit libao.conf.

    sudo gedit /etc/libao.conf

    and add the line below

    default_driver=pulse
    http://www.blog.arun-prabha.com/2008...tup-in-ubuntu/

    and in the Skype Options I used:
    Sound-in: HDA Intel (hda:intel,0)
    Sound-out/Ringing: Pulse

    Only sound quality remains a small issue.
    Last edited by Azrael3000; June 10th, 2009 at 09:57 PM. Reason: Update

  4. #4
    Join Date
    Jun 2009
    Beans
    156

    Re: Acer Travelmate Internal Mic not working

    I got one more small issue.
    When mic is turned on I get a little bit of constant noise in my speakers which is a bit anoying. So I want to configure a key to mute the mic channel for which in turn I need a terminal comand.

    Now using amixer I only have to controls there: master and capture. But capture actually isn't what I want to mute. Now in the graphical volume control I can switch between devices (i.e. go to HDA Intel (Alsa mixer)) where I then have loads of channels and there I can easily mute the mic.

    So basically the question is, how do I access this device from comand line. I found the -D option in amixer but I couldn't find out how to get a list of the available devices (or how HDA Intel (Alsa Mixer) is called there).
    Once I have an answer for that it should only be a mater of using set.

    Thanks in advance,
    Arno
    Warning! Ubuntu might cause smashed Windows. Are you sure you want to continue? [y/n] y

  5. #5
    Join Date
    Feb 2007
    Location
    /home/paris
    Beans
    688
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Acer Travelmate Internal Mic not working

    I'm guessing that this post hasn't helped resolve your problem?

    David.

    ps, I like your bump!
    Last edited by theDaveTheRave; June 19th, 2009 at 08:26 AM. Reason: Oops, bad link!
    Eee pc via Wubi install.
    evertying works straight out of the box

    My Launchpad page

  6. #6
    Join Date
    Jun 2009
    Beans
    156

    Re: Acer Travelmate Internal Mic not working

    you got something wrong in your ctrl+v
    Warning! Ubuntu might cause smashed Windows. Are you sure you want to continue? [y/n] y

  7. #7
    Join Date
    Jun 2009
    Beans
    156

    Re: Acer Travelmate Internal Mic not working

    haha nice one dave

    anyway good time for a bump (although I won't reply before late Sunday).

    Cheerio
    Warning! Ubuntu might cause smashed Windows. Are you sure you want to continue? [y/n] y

  8. #8
    Join Date
    Feb 2007
    Location
    /home/paris
    Beans
    688
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Acer Travelmate Internal Mic not working

    AS I said, a totaly non helpfull response.

    did you ever get any joy on your microphone or is it still outstanding?

    I only ask as I had a problem with my acer, I sent it back to them for repair.

    It was producing "feedback" type noise as soon as the unit was turned on, and wasn't even getting through the POST test thing.

    Acer decided that it was an issue with the "un supported" os (ie ubuntu) and refused to fix it.
    Surprisingly however, when I got it back it no longer made this horrid noise... but the microphone hasn't worked properly since.

    I may have to invest in a USB microphone (or headset).... if I can get one that is?

    So my suggestion... a little more helpfull than the original post, have you tried a live CD to see if it will work?

    David
    Eee pc via Wubi install.
    evertying works straight out of the box

    My Launchpad page

  9. #9
    Join Date
    Jun 2009
    Beans
    156

    Re: Acer Travelmate Internal Mic not working

    Dave, as I said I also get the feedback, but it's quite easy to fix:
    On my laptop this resulted in horrible Feedback if my cans weren't plugged in. To cope with that I reduced front-mic volume to 0 and mic volume to 100 (in alsamixer). Input Source has to be Front Mic.
    Now the only thing that is left to do is noted here:
    http://ubuntuforums.org/showthread.p...92#post7447392

    But I'll probably open a new thread anyway because this one is kinda confusing.
    Warning! Ubuntu might cause smashed Windows. Are you sure you want to continue? [y/n] y

  10. #10
    Join Date
    Jun 2009
    Beans
    156

    Re: Acer Travelmate Internal Mic not working

    Okay I could finally figure out which commands to use

    when I started amixer I got PulseAudio as card, which was not what I wanted, so I used amixer -c 0 to get to my real soundcard. Now I created a file called mictoggle.sh which looks like:
    Code:
    #!/bin/sh
    amixer -c 0 set 'Mic' toggle
    copied the file into /bin and created a new shortcut in System->Preferences->Keyboard Shortcuts which uses as command
    Code:
    mictoggle.sh
    asigning a key to that et voilá.
    Warning! Ubuntu might cause smashed Windows. Are you sure you want to continue? [y/n] y

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •