Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 36

Thread: mpd with mcp, ncmcp, ncmpc++

  1. #21
    Join Date
    Aug 2007
    Beans
    65

    Re: mpd with mcp, ncmcp, ncmpc++

    groups mpd still showed 'audio' only. Ran the line you mention, but it still is 'audio' only when doing groups mpd...

    The thing is, before changing things from the website you mention, I managed to 'completely remove' mpd, mpc, ncmpc, and ncmpcpp, and reinstalled all of them, so all of this is happening on a fresh install of mpd!

    Well, settling on a media player would be good. I didn't know, though, that it would be this problematic, considering how popular the player is.

    I guess it also doesn't help that I'm fairly new to linux so still don't know my way around!

  2. #22
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    Ya linux can be frustrating like that sometimes. mpd worked for me "out of the box" really! Some programs seem to work perfectly for some and cause awful trouble for others!

    Post up the log files I mentioned anyway, they might help.

    As for the group thing, there must not be a group called mpd, because other wise it would have been listed in /etc/group when you did the other command.

    Try "sudo groupadd mpd"
    and then the usermod command to add mpd to that group. It might not make any difference, but worth a try.
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

  3. #23
    Join Date
    Aug 2007
    Beans
    65

    Re: mpd with mcp, ncmcp, ncmpc++

    Hi, here they are! doing the groupadd changed nothing, as 'groups mpd' still returns audio only.

    mpd.log

    Jun 08 15:14 : Avahi: Service 'Music Player' successfully established.
    Jun 08 16:04 : Avahi: Service 'Music Player' successfully established.
    Jun 08 16:16 : Avahi: Service 'Music Player' successfully established.

    mpd.error

    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    [WARN 11595] polkit-session.c:144olkit_session_set_uid(): session != NULL
    Not built with -rdynamic so unable to print a backtrace
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    [WARN 11737] polkit-session.c:144olkit_session_set_uid(): session != NULL
    Not built with -rdynamic so unable to print a backtrace
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    Jun 08 16:16 : can't find alsa mixer_control "PCM"
    Jun 08 16:16 : using software volume
    Jun 08 16:16 : Error opening ALSA device "hw:0,0": Device or resource busy
    Jun 08 16:16 : problems opening audio device while playing "7/Parsifal1.ape"
    Jun 08 16:16 : problems opening audio device while playing "7/Parsifal1.ape"
    Jun 08 16:16 : Error opening ALSA device "hw:0,0": Device or resource busy
    Jun 08 16:16 : problems opening audio device while playing "7/Parsifal1.ape"
    Jun 08 16:16 : problems opening audio device while playing "7/Parsifal2.ape"
    Jun 08 16:17 : Error opening ALSA device "hw:0,0": Device or resource busy
    Jun 08 16:17 : problems opening audio device while playing "7/Parsifal2.ape"

  4. #24
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    lol at smileys in log file!

    Ok, loads of errors there. It seems the problem is with alsa. Did you try closing all other media players, like mplayer and restarting mpd? See if that helps. alsa controls the sound on your computer. I think the reason id something to do with whether your sound card supports hardward mixing.


    After the groupadd, you still have to run "sudo usermod -a -G mpd mpd" then groups command should show both audio and mpd. As I said, I doubt that's the problem.
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

  5. #25
    Join Date
    Aug 2007
    Beans
    65

    Re: mpd with mcp, ncmcp, ncmpc++

    Hi, ok, now I get audio mpd for 'groups mpd'. I killed mpd again, mplayer isn't playing, tried restarting, and get the same issue (i.e. now it doesn't actually even play, it hints at starting and then stops). No sound either.

    Does mplayer not use ALSA? I mean, how can I get sound from mplayer, aqualung, gmusicbrowser, audacious (i.e. a rather big range of players, I don't know what program they use)?

    Sorry about the smileys!

  6. #26
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    Think this is the same problem:
    https://bugs.launchpad.net/ubuntu/+s...pd/+bug/192735

    Maybe try John Smith's solution a bit down the page,
    audio_output {
    type "pulse"
    driver "esd"
    options "host=localhost"
    name "esd"
    }
    change settings to that in your mpd.conf file. I think it seems to be a ubuntu problem judging from the comments on that page.
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

  7. #27
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    I'm not 100% sure tbh, as I said I remember sometimes if I had more that one audio player open I used to have problems under ubuntu. Wouldn't be an expert on it anyway!

    Maybe someone else knows more about it? I'm using alsa on this computer (arch linux), and everything plays fine.

    Edit: http://www.musicpd.org/forum/index.php?topic=1587.0 here's another thread on the same problem (I think).
    Last edited by dioltas; June 8th, 2009 at 05:27 PM.
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

  8. #28
    Join Date
    Aug 2007
    Beans
    65

    Re: mpd with mcp, ncmcp, ncmpc++

    Hi, thanks again for your ongoing help! I have changed mpd.conf with those settings. Now, ncmpc seems to be playing again, with no sound! As a probably meaningless note, the time passes by in jolts, sometimes two seconds at a time...

    I tried the paplay /usr/share/sounds/alsa/Front_Center.wav thing mentioned in the launchpad page you mention, and it works. I'm getting really confused...

  9. #29
    Join Date
    Jul 2008
    Location
    Éire
    Beans
    88

    Re: mpd with mcp, ncmcp, ncmpc++

    Maybe try step 3 here.

    Quote Originally Posted by http://www.musicpd.org/forum/index.php?topic=1587.0
    1. I apt-get installed mpd
    2. set type "pulse" as audio output
    3. edit /etc/pulse/default.pa and add
    load-module module-native-protocol-tcp auth-anonymous=1
    this gives permission to everybody to use pulse.
    4. start mpd
    5. play music


    So mpd is just fine.
    Mpd should be set up to use pulse after the last step you did. Maybe post up your mpd.error file again and see what it's saying now. Not sure why the time is like that now...
    To be human is to affirm one's humanity by recognizing the humanity of others and, on that basis, establish respectful human relations with them.

    Ubuntu User 24011

  10. #30
    Join Date
    Aug 2007
    Beans
    65

    Re: mpd with mcp, ncmcp, ncmpc++

    No luck still! No sound...

    Here's mpd.error:

    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    [WARN 11595] polkit-session.c:144olkit_session_set_uid(): session != NULL
    Not built with -rdynamic so unable to print a backtrace
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    [WARN 11737] polkit-session.c:144olkit_session_set_uid(): session != NULL
    Not built with -rdynamic so unable to print a backtrace
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    Jun 08 16:16 : can't find alsa mixer_control "PCM"
    Jun 08 16:16 : using software volume
    Jun 08 16:16 : Error opening ALSA device "hw:0,0": Device or resource busy
    Jun 08 16:16 : problems opening audio device while playing "7/Parsifal1.ape"
    Jun 08 16:16 : problems opening audio device while playing "7/Parsifal1.ape"
    Jun 08 16:16 : Error opening ALSA device "hw:0,0": Device or resource busy
    Jun 08 16:16 : problems opening audio device while playing "7/Parsifal1.ape"
    Jun 08 16:16 : problems opening audio device while playing "7/Parsifal1.ape"
    Jun 08 16:17 : Error opening ALSA device "hw:0,0": Device or resource busy
    Jun 08 16:17 : problems opening audio device while playing "7/Parsifal1.ape"
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    [WARN 12651] polkit-session.c:144olkit_session_set_uid(): session != NULL
    Not built with -rdynamic so unable to print a backtrace
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    Jun 08 17:16 : can't find alsa mixer_control "PCM"
    Jun 08 17:16 : using software volume
    Jun 08 17:17 : Error opening ALSA device "hw:0,0": Device or resource busy
    Jun 08 17:17 : problems opening audio device while playing "7/Parsifal1.ape"
    Jun 08 17:17 : problems opening audio device while playing "7/Parsifal2.ape"
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    [WARN 12871] polkit-session.c:144olkit_session_set_uid(): session != NULL
    Not built with -rdynamic so unable to print a backtrace
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    Jun 08 17:27 : can't find alsa mixer_control "PCM"
    Jun 08 17:27 : using software volume
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    I: caps.c: Dropping root privileges.
    I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
    [WARN 13041] polkit-session.c:144olkit_session_set_uid(): session != NULL
    Not built with -rdynamic so unable to print a backtrace
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    Jun 08 17:37 : can't find alsa mixer_control "PCM"
    Jun 08 17:37 : using software volume
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    No protocol specified
    E: client-conf-x11.c: XOpenDisplay() failed
    I've also tried with other file formats (just in case it was having issues with ape), but still the same.

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •