Results 1 to 5 of 5

Thread: Unable to access shared folders

  1. #1
    Join Date
    Jul 2008
    Beans
    1

    Cool Unable to access shared folders

    I have samba installed on my main Ubuntu desktop with the sharing option enabled for the folders I want to share.

    My Vista laptop cannot access the shared files. It shows the Ubuntu desktop on the network device window, but when I try to double click on the icon,I get a message that says Windows cannot access the Ubuntu desktop. The details arrow shows that the network path was not found.

    This has me totally confused since all I want to do is access certain /home folders using my laptop. Please advise.

  2. #2
    Join Date
    Jun 2007
    Location
    Greater Boston
    Beans
    1,586
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to access shared folders

    Quote Originally Posted by rrroninnn View Post
    I have samba installed on my main Ubuntu desktop with the sharing option enabled for the folders I want to share.
    .
    .
    .
    I am confused as to what the "sharing option" is.
    cmn

  3. #3
    Join Date
    Nov 2006
    Location
    Montreal, Canada
    Beans
    485
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Unable to access shared folders

    Quote Originally Posted by cmnorton View Post
    I am confused as to what the "sharing option" is.
    In Nautilus. Right-click -> Sharing Options. Always seems to cause problems and I'll never understand why people use this over proper shares defined in smb.conf.

  4. #4
    Join Date
    Jan 2007
    Beans
    5,549

    Re: Unable to access shared folders

    in your ubuntu terminal type smbtree and post output.. in windows go to windows explorer and type \\x.x.x.x where x.x.x.x is the ip of the ubuntu machine.. that should hopefully give you list of shares..

  5. #5
    Join Date
    Apr 2008
    Beans
    1

    Re: Unable to access shared folders

    Sorry for necro-ing this thread but I thought I'd share the solution I found to this elsewhere in the forum (where I don't seem to have sufficient privileges to post).

    With the same problem as the OP I came upon this thread (links to the page containing the solution): http://ubuntuforums.org/showthread.php?t=737664&page=3. This got me trying various permission configurations for "other" users (since adjusting group permissions would be useless without changing the group of a share, which one might not always want to do).

    The generic (but complex) resolution to this problem is that the user trying to access a share must also have sufficient privileges to traverse the parent directories (though not necessarily read the files in those directories).

    In the specific case of guest access to a share in a user's home directory: The "execute" permission for "other" users needs to be set on the home directory.

    Code:
    chmod o+x /home/user
    Even the 10.04 "Lucid" Nautilus filesharing GUI doesn't seem to ensure this automagically when you enable sharing for the first time.

    I'll write a blogpost about how to do this with just the GNOME GUI and link to it from here later.
    Last edited by eckie; July 4th, 2010 at 04:49 PM. Reason: Added link to thread that got me looking at this solution

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •