Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Modem is not detected

  1. #11
    Join Date
    Aug 2007
    Beans
    1,211

    Re: Modem is not detected

    M Star,
    The reason that www.linmodems.org isn't accepting your emails is
    that they are not in PLAIN ASCII TEXT. Marvin and those folks will
    ONLY accept PLAIN TEXT. Just change your format in your email
    to Plain Text. Problem solved!

    Then forward your results from running scanmodem script and
    Marvin & Company will assist you. But, your at least 3-4 days
    from getting some sort of answer, and then there is the remote
    possibility that it will never work.....meaning you have wasted
    a week or more fiddling.

    I'd recommend:

    Why don't you search ebay for an External US Robotics Hardware
    Modem (56K) and just use it. Plug it in to AC Power, connect to
    your serial port (or a USB to Serial Adaper) and run the following
    from a Terminal (wvdial is used from a Terminal Window).
    Code:
    sudo wvdialconf /etc/wvdial.conf
    From this point you can start from the guide I posted way back in
    a previous listing. (It might be a good idea to go back and re-read
    those postings at a much slower pace........speed reading always gets
    me because I gloss over a step.)

    If you need a USB to Serial adapter I recommend the Sabrent USC1M
    model. I know they work and are less than $10.00, Newegg or TigerDirect.

    As I posted before in 30 minutes you should be online using this
    method. Once you have wvdial working you can use Gnome-PPP and run
    everything from the GUI.

    Keep us informed as to how it is going. Good Luck!

    lkraemer
    Last edited by lkraemer; June 19th, 2009 at 03:46 PM. Reason: Added URL.

  2. #12
    Join Date
    Apr 2009
    Location
    Dhaka, Bangladesh
    Beans
    23
    Distro
    Ubuntu 13.04 Raring Ringtail

    Post Re: Modem is not detected

    Quote Originally Posted by Sealbhach View Post
    You probably won't find it in the menu, you will need to run it from the terminal. Put this command in the terminal and see what happens (copy and paste the response you get here):

    Code:
    sudo wvdialconf
    You'll find the terminal in the Applications/Accessories menu.


    .
    Here's what I did and what I got

    Code:
    sudo wvdial config
    
    WvDial: Internet dialer version 1.60
    Warning: section [Dialer config] does not exist in wvdial.conf.
    Cannot open /dev/modem: No such file or directory
    Cannot open /dev/modem: No such file or directory
    Cannot open /dev/modem: No such file or directory
    Code:
    sudo wvdial
    
    WvDial: Internet dialer version 1.60
    Cannot open /dev/modem: No such file or directory
    Cannot open /dev/modem: No such file or directory
    Cannot open /dev/modem: No such file or directory
    Code:
    /etc/wvdial.conf
    
    /etc/wvdial.conf:
    line 1: [Dialer: command not found
    /etc/wvdial.conf: 
    line 2: Phone: command not found
    /etc/wvdial.conf: 
    line 3: Username: command not found
    /etc/wvdial.conf: 
    line 4: Password: command not found
    /etc/wvdial.conf: 
    line 5: New: command not found
    The attached file is my scan_Modem.gz results.
    And as I live in Bangladesh there's not much facillities to but things online and after all I don't want to invest any more money on dial-up modem cuz WiMax is coming here next year (maybe); I just want my modem to work on ubuntu in the meantime.
    Attached Files Attached Files
    Last edited by M Star; June 25th, 2009 at 11:55 AM.

  3. #13
    Join Date
    Aug 2007
    Beans
    1,211

    Re: Modem is not detected

    Please use cut and paste to copy the commands, this will
    correct any issues of trying incorrect commands.

    The correct command for the configuration of wvdial is:
    Code:
    sudo wvdialconf /etc/wvdial.conf
    That should allow you to get you started on the guide, and
    your External hardware modem should be working in less than
    30 minutes.


    OK, It looks as if your modem might be capable to work.
    from your posting:
    Start at http://www.linuxant.com/drivers/hsf/...ds-license.php to find the
    hsfmodem package matching your System. For several Linux distros, there are
    precompiled drivers matched to specific kernels. These have within the FileName,
    your KernelVersion: 2.6.28_11_generic
    They can be found through http://www.linuxant.com/drivers/hsf/full/downloads.php
    A more precise location may be given a few paragraphs below.
    If an EXACT Match with your your KernelVersion is not found, one of the
    "Generic packages with source" near the bottom of the page must be used.
    Downloaded packages must be moved into the Linux partition (home folder is OK)
    and unzipped with:
    unzip hsf*.zip
    The installation command for a .deb suffic packages is, with root/adm permission:
    sudo dpkg -i hsf*.deb
    while for .rpm suffix it is, with:
    rpm -i hsf*.rpm
    From http://www.linuxant.com/drivers/hsf/...ubuntu-x86.php
    download hsfmodem-7.80.02.02full_k2.6.28_11_generic_ubuntu_i386.deb. zip
    Under Linux unpack with:
    $ unzip hsfmodem*.zip
    Then install with:
    $ sudo dpkg -i hsfmodem*.deb
    Subsequently, the modem should be found with
    $ sudo wvdialconf /etc/wvdial.conf
    Edit in your personal information with:
    $ sudo gedit /etc/wvdial.conf
    and try dialing out with:
    $ sudo wvdial.
    See DOCs/Testing.txt for details.

    Read DOCs/Conexant.txt


    You also need to do this after wvdial is installed and
    after pppconfig is executed:
    To enable dialout without Root permission do:
    $ su - root (not for Ubuntu)
    sudo chmod a+x /usr/sbin/pppd
    or under Ubuntu related Linuxes
    sudo chmod a+x /usr/sbin/pppd

    Checking settings of: /etc/ppp/options
    asyncmap 0
    noauth
    crtscts
    lock
    hide-password
    modem
    proxyarp
    lcp-echo-interval 30
    lcp-echo-failure 4
    noipx


    Once you get wvdial installed & functional, then install Gnome-ppp with Synaptic
    Package manager, and set it up.

    So, you need to do these steps:
    1. Install wvdial
    2. Configure wvdial with the modem installed and powered "ON",
    or with the proper drivers installed if you are still trying
    to use the Winmodem. (Please contact Marvin & Co for their
    excellent support as it is his script that has helped us so far
    for the Winmodem.)
    3. configure pppconfig
    4. VERIFY the pppconfig file and also pap-secrets and/or chap-secrets
    in /etc/ppp
    5. Add your specific login into info to /etc/wvdial.conf
    6. Correct the permissions for pppd.
    7. wvdial in a Terminal Window will Dialout. (Leave the Terminal Window
    Open, and issue a CNTL C to terminate the session. You may have to
    Open Firefox and uncheck OFFLINE, to be able to browse the internet.)
    8. Setup Gnome-ppp
    9. If using the Winmodem you may have to re-install the drivers when a
    Kernel upgrade is downloaded,....I forget.


    lk
    Last edited by lkraemer; June 25th, 2009 at 01:01 PM. Reason: Added Steps.

  4. #14
    Join Date
    Apr 2009
    Location
    Dhaka, Bangladesh
    Beans
    23
    Distro
    Ubuntu 13.04 Raring Ringtail

    Talking Re: Modem is not detected

    Thanks!!!
    I installed the HSF driver and gnome-ppp. And now I am online with Ubuntu. Thanks Thanks Thanks.




Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •