I've folllowed this
1. Find out the 'Workgroup' your windows computer(s) are on

a. Right click computer on start menu (vista) or my computer (xp) and select properties

b. Workgroup is listed in section 'Computer name, domain, and workgroup settings'

2. Install samba on ubuntu, sudo apt-get install samba
3. Edit smb.conf to reflect your proper workgroup name found on windows machine, restart samba

a. gksudo gedit /etc/samba/smb.conf

b. sudo /etc/init.d/samba restart

4. Create a samba user and password

a. sudo smbpasswd -a <YOUR_USERNAME>

b. this will prompt you to create a pasword for the user


Your computer should be recognized on the network now, use your windows login credentials to access windows shares, and your smbpasswd login info you created for windows-to-linux connections.

In nautilus (file browser) you can easily right click the folder and select 'Sharing options' granted you have the correct file permissions for the folder you wish to share. Anything under the home directory should be easily shared. When you create your first shared file it may prompt to install packages required for sharing, make sure you follow through.


Mentioned by mattgyver83
over here
as of now I see ROAD-RUNNER in my network but still the same error persists i.e Failed to retreive share list from server