Results 1 to 7 of 7

Thread: How-To Jaunty KDE ATI Dual Monitors

  1. #1
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    How-To Jaunty KDE ATI Dual Monitors

    If you have an RV200-RV500 card and cannot use fglrx please see the next post. bmcage has kindly posted directions for getting your big desktop back using the open source drivers. If you are using flgrx on Jaunty you can read this:

    I have been trying to get a big desktop working with KDE on Jaunty with my HD3650 card for a while now and I finally figured it out so I thought I would share what I learned.

    First of all I found no way in KDE setting to enable dual monitors using the open source radeon or radeonhd driver. The options do not exist for me. The KDE docs say they do but they do not. I could set a big desktop with randr in Gnome by unchecking clone but that does not work with KDE.

    Sooo, I finally knuckled under and installed fglrx. It was a mess. First of all it did not configure itself properly when I rebooted. The resolutions were all screwy and the Catalyst Control Center did not seem to operate properly. It seems that all that happened was that fglrx replaced radeonhd in xorg.conf. Soo.....
    Code:
    aticonfig --initial -f
    and another x restart made some progress with that. But still no option for big desktop. In fact no options at all for Multiple Displays so I tried aticonfig --dtop=horizontal,reverse and got a message that this command could not be used while randr is installed or something like that.

    RandR is the problem so I disabled it like this in xorg.conf

    Code:
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	Option	    "EnableRandR12" "false"
    	BusID       "PCI:1:0:0"
    EndSection
    another x-restart and then opened Catalyst Control Center and everything works like it should, resolution picking worked and Multi Display let me set my big desktop. One more x restart and YAY!!! Big desktop on KDE!!! with effects...

    and gnome with compiz and none of that screwy full screen action filling both monitors which btw you can get rid of with setting

    Code:
    Section "ServerFlags"
    	Option	    "Xinerama" "off"
    EndSection
    Enjoy.

    Thanks to the folks at the Mandriva and SUSE forums for sharing the critical info to get this figured out. btw, this also works in Mandriva One 2009.1 KDE which is where I first got it working and thanks to bmcage for following with directions for using open source drivers for those unable to use fglrx.

    mark
    Last edited by markbuntu; May 28th, 2009 at 08:37 PM.
    PMs will be ignored.

  2. #2
    Join Date
    Oct 2005
    Location
    Ghent, Belgium
    Beans
    55
    Distro
    Kubuntu 8.04 Hardy Heron

    Re: How-To Jaunty KDE ATI Dual Monitors

    Only new ATI cards can use the fglrx driver.
    Big desktop on older cards with all desktop effects is not difficult though. All that is needed:

    1. no fglrx driver, with
    Code:
    dpkg-reconfigure -phigh xserver-xorg
    you again use the default driver, which should be ati or radeon

    2. Unfortunately, there is a nasty bug in the ubuntu kernel with ati, so you need to downgrade or upgrade the kernel, see launchpad bug. So I got a newer kernel. Only do this as long as the launchpad bug is not fixed.

    3. Now you run on the terminal xrandr to determine your outputs.
    Code:
    xrandr -q
    4. Now update your xorg.conf using the outputs to have a big desktop. My xorg.conf is:

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Monitor"
    	Identifier	"VGA"
    EndSection
    
    Section "Monitor"
    	Identifier	"DVI"
            Option "RightOf"  "VGA"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
            Option          "Monitor-VGA-0" "VGA"
            Option          "Monitor-DVI-0" "DVI"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    
    	SubSection "Display"
                Depth           24
    	    Virtual	2048 768
    	EndSubSection
    EndSection
    Note in the above that my identifiers for xrand are VGA-0 and DVI-0, you should replace it with your idents (Specifically "Monitor-VGA-0"). Furthermore, you must set the Virtual key to the maximum big desktop you want to create. And one Monitor section must contain a RightOf, ... setting.

    That is it. I have the impression for my card (ATI Technologies Inc RV515 PRO [Radeon X1300/X1550 Series]) the KDE 4.2 desktop is snappier than with fglrx under Kubuntu 8.10. But then, it could be the newer kernel.

    Well, I would try it. It is an easy xorg.conf to have, and it would be shame to use fglrx if the radeon driver works just as good. Best of all is that you can do bug submissions for those drivers. And you can improve performance by taking the latest stable drivers from the swat ppa

  3. #3
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How-To Jaunty KDE ATI Dual Monitors

    Well yes, older cards are not supported by fglrx in Jaunty so thanks for posting that so people who cannot use flgrx can get their big desktop back.

    I tried a lot of things before succumbing to using fglrx myself including kernel 2,6,29 but still had no luck. There is no 3D support in the open source drivers yet for newer cards like mine. That is not really a big deal for me but having a big desktop is. Even after I set up xorg.conf for a big desktop with the open source driver KDE would not unclone. It was weird and frustrating since I could get a big desktop easily with gnome usinf randr which reconfigured my xorg.conf.

    Hopefully I can go back to the open source drivers soon.

    regards,
    mark

    EDIT: If you want to get the latest open source ati drivers there is a how to here

    http://ubuntuforums.org/showthread.php?t=1164013
    Last edited by markbuntu; May 29th, 2009 at 02:53 AM.
    PMs will be ignored.

  4. #4
    Join Date
    Feb 2009
    Beans
    215
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: How-To Jaunty KDE ATI Dual Monitors

    sounds great guys!

  5. #5
    Join Date
    Aug 2008
    Beans
    3

    Re: How-To Jaunty KDE ATI Dual Monitors

    Just to document my experience:

    I'm using an HD3850 which is dual-headed. I spent a lot of time getting it working properly using fglrx, but when I upgraded to Jaunty my setup was trashed and I lost the dual monitor setup.

    In the end I followed a path similar to the initial post.

    I had to reset the database with
    sudo aticonfig --initial=dual-head
    Then I used
    xrandr -q
    to list the modes from my monitors (more about this later.)

    Then I turned off randr using the Option described above. In Jaunty,starting RandR would hang my PC usually, but not always, in any case, so this hasn't been a loss.

    Once I'd done this I was able to run Catalyst, but one of my monitors was still blank.

    I fixed this by re-adding the pairmodes that my monitors support (i.e. the configurations that make a pair of screens match nicely in resolution). First listing to see what was set by default:
    aticonfig --list-pairmode
    Then having found out that the default pairmode was
    1600x1200 + 1600x1200 --> 3200x1200
    and knowing that the blank monitor doesn't support 1600x1200, I added a new mode:
    sudo aticonfig --add-pairmode=1280x1024+1280x1024
    After this I was able to use Catalyst to switch to the new resolution, which made the second screen work.

    Then I was able to remove the 3200 pairmode.

    -----------

    Note on xrandr: for one of my monitors it doesn't list all the modes that the monitor supports. It took finding and reading the monitor documentation to discover this.

  6. #6
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How-To Jaunty KDE ATI Dual Monitors

    Adding parimodes is a pretty common thing that is necessary to get two monitors working, especially when they are of different sizes so thanks for adding that.

    One good place to look for monitor resolutions is in /var/log/Xorg.0.log where the driver will list all the resolutions for every monitor it can detect.
    PMs will be ignored.

  7. #7
    Join Date
    Dec 2006
    Beans
    28
    Distro
    Kubuntu

    Re: How-To Jaunty KDE ATI Dual Monitors

    thank you...disabling randr in xorg did it for me on the latest drivers...muchly appreciated!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •